Password not accepted after screen lock: "The account is locked due to 3 failed logins". (luks issue?)

I’m running Manjaro 20.1 on the latest 5.8 kernel with Gnome on my Ryzen Thinkpad T14 perfectly fine but i have one strange problem. I’ve set my laptop to lock the screen whenever my display goes blank. But whenever i try to unlock it won’t accept my password and i’m 100% positive that i’m typing it correctly.

I did an install using Architect and i did nothing out of the ordinary except for my partitions. I have the following partitions

  • /boot        FAT32 (unencrypted)
  • /            Volume Group  (/dev/mapper/cryptroot)(luks encrypted)
  •              /dev/mapper/lvg-root          ext4
  •              /dev/mapper/lvg-swap          linuxswap

The encrypted volume group has 2 volumes. 1 ext4 volume for root and 1 volume for swap. I wanted to have a unencrypted boot volume to speed up to boot process. Not sure if this is related to my login problem but i have hunch that it is.

Its PAM not luks. Luks has nothing to dow with authentification at user-session level.
I have the problem as well - i SUSPECT that despite not being in use my fingerprint reader on my T490 does “register” but wrongly and thus if my palm rests on it PAM detects failed logins.

I will go ahead, and because I don’t use it, deactivate the fingerprint reader in the UEFI

1 Like

Thanks for your reply! I guess i’ll do the same and disable the fingerprint reader since i’m not using it anyway. Hopefully that’ll be the solution.

@Th3Z0ne: I haven’t had the same problem since your solution. I’m not 100% sure if it solved the problem but i’m beginning to think that it did.

1 Like

I had the same problem. I disabled the fingerprint on the bios and resolved the issue


1 Like

Not truely a fix for sure - its a work around. The fingerprintreader should not be read if not configured at all. Turning it off in UEFI is more a hack - but it works.

Guys, I had the same problem. I wrote down my password and when I tried to login again, I was simply informed that something went wrong.
I used the advanced feature of Manjaro, and changed my password to be able to login again, but I still can’t access it. Even changed my password, the system not accepted it.

I’m getting the same with a fresh install of Manjaro. When I lock the screen manually and quickly unlock it, everything works fine. But if the screen locks due to a timeout, it switches to a dvorak keyboard layout, which trips up my password entry (since I have a y in my password which is now in the z position). I can confirm this by bringing up the virtual keyboard, which reflects the dvorak layout.

I don’t use dvorak. I only have EN-UK installed as a locale. I have no idea what’s happening here.

Even more infuriating, Manjaro appears to be configured to lock the account after 3 failed login attempts. Not sure what the point of that is on a single-user system, but I had to edit /etc/security/faillock.conf to bump this up to 3000 so it doesn’t affect me (see: Account gets locked for 10 minutes after 3 failed attempts).

Edit: just to add, there’s no fingerprint reader involved here. My PC is an off-the-shelf desktop unit.
Edit2: Seems to be affecting a few folk, although this link is also fingerprint related: Getting locked out for "3 incorrect attemts" even though there were 2 and the password was correct

It’s from upstream. That’s the default configuration shipped by Linux-PAM.

  1. Not every system is a single-user system, for example mine are not.
  2. This is a (sane) default by upstream - everybody can change it if they so choose.
  3. setting deny = 0 will disable this entirely, see Security - ArchWiki

Hello, not sure this is the right place to ask. I get the ‘logging failed’ regularly ( KDE kernel 5.9.11-3) Is there a easy cure for an eternal newbie? step by step if possible?
Thank you

I did this.

Ctrl alt f2.
Baam. Inside.

It is a bugg. Not sure what causes it.