Fslint-gui searches do not work

Hi there,
after installing fslint and trying my first search the program would complain, that ist cant find:
the last directory was missing, so i created it manually.
Now when I want to search for dupliactes i get:
“/bin/sh: Zeile 1: ./findnl: Datei oder Verzeichnis nicht gefunden”
and similar lines searching for Bad Names etc.

any idea how to fix this?
Thanks for reading

AUR package - consult the maintainer

Hi @FluffyMcDuckface, and welcome!

According to this page, the full error was probably something like:

Traceback (most recent call last): File “/usr/bin/fslint-gui”, line 27, in import gtk ImportError: No module named gtk

But there’s no way to be sure, and without more information, we’re shooting in the dark here. Please see [HowTo] Provide System Information, [HowTo] post screenshots and links and [HowTo] Increase your chances of solving your issue for more information and help to provide the required information.

What did you actually install?

How did you install it?
(because just did - and it works for me no problem …)

What command did you use here - to get this output/this message?

Please start the program from a terminal - and like this:
LANG=C fslint
LANG=C fslint-gui
so that the output will be in english.

I installed
I used Pamac, with the graphical UI
the GUI of fslint starts fine. I get the output after pressing “Find”

Trying to search Duplicates gets me:
/bin/sh: line 1: ./findup: No such file or directory
Bad names:
/bin/sh: line 1: ./findnl: No such file or directory
Name clashes:
/bin/sh: line 1: ./findsn: No such file or directory

I don’t know if its important:
starting fslint-gui from terminal with

LANG=C fslint-gui
works also, but shows also this:

(fslint-gui:12648): Gtk-WARNING **: 18:22:38.388: Unable to locate theme engine in module_path: “murrine”,

What I find strange is that all the error messages
(which I do not get)
are starting with:
/bin/sh: line 1: ...

even though all the scripts that the program uses are bash scripts
and all but one start with:

so I don’t know why /bin/sh is what the error starts with
(have you done something to your shell environment variable - aliased it to something …?
idk …)

Just something I noticed.

I have used this program before - it always worked nicely.
And I just installed it in this my installation, which did not have it yet.
and it works - as I’m used to.

Can’t really help - sorry.

I had the same problem and the issue was that I did only install fslint-gui. After installing fslint too, everything worked fine.



Don’t use fslint or fslint-gui anymore. :-1:

Use czkawka-gui-bin. :+1:

It’s available on the AUR.


the name is a bit … unintuitive
(it doesn’t readily give away what the program does/is for)
but, yes: right on!

Thanks, this worked. Strange that in fslint-gui it does not say anywhere that fslint needs to be nstalled…
Should be added as a dependency, but that is a job for the developer obviously.

You need to install both fslint and fslint-gui and then it works.