Copy paste problem - works every other time

Has someone experienced some copy/paste problem after last upgrade?

Using Manjaro KDE with Wayland.

Mostly using Vivaldi and VSCode and it drives me crazy.
Copy/paste works every other time 90% of the time.
Cut behaves the same as copy - broken.


  • copy stringA (it does not matter if I use Ctrl+C or right click Copy)
  • pastes : stringA
  • copy stringB
  • pastes : stringA <----- BUG - it should be stringB
  • copy again stringB
  • pastes : stringB

UPDATE: Clicking/pressing Copy multiple times like a madman does not solve the problem anymore.
It must be and odd number of clicks or key-presses.

copy 1 ## fails
copy 2 ## ok
copy 3 ## fails again - like it populates clipboard with an invalid value

Is this somehow linked to Electron or Wine (Ubuntu users have problems with Wine copy/paste) or something?

Note: copy/paste works OK in Kate.

OS/DE/kernel versions
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     OS: Manjaro 20.2 Nibia
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Kernel: x86_64 Linux 5.9.3-1-MANJARO
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Uptime: 6m
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ             β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Packages: 1521
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Shell: fish 3.1.2
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Resolution: 2560x2160
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     DE: KDE 5.75.0 / Plasma 5.20.2
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     WM: KWin
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     GTK Theme: Breath [GTK2/3]
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     Icon Theme: breath2
 β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ  β–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆβ–ˆ     

1 Like

I’ve experienced the same lately. Although I’m usinga Wayland session, so just thought it was another wayland quirk.

I am using Wayland also.
A colleague uses Gnome and has the same problem but only inside Wine apps.

This drives me crazy.
In which apps are you experiencing this?
Have you tried native DE apps? (e.g. Kate in my KDE setup)

Tried wine-git from AUR but same problem again (hopped it was wine related bug that affected global clipboard).

Mainly experienced from GTK apps (like firefox) and some times with Kate.

Another me too. Manjaro Gnome, and yes, Wayland.
Mostly I notice this when using Cherrytree. Often restarting Cherrytree seems to fix the glitch, but not always. Noticed in in other apps too but less frequently.

edit to add: I also use Clipit cliboard manager.

Been having this issue since last pamac update - so for 4 days now.
Every time I CTPL+c something, I have to do it at least 2 times.
I think it is everywhere… terminal, vscode, firefox, slack.
I use default whatever the clipboard is, default terminal.

Wayland, KDE plasma:
plasma-desktop 5.20.2-1
plasma-framework 5.75.0-1
plasma-wayland-session 5.20.2-1
kwayland 5.75.0-1
wayland 1.18.0-2

journalctl has these kinds of lines appearing intermittently:
xdg-desktop-portal-kde[72040]: xdp-kde-background: GetAppState called: no parameters
but they do not appear when β€œcopy” fails. Just every 30s this line is logged (probably not related?).


Just noticed that in firefox copy link location selected via mouse right click failed also on 1st try. On 2nd try it worked.
That indicates that this is a system wide bug.
Somehow any β€œcopy” command might get lost. System behaves as if β€œcopy” was done, but nothing appears in clipboard. Maybe some kinda race condition

I think next installation is back to Windows10 for me. WSL2 makes it into a mostly working OS again.

On Arch with i3wm I never had crap like this, but many small things didn’t work coz I couldn’t spend 1 year to figure some obscure configurations.
On Manjaro everything just worked (even full disk encryption out-of-the-box!) - except any update is a potential nightmare; this time broken copy-paste.

Oh man… Should there be a bug report done to some place?

Worst thing about this is CTRL+x, aka β€œcut”.
Line/text disappears as if β€œcut” happened ok, but then β€œpaste” doesn’t contain what was cut. Paste contains the previous thing on clipboard. β€œcut” content is completely lost.

1 Like

I’ve seen this β€˜every other’ copy working behavior but what I mostly experience is different.
Basically copy stops working in a particular app. Mostly cherrytree, but just happened in tilix too.

Workaround is restarting the problem app.

It’s definitely the copy part of copy-paste that is the issue, content just never reaches clipboard.

FFS… any updates anyone?

By now I’ve become accustomed to repeatedly smashing CTRL+c , but not having fun with it.
I’m considering taking a backup of my data and doing a full reinstall - can’t stop working though, so not sure when I’d find time for such an amazing endeavor.
Feels like back in Win95 days; have to be prepared to format harddisk at any time :smile:

Another thing.
Clicking/pressing Copy multiple times like a madman does not solve the problem anymore.
It must be and odd number of clicks or key-presses.

copy 1 ## fails
copy 2 ## ok
copy 3 ## fails again - like it populates clipboard with an invalid value

P.S. Latest update from 2020-11-18 does not solve anything.

I have experienced something like that also.
Hammering on copy results in empty paste.

But I get that intermittently. I cannot reproduce it now for example. Tried 3, 5, 7. Tried with different speeds also. Could not get it to happen.
Maybe 1 in 40 cases I get an empty buffer after copy hammering.

I’m having the same problem in Archlinux, KDE + Wayland

Trying live ISO 20.1.2 (Mikah) and copy works like it should (X11 + KDE).
At this point I think I will be making a fresh install probably (last 2 rolling updates did not solve this).

It is probably one bad package or config but I can’t figure out which.
If it is a config problem then a clean account should help - empty home with default configs. Will try this too before reinstall.

  • UPDATE: new account with default .config - same problem

UPDATE: I installed again from stratch. X11 works now OK (before I was forced to use wayland session - KDE + X11 did not work on my machine at all - could not get past the login screen)

This copy/paste problem is probably something specific to KDE + Wayland combination.

UPDATE: A friend has the same problem on Ubuntu 19 & 20 (Gnome+X11).

can somebody having copy paste issues with KDE (in some applications) have a look at my problems with LibreOffice Calc?

Is this the same / a related issue? The descriptions here sound a bit different than what I experience but I’m not too sure.

I experienced the same error using KDE + Wayland + Klipper on Arch. I could solve it by disabling the option β€œPrevent empty clipboard” in the Klipper settings. Please leave some feedback if this helps others as well, than I will create a bug report to Klipper.


No, this doesn’t help in my case. What’s funny is that tray element for clipboard does contain whatever I’ve copied, be it a screenshot or text.

I also tried playing with other options with no success as well. I have a feeling (which, as all we know, a thing one should not relay on) that issue raised after I’ve edited the configuration trying to deal with something else (clipboard content auto-deletion or auto-copying selection, I really don’t remember well).

I think (hope) my problems with this are resolved now. A few days ago I uninstalled Clippit clipboard manager in favour of gpaste. Doesn’t have quite the same functionality yet, but I’ve stopped having clipboard issues.

Thank you. It seems that worked in my case, too. (KDE Plasma 5.21.3-1 & wayland 1.19.0-1)

this setting doesn’t influence my LibreOffice Calc clipboard issues…

The workaround I’m using is to use the flatpak version of LibreOffice instead of the one from the normal repository. That one doesn’t adhere to the dark theme I’ve got my laptop configured too but at least it has working copy-paste functionality.

I could solve it by disabling the option β€œPrevent empty clipboard ” in the Klipper settings.

I confirm right clicking the β€œclipboard icon” in the notification area, selecting β€œConfigure Clipboard” and disabling β€œPrevent empty clipboard” solves this issue on Ubuntu 21.04 - KDE Plasma 5.21.4 on Wayland.

In X11 the issue doesn’t exists. It must be something with KDE on wayland.

1 Like