LibreOffice Calc paste inserts text twice

Hi there!

since a few days (recent update?) when I paste text inside a cell (so not text as cells but after having clicked into the textbox of a cell) the key-combination Strg+V inserts text twice.

Using insert from the rightclick popup doesn’t show the same bug.

Anybody else have come across this issue and knows how to workaround it? (besides using the mouse every time I want to insert text…)

Thank you,
kind regards

Which version of LO calc?

Build ID: 6.4.7-1

more info about my System:

Operating System: Manjaro Linux
KDE Plasma Version: 5.20.2
KDE Frameworks Version: 5.75.0
Qt Version: 5.15.1
Kernel Version: 5.8.18-1-MANJARO
OS Type: 64-bit
Processors: 12 × Intel® Core™ i7-9750H CPU @ 2.60GHz
Memory: 62,4 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 630

I cannot reproduce this error on LO Fresh 7.03 with xfce.

okey, so I’m gonna try to switch from libreoffice-still 6.4.7-1 to libreoffice-fresh 7.0.3-1.

But I suspect the problem lies somewhere in between the KDE clipboard tool klipper and libreoffice calc, and you’re not experiencing it because of using xfce and not kde.

Most likely, you are correct. I have had issues with the distribution builds of LO, so I use LibreOffice-fresh-rpm from the AUR. The PKGBUILD converts the .rpm directly from TDF (The Document Foundation) to .zst and installs. I have not had any issues since. YMMV.

so I switched to libreoffice-fresh 7.0.3-1 now, but it shows the same issue on my machine.

probably a related issue that started at the same time:

I can no longer cut and insert cells. cutting makes them vanish immediately from source, pasting pastes an empty cell.

Apparently, you are not the only one with this issue in KDE:

1 Like

I’m still experiencing the same issue with libreoffice-still and libreoffice-fresh from the repositories.

I’ve now installed the flatpak version and found this works without any strange copy cut paste issues. The downside to the flatpak version is that I could not find any way to make it look dark like the rest of my system.

also the flatpak version has weird bad scrolling behavior…

I’ve never experienced that issue in LO but I have always had problems with typing lag, especially in documents with inserted pictures. I solved that by getting rid of LO 7 (installed from the Manjaro repo) and getting an appimage of LO 6 direct from the LO website.

I’ve not tried the appimage of version 7 as I always found 6 to be less laggy when installed from the Manjaro repo.

May not help you but posting in case it does.

1 Like

I just tried the AppImage version of LO 6 but found it actually shows the same copy paste issues as the LO from the repository on my Manjaro KDE System.

So I guess for the moment I will stick with the Flatpak version and use it with inverted colors…

For me help command
systemctl --user mask at-spi-dbus-bus.service --now #unmask to revert
from here