[Stable Update] 2020-11-18 - Kernels, Plasma5, Frameworks, Thunderbird, Firefox, Mesa

Kernel 5.9.8-2 won’t boot for me. 5.8.18-1 works fine tho.

Hello everybody

After the update, I don’t get the display manager running. After a smooth boot, instead of a loginscreen I get a black screen with a white cursor in the upper left corner.

I tried to fix it, but haven’t found a solution yet.

What I have: Manjaro-Gnome (up to date): Note: After update: gnome-wallpaper was newer then in the repo.
What I tried to do:
-Install another dm (sddm with plasma) and start it. Didn’t work.

  • Downgrade gnome-wallpaper
  • Boot an older kernel: Can’t even boot, due to the fact that it doesn’t find a HDD, that should be mounted, that I’ve written in /etc/fstab (no problem with the newer kernel in this affair, but maybe I should investigate the further… :thinking: )
  • Switched to testing & unstable for updates. But no update available, that worked, so turned that back

What I should do: unplug my headset, which I added yesterday(USB), but I don’t expect that that solves the problem.
If anybody has an idea, I would be very thankful.

Updated, all good on XFCE with AMD hardware.

On Gnome QT5 app Kate fails to show the save file dialog.
I use
QT_STYLE_OVERRIDE=Fusion (tried switching to adwaita but that changes nothing)
I can’t seem to find anything online about this.
Anyone has any suggestions?

Also by switching to wayland my .profile does not seem to be loaded anymore? The PATH changes present in .profile are not executed in terminals.

1 Like

jesus, what happened to Thunderbird GUI :open_mouth: :frowning_face: :grinning:

Problem with copy/paste is still here. :pensive:
Does anyone have some new info about this?

Was there a /etc/mkinitcpio.conf.pacnew for others? @waranty92 @RayonRa

I do not quite understand how this can happen – wouldn’t it imply that the file was not changed from default (which does not have the encrypt hook)? But it had the hook as otherwise the system wouldn’t have been working before, right? I did not manually delete a /etc/mkinitcpio.conf.pacnew file and run pacdiff from time to time – but pacnew files are neither removed automatically by pacman/pamac at any point, are they?

Also, is there a way to configure pamac in a way that upon new kernel install the old kernels/initramfs GRUB entries are retained as a fallback (in case the new kernel or initramfs has a problem, for example, like here due to a missing encrypt hook in mkinitcpio.conf)? To clarify, the entries were of course still present, but it appears the update process not only mkinitcpio’d for the new kernel but also the old ones, which broke those existing entries as well and there was no fallback to boot and fix the system. I was lucky enough to have a bootable usb drive in reach, but on the road…

I’ve had a small issue with jade-application-kit package before updating, I had to reinstall it. Otherwise, everything is working fine.

I had no /etc/mkinitcpio.conf.pacnew the only pacnew file I had during this update was grub related. /etc/mkinitcpio.conf was overwritten unattended.

CoreCtrl problem fixed after todays update. Thanks.

Well, I think I won’t even try to do an update for at least 24 hours or more. Live and learn :slight_smile:

I reviewed the repos, checked my mirrorlist file, ran pacman-mirrors --fasttrack and checked my mirrorlist against the web page again. I used pacman -Syu and tried pacman -Syyu and the same results. I’m on a VM and restored for each attempt.

The last two errors have been "error: could not extract .... (Zstd decompression failed: Corrupted block detected), as mentioned here. It has been different files. I think the repos are still syncing (United_States), even though there is a checkmark indicating “Up to date”.

My conf was also overridden:
[2020-11-05T06:55:32+0100] [ALPM] warning: /etc/mkinitcpio.conf installed as /etc/mkinitcpio.conf.pacnew
I have no idea how I can restore the previous values present in the conf :confused:


Configuration files are never overridden, that’s why you get a *.pacnew file. However, you must maintain these files yourself.

Please refer to the ArchWiki: pacman/Pacnew and Pacsave - ArchWiki

Thank you for that clarification :slight_smile:
If I understand correctly I should merge the existing conf and pacnew file and remove the pacnew file?

Use i915.enable_dpcd_backlight=0 as boot parameter to fix backlight problem

My last update was on 2020-11-10.

At this time, mkinitcpio.conf was updated and a pacnew was created. The only difference was the use of “()” verses “""” for array lists. The only place encrypt appears is in an example HOOKS which is commented.

You should be able to confirm the creation of a pacnew file by looking at /var/log/pacman.log. I found it there. I also run pacman and pipe it to tee and save it in a timestamped file. I look for the following specifically:

less --pattern='(Generating|warning:|error:|New|Optional|[0-9]+/[0-9]+)'

Last I run: DIFFPROG=meld pacdiff

1 Like

I am getting below message in black screen after grub and then login screen shows up after 30 sec.

/dev/sda8: clean, XXX/YYY files, xxx/yyy blocks

sda8 is my root dir
DE : Gnome


Yes, you have to merge them manually. You can use the pacdiff tool to manage these files as it’s mentionned in my previous link.

Personaly, I’am using sudo DIFFPROG=meld pacdiff wich means that meld needs to be installed but you can also use nano, vim, …

1 Like

There was a grub.pacnew file and I used meld to manually avoid stepping on the caltrops. Accepting the whole file would have been disastrous.

The grub.pacnew in the last update is a good example. On my side, I rejected all the confilcts as I am not using the quiet splash + I have a grub theme + I am using custom kernel parameters.

So merging these files depends on your custom settings and may vary from one user to antoher.