Cant start Manjaro

Hello people, I am very new to linux and I was looking for distributions that I really like and serve me. Currently, I have Linuxmint and Windows 11 installed on the pc. Using Virtualbox, I planned to test Manjaro. However, once I finished installing, the system seemed to freeze on startup. The logo and the loading screen appear, but then it never comes out of there.
Am i missing something useful for you?
My English is not the best, I hope you can understand me. Thanks and regards!

Looking for error messages is a good start.

On which of your systems are you using Virtualbox?
Windows or Linux Mint?

If Manjaro cannot boot there
check how you set it up - to be sure that your Virtualbox installation actually works
make sure you can boot the Linux Mint Installation iso, for instance - you probably still have it …
or any other live iso will do - even a Windows installation iso

Thanks to both. Im running virtual box on windows 11. I tried other distros without problems. It is the first time im getting this problems. But i cant find any error or log. Or maybe i dont know how. The cursor (mouse) move, but the circle loading freeze. Cant see more at first look. Just logo + Manjaro and loading circle. Gonna try a new machine and reinstall.
And yes, i can boot linux mint without problem.

1 Like

When you say you finished installing in a VM it means Manjaro Live ISO went all the way to desktop? Or did you install it directly, not from Live ISO?

Have you been getting past the login screen since you are seeing the M logo?

I suspect a weak VM hardware configuration, maybe low RAM or just 1 processor. Post your VM hardware config please. Maybe also which file system did you use and which Manjaro version XFCE, KDE, Gnome, etc.


1 Like

Is it actually frozen, or just really slow?
Remember, Virtualbox defaults to using only one core and very low RAM and video memory. These are the settings I adjust before running any OS I’m trying out
(change the settings to whatever the system can comfortably handle). For example on my system I change the cores to 8, RAM to 16384mb, video memory to 128mb.

When i said “finished installing” i mean: the install finished and ask me for reboot. After reboot, dismount the ISO and never pass the M logo screen. Can move my mouse, but i leave it there for like… 3 hours and nothing happened.
I tried to use 4gb Ram, 128mb for GPU and 2 Cores. Cant install.
I tried to use 2gb ram, 128mb for GPU and 1 Core. Can install but cant pass logo.
Im using de KDE Plasma edition.
Gonna try really high settings, like 4+cores or 8gb+ ram.

Strange then. My Manjaro KDE Virtualbox VM is a 1 dual core and 4 GB RAM and it runs normal. It’s not the fastest though but usable.

Running it from the local SSD or from external USB disk?
Do you get any Virtualbox error message? Have you installed VB extension pack?

You said you also have Linux Mint on your machine. Have you tried to start the VM under Linux Mint?

I can confirm that Manjaro installs and runs properly in my VirtualBox, but I never tried on Windows so maybe there is an issue running it in Windows VirtualBox. I also give it 2 cores, 4GB RAM, 16GB disk.

From the VM if it is stuck and the desktop doesn’t load, you can jump to a TTY to collect logs from terminal with the CTRL+ALT+F3 shortcut.

You verified that iso? Which version of manjaro are you trying? I have no problems installing the latest manjaro KDE and KDE minimal on Virtualbox.

Tried 8gb ram 4 cores 50gb space 128mb gpu and i got "watchdog: BUG: soft lockup CPU#1 (pretty much infinite, i leaved it working for at least 30minutes.
The iso is the last version from this same web. It makes it to the logo with less resources. But when i upgrade the resources, cant install. I dont get it.
About the VB… I didnt install any extension, just the raw VB, thats all.
Never tried use VB on Linux mint, i can try if u want.
Thanks all!

If that is what is holding you up
there is a boot parameter nowatchdog (I believe that is the name)
Add to Grub config and update grub
or edit the Grub command line at startup to have instant confirmation.

I never had to do anything like that in a VM though.
But I only have Windows in a VirtualBox running on Linux - probably the other way around than what you are doing.

Have you checked the tutorial i linked in the very same post?.. :roll_eyes:

Gonna try it later. Im testing right now with 2gb ram, 2 cores, no 3d and it works perfect. Not sure what is going on, but now works. Gonna keep trying different settings. Any extension for VB recommended? One of you said if i installed VB extension pack. But dont know about it.

Checking it now, was too early in the morning and had to work. Sry and thanks you!

Found this • View topic - Soft Lockup … Might be WIN 11 and/or version related, who knows.

VirtualBox 6.1.32 Oracle VM VirtualBox Extension Pack is optional for USB 2/3 etc support, if you want to connect to USB devices within VM: Downloads – Oracle VM VirtualBox
Scroll down to link on page and decide for yourself if you need it. It’s not needed to start or run Manjaro.

Ok, little update. Manjaro works perfectly with Hyper-V. VB is the problem i think. Gonna check all the info u said. Thanks u all a lot!