Brother laser printer trouble HL-L2300D

Hello folks! I tried to get my Brother laser printer to work. I found the printer manager and it added a generic driver, but I couldn’t find my exact model of printer in the driver dialogue box.

Can I delete the whole thing and start over?

You can edit your posts to focus on one issue here, and create another topic for the other.

Thanks, sir! I did as you suggested.

Brother has 2 different printer drivers available on their website along with a driver installation tool.
They have both a CUPS and an LPR driver There are 2 versions of each.

If someone has time to kill, would they be able to give me help with a more beginner focus? First, I need to get the proper dialogue box to come up and to know what it will be called and what section it will be in the menus.

It is available from the AUR. Enable AUR support in pamac and search for brother-hll2300d.

or in terminal:

 pamac build brother-hll2300d 


Thanks, Mr. Richard! I entered the line in the CLI and then went into Abiword and tried to print a test page and the printer was in the menu. I hit print, the printer started humming and then nothing came out. I guess we are making progress.

Some information in link below: Just to be sure make sure all the CUPS services are enabled and check in your browser localhost:631 Administraton-Manage Printers and make sure that the printer is listed there.

systemctl enable --now cups.service
systemctl enable --now cups.socket
systemctl enable --now cups.path

Reboot may help as well as turning the printer off and on after reboot.
Try connected via USB first before configuring wireless, if available.

I don’t know how to sign in on the local host thing? stuff automatically comes up to fill the boxes, but it doesn’t go through.

I entered all three lines on the CLI and there were no responses.

Now, the green light is flashing on my printer.

localhost:631 gets entered in your browser address bar. There should not be a password required. At least on mine there isn’t.

The printer is listed on the website, and it didn’t require a password for me to get to that page. So, something is working. How do I get the green light to stop flashing on my printer? The green light was steady and then I initiated a print job. Now, the green light is blinking, yet there is no hum and nothing is printing.

Maybe this?

Thanks. The correct driver is definitely installed, so I should be pretty close. I unplug the printer and it goes back to a solid green light under ready, and then I try to print something and then the light just starts blinking. I’m still not getting email notifications when someone posts a reply. I tried ‘watching, tracking and normal’ on the menus, but none of them seem to work. I don’t know why they don’t make it easier to get an email when someone adds to the discussion.

Try a different printer cord. Is the system fully updated? Have you rebooted or tried a different kernel, preferably a LTS kernel, either 5.10 or 5.15? Have your tried printing from different software e.g. xed, mousepad, etc.

Yes, the system is fully updated. I did reboot. I didn’t try a different kernel. I don’t know how to do that. I didn’t know you could print from a text editor. I tried it and the machine started to hum, but nothing came out.

To change kernels- Settings- Manjaro Settings Manager- Kernels and choose a LTS Kernel if you are not already running one (5.15 or 5.10). Again, are you certain that your printer cord is not damaged in some way? Maybe the “generic” driver that you may have installed in post#1 is interfering somehow?

I am pretty much out of ideas here. Please read and post some information about your system:

Thanks guys for trying so hard! Thanks Mr. Richard!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.