Beginner question: Ext4 Partition is readonly

Hi there,

first of all: i am absolutely new in manjaro and…relatively new in Linux at all :wink:
So please don’t be too hard to me ;-(

And here comes my problem:
After successful installation I now have the problem that one partition is partially write protected.
Apparently I made a mistake due to my lack of knowledge when partitioning manually during the installation.

The corresponding partition I want to take main storage location for my data (500GB, ext4).
However, I can not save directly on it but only in a folder “basementmedia” (= my username).
How can I make the whole partition writable?
Can it be that it has to do with the fact that I have chosen a wrong mount point? Anyway: I am helpless and need from you an idiot-proof instruction how to proceed…please;-)

Best wishes

Let’s have some precise information first. :point_down:

If you mean that you can write to /home/basementmedia but not to /home itself, this is normal. Unprivileged user accounts should not have write access to /home itself.

sudo chown -R “username” /home/“username”/“foldername”

if i try to paste the result of command " inxi -Fazy" the message “Sorry you cant post links” is displayed ;-(

see this


this is my lsblk output:

sda 8:0 0 465,8G 0 disk
├─sda1 8:1 0 300M 0 part /boot/efi
├─sda2 8:2 0 48,8G 0 part /
└─sda3 8:3 0 416,6G 0 part /run/media/basementmedia/649e6c06-3495-4368-916
sdb 8:16 0 1,8T 0 disk
├─sdb1 8:17 0 16M 0 part
└─sdb2 8:18 0 1,8T 0 part
sdd 8:48 0 931,5G 0 disk
├─sdd1 8:49 0 709,4G 0 part /run/media/basementmedia/ExterneFestplatte
└─sdd2 8:50 0 1K 0 part
sr0 11:0 1 2,8G 0 rom

The partition all is about is “sda3” so if i understand correctly, i have to
sudo chown $USER:$USER /run/media/basementmedia/649e6c06-3495-4368-916

But then the following error is displayed:
Zugriff auf ‘/run/media/basementmedia/649e6c06-3495-4368-916’ nicht möglich: Datei oder Verzeichnis nicht gefunden

which means
Unable to access ‘/run/media/basementmedia/649e6c06-3495-4368-916’: file or directory not found

What am i doing wrong?

I’m a new Jack too, but it sounds like maybe you’ve not got your partition mounted. Maybe

sudo mount /run/media/basementmedia/649e6c06-3495-4368-916

then proceed as robin0800 suggests?

If i execute

sudo mount /run/media/basementmedia/649e6c06-3495-4368-916

the following error message is displayed:

mount: /run/media/basementmedia/649e6c06-3495-4368-916: konnte nicht in /etc/fstab gefunden werden.

in english “mount: /run/media/basementmedia/649e6c06-3495-4368-916: could not be found in /etc/fstab.”

Today is a typical monday: nothing works :wink:

the strange thing: if i now execute lsblk again the name of the partition seems have changed:

sda 8:0 0 465,8G 0 disk
├─sda1 8:1 0 300M 0 part /boot/efi
├─sda2 8:2 0 48,8G 0 part /
└─sda3 8:3 0 416,6G 0 part /run/media/basementmedia/649e6c06-3495-4368-916a-a9d3fc5841bc
sdb 8:16 0 1,8T 0 disk
├─sdb1 8:17 0 16M 0 part
└─sdb2 8:18 0 1,8T 0 part /run/media/basementmedia/Volume
sdd 8:48 0 931,5G 0 disk
├─sdd1 8:49 0 709,4G 0 part /run/media/basementmedia/ExterneFestplatte
└─sdd2 8:50 0 1K 0 part
sr0 11:0 1 2,8G 0 rom

but again if i then execute

sudo mount /run/media/basementmedia/649e6c06-3495-4368-916a-a9d3fc5841bc

the same error message is displayed ;-( (…could not be found in /etc/fstab)

Whoops I may have spoken a little hastily there… I think my syntax was bad. I think what I should have put in was

sudo mount /dev/sda3 /run/media/basementmedia/649e6c06-3495-4368-916

Told ya I was new :wink:

sorry about that

1 Like

Ah, perfect. Now it works

The thing is that /run itself is a tmpfs, and that anything mounted to a directory under /run is therefore only an ad hoc solution. Better is to create a static mountpoint for the partition and add it to /etc/fstab.

If the partition contains only files that are owned by yourself, then I would suggest creating the mountpoint ─ as yourself, not with sudo ─ inside your $HOME, e.g. /home/basementmedia/data.

Then, run… :arrow_down:

lsblk -o UUID /dev/sda3

… and write down (or copy) the UUID. Then, add a record for it to /etc/fstab:arrow_down:

sudo nano /etc/fstab

The record would look something like this:arrow_down:

UUID=the-UUID-you-copied  /home/basementmedia/data   ext4   auto,nofail,defaults   0   0

Save the file with Ctrl+O and leave the editor with Ctrl+X. If you reboot now, then the partition will automatically be mounted to /home/basementmedia/data.

1 Like

Another last question: How can i rename the partition “Datenträger” (e.g. to "mondays suck;-)?

Sweet! BY THE WAY…

@Fabby sent me a fantastic link if you’re new to Linux and want to start learning! Check out [HowTo] become a Manjaro power user when you’re a wizard at Windows but a N00b at Manjaro / Linux as it is a fantastic intro!


Whuh oh… so you’re saying what I’ve done with my /etc/fstab (set it to auto mount under /run/media/) is… not good, then?

Thank you for this!

Well… before you do that have a look atthe comment @Aragorn above. Looks like you may want to change your mount point. I certainly do :joy:

Good morning everybody,

after having mounted the partition as JulianVickers told me unfortunately the system does not boot anymore. The message “/sys/firmware/efi/efivars: unknown filesystem type ‘efivarfs’” is shown.
Or maybe it has to do with having changed the kernel to a realtime kernel?

What can i do to get the machine booting again?

Help ;-(

Best wishes

Ah, it was the realtime kernel,
Changing back to the Kernel 5.9.16-1 has solved the problem.
But i want to use a realtime kernel (because i want to make high end audio production) which reccomends usind rt-kernels. In my case i tried the 5.9.1_rt19-1 kernel. Yesterday this kernel workes but this morning…no more?

Workes perfectly, thanx

1 Like

Please read this:

and this as per @maycne.sonahoz :

As you provide little information, we don’t know your DE (Desktop Environment) but if you’re on Gnome, use gparted and under KDE use partitionamanager. Under XFCE install one of those 2.

Furthermore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.


1 Like