How do I change ownership for a hard disk?

I’m quite new to Manjaro, did use Linux like half a year ago, and got into it again, I just have a slight bit of a problem. I can’t write anything on my hard disk. I tried to change it in properties but it said that only the owner can change the permissions. So this is the problem, how do I change the permissions so I can edit files in it, move, and etc…?
Pics of what I mean:

      sudo chmod 777 -c -R /dev/Path to you hard disk

Got back a bunch of ‘chmod: changing permissions of …; Read-only file system’
Still not writable.

Never Use chmod 777

Setting 777 permissions to a file or directory means that it will be readable, writable and executable by all users and may pose a huge security risk.


That’s odd, what file system do you use, e.g. ext4 or btrfs?
Or try the same command with one more 7

Ok someone was faster

nevertheless, it’s still all root permission

as I reckon it’s ext4.

You need to use chown . Something like:

sudo chown /path/to/mount/point

chown: missing operand after ‘…’

I am sorry:

sudo chown $USER:$USER /path/to/mount/point

chown -R username:group /path
1 Like

ok i am completely new to linux and have the same problem. how do i get the ownership of my hard drive? the file system is ext4. I don’t know which of the above commands I should use and sometimes i don’t even know if i type the correct command because for example

sudo chown /path/to/mount/point

i guess for path i have to type my actual path but i dont know when to fill something in and when not

1 Like

Do you have / use a windows hard disk next to the linux? It doesn’t matter if you dual-boot it, or not, but if you do, I can possibly tell you the answer to your problem.

1 Like

No i have a ssd and a hdd both have the ext4 filesystem and no windows installed. i can right click and say open as administrator that works but I have to do that again and again.

Open a terminal in fullscreen. Run lsblk to find out where the partition is mounted in the filesystem.
Run: sudo chown $USER:$USER /path/to/mountpoint. Replace /path/to/mountpoint with the real one.


8 posts were split to a new topic: Chaning ownership for a hard disk

closed due to necro bumping