[Stable Update] 2021-03-08- Kernels, Plasma 5.21.2, Haskell, Kodi, Grub, KDE-Dev

RAS kernel 5.11.2 , nvidia , cinnamon


Amazing update & big thanks to the whole team, including those who run non-Stable for the rest of us!

More power to you all.

Ruziel :slight_smile:


Thank you for encouraging women against the smell of hatred around them.


For now i solved reinstalling the previous package of GRUB with sudo pacman -U /var/cache/pacman/pkg/grub-2.04-16-x86_64.pkg.tar.zst and after running sudo update-grub it works again.


Finally, able to remove python2… great work everyone :slight_smile:

Through a recent patch, os-prober seems to have been disabled by default. See here for details: https://gitlab.manjaro.org/packages/core/grub/-/commit/991784fbecb814a14651e1ccbd0dd6b08de2a129

I had the same issue and could resolve it by manually adding the line GRUB_DISABLE_OS_PROBER=false
to /etc/default/grub.


Which clock is that, a third party widget?

That’s an Event Calendar. Ok, it’s fixed: all you have to do is to update that plasmoid. :+1:

1 Like

The update went smooth on all my GNOME machines.

Keep up the good work!

Everything is fine here :smiley::smiley::+1::+1:…Gnome…5.11 & 5.10 LTS

Thank you very much for the info. I added that line to my Grub config with the new package installed and now it works.

Thanks Hefty!!!

That worked :slight_smile:

I’m on stable branch to NEVER experience such issues!!!

Even grub.pacnew doesn’t contain

Every one with multiboot is in a really bad situation!

Very bad, really!


Hi @Hefty !

Can you include your solution to the problem in " Known issues and solutions" (above)? I think it is quite important and it would make easier to people find it.


1 Like

I found a small bug:
my Windows 10 installation is not found.


My grub didn’t recognize my Windows 10 installation either after this update. The os-prober setting and then running update-grub added it back.

1 Like

If your multiboot Manjaro grub does not include other OS as Windows … see post from Hefty (down)

Hi @Keruskerfuerst,

Have a look at @Hefty solution:


I got

npm: /usr/lib/node_modules/npm/node_modules/which/bin/node-which exists in filesystem
npm: /usr/lib/node_modules/npm/scripts/bundle-and-gitignore-deps.js exists in filesystem
npm: /usr/lib/node_modules/npm/scripts/resetdeps.sh exists in filesystem
Errors occurred, no packages were upgraded.

And so on, what to do.

Was the grub/os-prober change on purpose? Because I think it deserves a proper mention in the announcement.

I have added the mentioned line to /etc/default/grub and
now Windows 10 starts again.