GRUB don't show a windows 10

Hi there, I just installed Windows and Manjaro on my PC and got a problem. GRUB menu doesn’t show me Windows 10 but if I choose it manually in BIOS, windows works. How can I fix it without reinstalling Manjaro or windows?

The first thing you see when you jump into the forums:

Welcome to our Forum

Please use the search function of the forum before posting any help requests.

3 Likes

It didn’t help me, I did it and nothing changed. I added GRUB_DISABLE_OS_PROBER=false and sudo update-grub.

If you did this before I posted about it, it would be best in future posts to always include everything you’ve attempted so far.

Can you please check and confirm that it saved correctly in /etc/default/grub?

Also, can you try sudo os-prober and see if it detects the Windows bootloader?

So I double-checked and it’s saved correctly.

Also, when I run sudo os-prober nothing happens

This means that it doesn’t detect the Windows boot.

Can you verify if ntfs-3g is installed? It should be, but just to make sure. It’s needed to work.

Also… Are you using legacy boot or EFI boot for your system?

This can be easily checked by seeing if /sys/firmware/efi exists. You can just type ls /sys/firmware/efi in the terminal.

I don’t have ntfs-39 in /sys/firmware/efi. I think I’m using EFI, but I’m not sure, because before that I reset my bios settings.

No no, I meant, check your package manager to see if ntfs-3g is installed on your computer or not.

And also to type ls /sys/firmware/efi into the terminal to see if the efi folder exists or not.

ahh sorry, yes ntfs-3g is installed and the efi folder exist

I made a reset of bios and nothing has changed.(Clear CMOS)

Can you use sudo update-grub and provide us with the output here please?

Please remember to use ``` before and after the output.

I did it, here is the output
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.11-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.11-x86_64.img
Found initrd fallback image: /boot/initramfs-5.11-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Found linux image: /boot/vmlinuz-4.14-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-4.14-x86_64.img
Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

I don’t know is it worth trying to figure out what is the problem. I use windows for 1 game and 1 program, I guess I could try Virtual Machine

I think you did the ``` wrong here. Example:

```
sudo pacman-mirrors -f 5
sudo pacman -Syu

```

=

sudo pacman-mirrors -f 5
sudo pacman -Syu

Just good to know for future references! It makes the output significantly easier to read.

It looks like sudo update-grub doesn’t detect the Windows bootloader either :confused:

But the Windows bootloader is obviously there and works:

Unfortunately, I don’t use GRUB anymore, I use rEFInd, so I can’t help anymore from here for GRUB. Hopefully someone else can step in.

If the game doesn’t have an anti-cheat, it should work on Linux. But don’t try to play games in a virtual machine unless you use GPU passthrough, which can get very complicated.

Depending on the program, it might work on Linux as well. Or use through a virtual machine.

i had this problem too
first add GRUB_DISABLE_OS_PROBER=false to /etc/default/grub
then reinstall grub using command sudo pacman -S grub
and finally update grub : sudo update-grub
Done!

1 Like

I just installed rEFInd and it works well. But thanks anyways. I’ll mark it as a solution, if anyone will have a problem.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.