[Zen2] Problems with pre-OS boot with RAM on XMP profile

This is not related to the OS, but I thought that some Zen2 users have encountered a similar issue and/or have a solution/workaround for it.

CPU: Ryzen 9 3900
MB: Asus Prime X570-Pro, latest BIOS, AGESA 1.0.0.4
RAM: 2x 16G Crucial Ballistix DDR4-3200 (XMP) at 1.35V
No overclocking

What I still need to check: Ryzen Memory Timing Calculator (Windows)

Issue:
When running on the XMP frequency and voltage, the system has trouble booting and stays at blank screen with uninitialised keyboard, needs a few resets until it starts through. Eventually it boots.
Going back to DDR4-2666 at 1.35V helps, the system boots correctly on 1st try and generally seems to be a little more stable.

A quick web search shows that some users have similar problem and it is not a pure Asus problem.
Some BIOS have a special "Boot RAM Voltage" option which seems to help in some cases by increasing it, but mine doesn't.

Note that I do not have errors on MemTest (EFI version from AUR) running DDR4-3200.

Maybe Zen2 with current BIOSes is very picky on dual-bank RAM.
I don't know.
System stability seems fine so far, although mprime with AVX2/FMA3 crashes within seconds, which might be an mprime issue though.

Have you tried switching ram slots? So if 1 and 3 are used switch to 2 and 4?

Not yet, as they are difficult to access due to the enormous CPU cooler, but they are in the "correct" (i.e. what the mainboard documentation says) slots.

Having to underclock memory to 2666mhz on a Ryzen 9 must hurt, like, emotionally.

I'll try and keep an eye out for similar issues and report back if I come across anything.

Starting with reddit, one user seems to have some success with manually adjusting ram timings rather than using XMP

+1 and +2 for trying a manual ram overclock instead of XMP


Checking the slots as suggested above is also a good call, I've found at least one random forum poster who mixed up their dual-channel slots because the Asus Prime X570 numbers the slots backwards.

The second post on this thread, somebody posted their OC settings with 3600 mhz memory on the same board. Looks like they had it stable with the voltage at 1.4
https://www.overclock.net/forum/11-amd-motherboards/1737150-asus-prime-x570-pro.html

I know these aren't all specifically related to the asus model, but as these memory issues seem to be to be popping up across manufacturers on the same chipset they may still be worth a look.

1 Like

Hi I've the previous one (2700x, x470).
First bioses changed a lot of settings, anyway I still have random freezes, not frequent, often at start up.
I assembled the pc last december, only after some months the new bioses improved the things.

You should dig ASUS forum to find out the right settings; anyway what the net says is that XMP profiles are for Intel chipset, so timings are not always the best for AMD; moreover x570 is young in term of bios, so the combination could rise your problems.

Net says also that boot process does some fail-trial loop to find settings suitable to boot, so once booted check with Ryzen Memory Timing Calculator the actual timings.

Then compare those settings with the settings provided with Ryzen Dram Calculator and with the XMP settings.

Probably you would have to set manually the settings suggested by RDC. Not a big deal, only study the instruction and apply.

Now I'm with the RDC settings and it sems to me that the freezes are less, but sometimes it happens, as I told before.

1 Like

2933MHz should be stable too so try that setting as it's less of a performance hit.

I tried 3000 which didn't help much.

As for the Ryzen Mem Timing Calculator, I will check it out for sure in a Windows VM.
I just need to find a lot of time for that, given the enormous number of RAM settings... :slight_smile:

I noticed that too and I already thought the manufacturer did it wrong, but they are in the correct slots (I checked twice).

A slight voltage increase could perhaps help a little, I'll check that as well.

That is correct, and that's why it's called "D.O.C.P." in the BIOS due to the Intel trademark.
Technically it's just another entry in the RAM's SPD EEPROM besides the fail-safe JEDEC DDR4-2400.

Yes it's a very young platform and I'm surprised how well it works already now just a few months after release. Currently only the RAM is having some issues.

Thanks for your help so far!

3000 is not a value that should be used with Ryzen processors, 2933 is the nearest equivalent that works

Thanks, I'll try that too.

Just to make things clear: Both 3000 and 3200 do work and are MemTest-stable. It's just the boot process that gets stuck.

My suspicion is that the RAM doesn't get enough voltage on early boot, maybe it boots at 1.20V instead of the selected 1.35V.
And maybe Asus will add the corresponding "RAM Boot Voltage" option in a later BIOSes, if it is technically possible.

I'll report back once I have tested your suggestions.

It's primarily due to clock frequencies used by AMD for all Zen generations, while 3000 appears to work, it is not a proper clock multiple, which is why you get a quirk for some things but not others. 3200 should actually be fine for Zen2 on paper with supported modules from the QVL list but keep an eye out for future AGESA updates. RAM tolerance is constantly being improved upon.

1 Like

A single 16G module of that Crucial RAM is on the QVL list, but not the 32G (2x 16G) kit composed of the same modules. However it is marked as being compatible in 2x DIMM mode.
However the latest QVL is from July 2019, I'll wait for a fresh update.
In the worst case, I could ask of an exchange of the modules.

But first let me dig into the RAM Timings calculator :wink:

If it’s just boot issues. It may very well be that the board is vdrooping (dropping voltage) below the needed value. Some boards have read points you can check with a meter. You can also just bump up the ram voltage a bit. Or set it manually if it is using auto.

Edit. I run 32 gb at 3200 on a similar setup but have 4x8 gigs. It’s reasonable that with 2 x 16 it needs a voltage bump. Technically 3200 is considered an overclock for the board just not the sticks.

for me it takes more to read the howtos :cold_face: than to change the settings. This had taken few minutes.

Does RDC work into a VM? I had to install Windows on a spare disk to use both RMTC and RDC

It was a terrible idea to use the "safe" values from the calculator.
Leads to a completely unbootable system, and the BIOS doesn't even reset itself to the defaults.
I'll have to pull the CMOS battery, which has to wait until the weekend.
Meh :frowning_face:

What do you mean by RMTC/RDC?

Try this to get back in. Power off the psu. Depress the power button in machine to drain the capacitors. Turn on the psu. Hit the reset button thee times in rapid sucession and then hit the power button on machine. See if it boots to a recovery mode that asks you to hit f1.

1 Like

A good idea actually, but unfortunately it doesn't work.
The DRAM error LED is on.
I'll see if I can find info on how to do a hard reset...

EDIT: I shortened the CLRTC pins as documented, it brought the computer back to life :slight_smile:

2 Likes

Hi
I’m sorry about your problems, I never have incurred in such a stop. Each time a soft reset was enough.

Did you typed the inputs in or RDC has gathered them?

If I’m not wrong, with settings calculated in another PC, so with inputs typed manually by me, it didn’t boot. Once installed Windows, RDC gave settings that are still working, both safe and fast.

In my bios a couple of settings are inverted. Did you checked yours?

Acronyms of Ryzen Mem Timing Calculator and Ryzen Dram Calculator,

You can also offset voltages.

Anyway is dangerous fiddling with voltages if you don’t know what you are doing because you can burn chips

1 Like

Well I have now tried 2933, which seems to be mprime stable.
I chose the XMP/DOCP profile and set the frequency manually to 2933, and voltage to 1.36V.
Also set 2T command rate, and "Power Down Engage" (?) to disabled, everything else at auto.

My, I could have figured that out. Thank you :wink:
It's a little overwhelming, I have to read up on it.

I will observe 3200 and the cold boot behaviour over the next days and report back.

Thanks to all.

3 Likes

:crossed_fingers:
I use also stress-ng, apart memtest at boot

1 Like

From the author of the RDC:

It's not up to date with Zen2 but a very interesting read.

Also found the documentation of the Micron DRAMs that are on the modules. Has about 400 pages and I don't understand anything - but one thing caught my eye: The calculator suggests a procODT of 53 Ω but that value doesn't appear in the ODT section, it is not a clean divider of 240 (Rzq/4.5). It seems to be either 60 or 48.
As I wrote just above, I don't understand anything...

1 Like

Forum kindly sponsored by