XPS 9720 - extremely slow install, then never finishes rebooting

On 3 other machines, Manjaro for me installs in about 3-5 minutes. I always install with proprietary drivers on machines with nVidia cards.

On my new XPS 9720 (with intel 12700H and nVidia 3060), with the latest full and/or minimal manjaro KDE image (21.3.7) each individually labeled step in the calamares process takes several minutes, and the whole thing takes about 15-20 minutes. Unfortunately the live install log has never worked for me for manjaro, so I can’t see if there are errors or what’s taking so long. It just says calamares version.

But the real problem is, I don’t think it actually installs correctly. When it finishes installing, checking “restart now” and pressing done goes to the TTY logging out stuff as expected, but it throws errors for about 5-10 minutes and never actually finishes (waited >30min).

See pic:
i.imgur
.com/UkqeQMs.jpg

If I manually force a shutdown by holding the power button, then I can boot into manjaro (still takes longer than normal) but shutting down again results in the same lengthy failed shutdown as above.

these xps dell machines dont support deep sleep, they also have enabled RAID in bios, so you need to switch it to AHCI. However, if you are using windows, you will not be able to boot into win, when you switch to AHCI …
also add ibt parameter to your kernel;
and disable watchog too

also switching to the kernel6:
sudo mhwd-kernel -i linux60
may be better for your machine, may have better support for your hardware… but first resolve the RAID/AHCI issue, and also add the ibt parameter before switching kernels, otherwise you will probably end up with a black screen…

and provide output from:
inxi -Fazv7

How do I add parameters to the kernel?

I did disable secure boot, disabled raid and set ahci, and set fastboot to thorough (there is no option to disable it, just minimal, thorough, or auto, and I think thorough is the closest equivalent).

Still getting the issue.

And more issues. Even vanilla arch (via archinstall) fails with some error about dev/sda which can only be referencing the boot media (different flash drive than the one I tried with manjaro). I don’t mean this to derail the topic, but rather to add further context if it’s helpful. If not, ignore it.

so just to be clear, you were on RAID?

Before making the OP, I had tried with and without RAID. RAID remains disabled, currently.

so keep ahci enabled, secure boot disabled, and set fast boot to minimal, since you say you cant disable it…
and try booting into the live usb with this parameter:
ibt=off
here is a link where you add it when booting live usb;
if its again slow, dont bother with install, but download the latest iso from here: 202212061117 - download both zip files, merge them, and use Ventoy to flash the iso and try again - also add the ibt parameter with this iso too …

1 Like