Xfce4 startx doesn't work, while startxfce4 does work

I have an issue with the X server it seems.
I ran “sudo pacman -Syu” and after rebooting there was an issue where my Manjaro would be stuck at blank screen.
After some further investigation I found out that if I hit “E” in Grub and remove “quiet” and add “3” at the end to change runlevel it allowed me to log in to my system via terminal.
Next thing I tried figuring out is why my window manager doesn’t work. If I run the startx command I get a blank screen only resolved by a reset button on the PC, but if I run startxfce4 command, my desktop and windows load immediately.
I followed advice here since it seems like exactly my problem: “/r/archlinux/comments/8dv8ab/startx_not_working_but_startxfce4_works/”
and backed up my .xinitrc file and deleted everything and only added exec startxfce4 in it, but upon rebooting I still get a blank screen (I’ve got no compton or quicktile to remove).
I am assuming this could be a problem with permissions or something, but I don’t know how to proceed since I am pretty new at this linux thing. But at the same time it also makes sense to me that the permissions wouldn’t change a thing since running startx still doesn’t work even after I am logged in as my user in the terminal. At this point I am a bit confused.
Your help would be greatly appreciated.
Right now I am logging in the OS by always editing the startup instructions (remove quiet and add 3 at the end, followed by logging in to the terminal and running startxfce4)
My current .xinitrc file:

# ~/.xinitrc
# Executed by startx (run your window manager from here)

exec startxfce4

And my backed up (one that was actual before I changed it)

# ~/.xinitrc
# Executed by startx (run your window manager from here)



# merge in defaults and keymaps

if [ -f $sysresources ]; then
    xrdb -merge $sysresources

if [ -f $sysmodmap ]; then
    xmodmap $sysmodmap

if [ -f "$userresources" ]; then
    xrdb -merge "$userresources"

if [ -f "$usermodmap" ]; then
    xmodmap "$usermodmap"

# start some nice programs

if [ -d /etc/X11/xinit/xinitrc.d ] ; then
    for f in /etc/X11/xinit/xinitrc.d/?*.sh ; do
        [ -x "$f" ] && . "$f"
    unset f

	local dbus_args=(--sh-syntax --exit-with-session)
	case "$1" in
		awesome) dbus_args+=(awesome) ;;
		bspwm) dbus_args+=(bspwm-session) ;;
		budgie) dbus_args+=(budgie-desktop) ;;
		cinnamon) dbus_args+=(cinnamon-session) ;;
		deepin) dbus_args+=(startdde) ;;
		enlightenment) dbus_args+=(enlightenment_start) ;;
		fluxbox) dbus_args+=(startfluxbox) ;;
		gnome) dbus_args+=(gnome-session) ;;
		i3|i3wm) dbus_args+=(i3 --shmlog-size 0) ;;
		jwm) dbus_args+=(jwm) ;;
		kde) dbus_args+=(startplasma-x11) ;;
		lxde) dbus_args+=(startlxde) ;;
		lxqt) dbus_args+=(lxqt-session) ;;
		mate) dbus_args+=(mate-session) ;;
		xfce) dbus_args+=(xfce4-session) ;;
		openbox) dbus_args+=(openbox-session) ;;
		*) dbus_args+=("$1") ;;

	echo "dbus-launch ${dbus_args[*]}"

exec $(get_session "$1")

Thank you for all your help,

Hi @tipmisle, and welcome!

That sounds no fun.

Please provide the output of:

sudo journalctl --boot --priority=3

Also, see [HowTo] Provide System Information, [HowTo] post screenshots and links and finally, [HowTo] Increase your chances of solving your issue.

Hope you manage!

1 Like

Hi @Mirdarthos, thank you for a nice welcome and help!

My sudo journalctl --boot --priority=3 command output:

jan 22 01:08:00 tacijosip-systemproductname kernel: ACPI BIOS Error (bug): Failure creating named object [\_SB.PC00.PEG1._PRT], AE_ALREADY_EXISTS (20200925/dsw>
jan 22 01:08:00 tacijosip-systemproductname kernel: ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (20200925/psobject-220)
jan 22 01:08:01 tacijosip-systemproductname kernel: mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ee0000000040110a
jan 22 01:08:01 tacijosip-systemproductname kernel: mce: [Hardware Error]: TSC 0 ADDR fef20300 MISC 3880000086 
jan 22 01:08:01 tacijosip-systemproductname kernel: mce: [Hardware Error]: PROCESSOR 0:a0655 TIME 1642810078 SOCKET 0 APIC 0 microcode ec
jan 22 01:08:04 tacijosip-systemproductname kernel: uvcvideo: Failed to query (GET_INFO) UVC control 8 on unit 1: 0 (exp. 1).
jan 22 01:08:42 tacijosip-systemproductname systemd-coredump[2917]: [🡕] Process 2830 (light-locker) of user 1000 dumped core.
                                                                    Module linux-vdso.so.1 with build-id 7f29a6692a026efad074e7ddd7933a64fa51cf3e
                                                                    Module libgvfscommon.so with build-id 90d1858292300e4e1ee3fbe84ab06079af840ec6
                                                                    Module libgvfsdbus.so with build-id dcb9d652f2e5c65154517fe6934215ec6bd1c29c
                                                                    Module libogg.so.0 with build-id ca0cae30a809f10db1f16e54a23b4e5ff7b2c54c
                                                                    Module libvorbis.so.0 with build-id ad0a6c1af8f219b4e314090b6e8847223d424cbe
                                                                    Module libltdl.so.7 with build-id 64bc54a40a0b6e4209a2c712364b4ae653c3f5b2
                                                                    Module libtdb.so.1 with build-id bec061530310665480ee91395b4eb0a937750a03
                                                                    Module libvorbisfile.so.3 with build-id 0010b21da05e318b42e718d90738febf58028141
                                                                    Module libcanberra.so.0 with build-id 379ed64f9d1408a83806cd5d94dc5bb903765615
                                                                    Module libcanberra-gtk3.so.0 with build-id 133409dc3e744fe0edc6a4d078714dce82dacf98
                                                                    Module libcanberra-gtk-module.so with build-id 72bd14fd5ba4fb0eda082b3daeccc80b796a5586
                                                                    Module libxkbfile.so.1 with build-id de5e415879c20263a8dd42f8cf2dd88107c2bfb2
                                                                    Module libxklavier.so.16 with build-id cefd678b3d270e389f50a9686ad2db83a8c67494
                                                                    Module libgnomekbd.so.8 with build-id 794a46e6fb5c4ca09e07a74b1199fb1d480d0843
                                                                    Module libgnomekbdui.so.8 with build-id 0f2fd1658447a0f5bf23a5eff2ec69bc9c306142
                                                                    Module libxapp.so.1 with build-id d620e9f373e4da2e15bee8b4bd0d8c3d924f00b7
                                                                    Module libxapp-gtk3-module.so with build-id 643c50b57a55f780caa6c2ea8dd268a32a162913
                                                                    Module libdconfsettings.so with build-id 7a4ba7af122c4d11168004a9ea6def330f02089f
                                                                    Module libgthread-2.0.so.0 with build-id 959c30007e43b239203c1b55b4050ded9e05adcf
                                                                    Module libxfconf-0.so.3 with build-id 05a5980d778faaf25bba2d27249e359b41a796eb
                                                                    Module libxfconfgsettingsbackend.so with build-id 8ce01e731b1120543da65b897c044ac6073f4b2b
                                                                    Module libbrotlicommon.so.1 with build-id a4ba3f4b4571c8272343b621da812a6e24a202a7
                                                                    Module libstdc++.so.6 with build-id 9b5eeeb149bf3c4efe787fb398b44f00507aec87
                                                                    Module libicudata.so.70 with build-id e1dcc2a88cfaafed882d09c90c668af0eed4efed
                                                                    Module libgpg-error.so.0 with build-id 3801187d42c4955bd93c605451430cdf1b164e63
                                                                    Module libblkid.so.1 with build-id f03a24e92c9852272bd0049b5bcb7ed6cf0e664f
                                                                    Module libbrotlidec.so.1 with build-id 45defc036e918e0140a72f1fbce6e7692d38241d
                                                                    Module libbz2.so.1.0 with build-id 919597c477c9b2cb9cdbb7745ed6494ac0e6da60
                                                                    Module libdatrie.so.1 with build-id 6fe3b6ece2c8e7d11869fa051375128d8f808f58
                                                                    Module libxml2.so.2 with build-id b710b880b0d4e9c93554fa632129db44c20632cd
                                                                    Module libjson-glib-1.0.so.0 with build-id 5865be5fcc01b48a0a113e0145ec45529bff89a6
                                                                    Module libsqlite3.so.0 with build-id 6514739218fd9adab53e2e53a63a7364f9e544b3
                                                                    Module libicui18n.so.70 with build-id 95af755fca990df26753a7d720b8e3ae24270e42
                                                                    Module libicuuc.so.70 with build-id 2e245c2bf12f95fd8ab79b3a4be99524677cbd70
                                                                    Module libstemmer.so.0 with build-id aa44a40dfb223020ed8e49cd2d28fc3887128463
                                                                    Module libatspi.so.0 with build-id de251156cf6f2f447c5e2b8721bd913d79995d4f
                                                                    Module libtiff.so.5 with build-id e8d89a0fb0847641ddb75c5f03fa89d68155a75d
                                                                    Module libjpeg.so.8 with build-id 879ca18a2f58c25d77ba881db3a44a5676ef6c7d
                                                                    Module libexpat.so.1 with build-id 16023a53e7b5bbdff92bd0bf2eebd36f9b5b879f
                                                                    Module libgraphite2.so.3 with build-id 47761dc11e553f519cde97ed9ee985be12ccdae2
                                                                    Module libXdmcp.so.6 with build-id 8ca0792d23c8b8b4c0864297512349292bea5955
                                                                    Module libXau.so.6 with build-id 1c67764663e07bec24d8951e5fd93f4d165979ff
                                                                    Module ld-linux-x86-64.so.2 with build-id 040cc3dd10461562f177df39e3be2f3704258c3c
                                                                    Module libgcc_s.so.1 with build-id 7f8508bb914546ada778809b64b99d234337d835
                                                                    Module libgcrypt.so.20 with build-id db45f5d5e0f7af1e77324fea1885f974619ad268
                                                                    Module libcap.so.2 with build-id f56c6cd6ad4d35053340d7ff2f8f954498796739
                                                                    Module liblz4.so.1 with build-id e63600ab23b2f6997f42fac2fa56e1f02ce159a1
                                                                    Module libzstd.so.1 with build-id 6214183688018e3fba6d66db10c2c8d0b45e0578
                                                                    Module liblzma.so.5 with build-id 8b615460aa230708c5183f16bede67aa0437d95e
                                                                    Module libresolv.so.2 with build-id c915c72668282861a813f7ea3c0780f37b681dc0
                                                                    Module libmount.so.1 with build-id ff9a1d99d35cf640d0bfdaba294854372672c29b
                                                                    Module libpixman-1.so.0 with build-id 341f793dcada3a48a306a793d265a517e3f2e7d6
                                                                    Module libxcb-shm.so.0 with build-id fb797f299a446f559a95afcc168227482cc800d1
                                                                    Module libxcb-render.so.0 with build-id a37bdb37744b508be9dd29fd9ccb9bb0170d43e5
                                                                    Module libXrender.so.1 with build-id 97e0b9ab6ba96ebc86527cc2b3c3078aad8616b3
                                                                    Module libfreetype.so.6 with build-id 26c5f833068ff72660d1975cbc2074c3eb47fad8
                                                                    Module libpng16.so.16 with build-id 2dc0bce07f199bf983c07a05fb95a6f4af83a9b3
                                                                    Module libz.so.1 with build-id 0c1459c56513efd5d53eb3868290e9afee6a6a26
                                                                    Module libthai.so.0 with build-id a7ac5010b4275c49308021200d23690533952702
                                                                    Module libXinerama.so.1 with build-id dbb6adece34ea2766d3efcd628af8f9757344dd6
                                                                    Module libXrandr.so.2 with build-id d4e869b5c72541e1de8f96b456248987ea52d51b
                                                                    Module libXcomposite.so.1 with build-id f1bb5ffb6203ab2907ac044a204ce3902a79f1c1
                                                                    Module libXdamage.so.1 with build-id a1d867e093c16944b2c0083be98050ef35c9e5c2
                                                                    Module libXcursor.so.1 with build-id eb6315bcd7526aaf51b0a1307efdc587cea0a152
                                                                    Module libwayland-egl.so.1 with build-id 791e39283cdcc5a08cfd091b8cd4c59869a11278
                                                                    Module libwayland-cursor.so.0 with build-id 79d7e67af210407c2afe92ba8c189c8648a6474c
                                                                    Module libwayland-client.so.0 with build-id 0a237f2fd096bada4ca381eec5d64474c4078be4
                                                                    Module libxkbcommon.so.0 with build-id 1f1bc7527e57c886c3df5803068122e1971d4724
                                                                    Module librt.so.1 with build-id 75484da2d6f1515189eefa076e0a40328834cd16
                                                                    Module libXfixes.so.3 with build-id 0a05c7e8714522bfbdd7c0027c3e2a94965664b0
                                                                    Module libtracker-sparql-3.0.so.0 with build-id b0eee5a9b660fed5221ea15139e9608282320503
                                                                    Module libcloudproviders.so.0 with build-id ed1d9c9e60be4e858ad148484767249be1edf95f
                                                                    Module libatk-bridge-2.0.so.0 with build-id 1161ebbcc5aa791075dfa026671875e5417287bd
                                                                    Module libXi.so.6 with build-id 16603be937a02a7e61b0b0395d064be7efd86f49
                                                                    Module libm.so.6 with build-id 2b8fd1f869ecab4e0b55e92f2f151897f6818acf
                                                                    Module libepoxy.so.0 with build-id b6357fc6b748c512f90339433d74502b9d0621dc
                                                                    Module libatk-1.0.so.0 with build-id aacaa40363d304858b654728a893bc212a4ca119
                                                                    Module libgdk_pixbuf-2.0.so.0 with build-id ca4beb15a30de8d8767f7bca8222038c61b58b36
                                                                    Module libcairo-gobject.so.2 with build-id abbf5a8a182ea1b8b7d68540df5c2e25c0bdae0c
                                                                    Module libfribidi.so.0 with build-id 79124bad061c2aab4ec89f25d067363d5b781114
                                                                    Module libfontconfig.so.1 with build-id 1103a641395c7d3b42e49b793d3a9ea927c77bf6
                                                                    Module libpangoft2-1.0.so.0 with build-id ef74c3ce7ee52a746fb5f2840d80a84e314edb92
                                                                    Module libharfbuzz.so.0 with build-id 1d9dee49dd99162c3f83eb3259c3c88c6b4cd7fe
                                                                    Module libgmodule-2.0.so.0 with build-id 34cabbd12d9baf397a0255f174e4c96165bc329b
                                                                    Module libdl.so.2 with build-id 5abc547e7b0949f89f3c0e21ab0c8331a7440a8a
                                                                    Module libxcb.so.1 with build-id 0d1ef11740a5daad2ee331e812a51aa6574af222
                                                                    Module libpcre.so.1 with build-id 845483dd0acba86de9f0313102bebbaf3ce52767
                                                                    Module libffi.so.8 with build-id f90d8b734f6de9b25faedb8cbfab7054dafc0a42
                                                                    Module libpthread.so.0 with build-id 07c8f95b4f3251d08550217ad8a1f31066229996
                                                                    Module libc.so.6 with build-id 4b406737057708c0e4c642345a703c47a61c73dc
                                                                    Module libsystemd.so.0 with build-id 5e0c342d74b444cce6793925b41760cf298c417c
                                                                    Module libgio-2.0.so.0 with build-id fc7ccd9c7c26cbb1e938b1c0879f078c2f47d803
                                                                    Module libcairo.so.2 with build-id 06820af9cf79c2deb207d9533a61caf04e67a8ad
                                                                    Module libpango-1.0.so.0 with build-id 730a8183a36afae82dd6a5564c0e490fed239a40
                                                                    Module libpangocairo-1.0.so.0 with build-id 10d2af38056eee9a6b3458d8aac24095c4dfab72
                                                                    Module libgdk-3.so.0 with build-id 6f77a9486fc38cb4e374d862662cb5e39ca3988a
                                                                    Module libgtk-3.so.0 with build-id e17042e459bfe2a5cd401828a90435a81a82b70d
                                                                    Module libXss.so.1 with build-id baa7abf56d3c688475068639478b07b508149f7a
                                                                    Module libXext.so.6 with build-id d70f24beb4fad748d6becffdcc13e51be0a2ebfa
                                                                    Module libX11.so.6 with build-id 5ba5798d193c0065014b8c6252a0678671c8d478
                                                                    Module libglib-2.0.so.0 with build-id 8214b56e554b7cbead4034b6ba32c90bc8c674da
                                                                    Module libgobject-2.0.so.0 with build-id 3e451709a0a5772b9550d3a4c28dcb37a87028fa
                                                                    Module libdbus-1.so.3 with build-id e937e5ef5cc9606af5f5f5bae96be6314828d1de
                                                                    Module libdbus-glib-1.so.2 with build-id 9b483ffff76251ff057e007a0b960bff84ce34a8
                                                                    Module light-locker with build-id 0ba2c7a3fd62222b252e6f682fe52ef40d9b9153
                                                                    Stack trace of thread 2830:
                                                                    #0  0x00007faa7ede4250 g_log_structured_array (libglib-2.0.so.0 + 0x5b250)
                                                                    #1  0x00007faa7ede4516 g_log_default_handler (libglib-2.0.so.0 + 0x5b516)
                                                                    #2  0x00007faa7ede596d g_logv (libglib-2.0.so.0 + 0x5c96d)
                                                                    #3  0x00007faa7ede5c70 g_log (libglib-2.0.so.0 + 0x5cc70)
                                                                    #4  0x00005618c5a3f94e n/a (light-locker + 0xb94e)
                                                                    #5  0x00007faa7eef886a g_type_create_instance (libgobject-2.0.so.0 + 0x3986a)
                                                                    #6  0x00007faa7eee02f6 n/a (libgobject-2.0.so.0 + 0x212f6)
                                                                    #7  0x00007faa7eee132d g_object_new_with_properties (libgobject-2.0.so.0 + 0x2232d)
                                                                    #8  0x00007faa7eee1d12 g_object_new (libgobject-2.0.so.0 + 0x22d12)
                                                                    #9  0x00005618c5a410ff n/a (light-locker + 0xd0ff)
                                                                    #10 0x00007faa7eef886a g_type_create_instance (libgobject-2.0.so.0 + 0x3986a)
                                                                    #11 0x00007faa7eee02f6 n/a (libgobject-2.0.so.0 + 0x212f6)
                                                                    #12 0x00007faa7eee132d g_object_new_with_properties (libgobject-2.0.so.0 + 0x2232d)
                                                                    #13 0x00007faa7eee1d12 g_object_new (libgobject-2.0.so.0 + 0x22d12)
                                                                    #14 0x00005618c5a3a397 n/a (light-locker + 0x6397)
                                                                    #15 0x00007faa7ddb1b25 __libc_start_main (libc.so.6 + 0x27b25)
                                                                    #16 0x00005618c5a3abde n/a (light-locker + 0x6bde)
                                                                    Stack trace of thread 2873:
                                                                    #0  0x00007faa7de7db2f __poll (libc.so.6 + 0xf3b2f)
                                                                    #1  0x00007faa7ee31749 n/a (libglib-2.0.so.0 + 0xa8749)
                                                                    #2  0x00007faa7eddac11 g_main_context_iteration (libglib-2.0.so.0 + 0x51c11)
                                                                    #3  0x00007faa7a7bcebe n/a (libdconfsettings.so + 0x5ebe)
                                                                    #4  0x00007faa7ee0bd51 n/a (libglib-2.0.so.0 + 0x82d51)
                                                                    #5  0x00007faa7dd72259 start_thread (libpthread.so.0 + 0x9259)
                                                                    #6  0x00007faa7de885e3 __clone (libc.so.6 + 0xfe5e3)
                                                                    Stack trace of thread 2872:
                                                                    #0  0x00007faa7de7db2f __poll (libc.so.6 + 0xf3b2f)
                                                                    #1  0x00007faa7ee31749 n/a (libglib-2.0.so.0 + 0xa8749)
                                                                    #2  0x00007faa7eddac11 g_main_context_iteration (libglib-2.0.so.0 + 0x51c11)
                                                                    #3  0x00007faa7eddac62 n/a (libglib-2.0.so.0 + 0x51c62)
                                                                    #4  0x00007faa7ee0bd51 n/a (libglib-2.0.so.0 + 0x82d51)
                                                                    #5  0x00007faa7dd72259 start_thread (libpthread.so.0 + 0x9259)
                                                                    #6  0x00007faa7de885e3 __clone (libc.so.6 + 0xfe5e3)
                                                                    Stack trace of thread 2874:
                                                                    #0  0x00007faa7de7db2f __poll (libc.so.6 + 0xf3b2f)
                                                                    #1  0x00007faa7ee31749 n/a (libglib-2.0.so.0 + 0xa8749)
                                                                    #2  0x00007faa7eddcab3 g_main_loop_run (libglib-2.0.so.0 + 0x53ab3)
                                                                    #3  0x00007faa7e135598 n/a (libgio-2.0.so.0 + 0x103598)
                                                                    #4  0x00007faa7ee0bd51 n/a (libglib-2.0.so.0 + 0x82d51)
                                                                    #5  0x00007faa7dd72259 start_thread (libpthread.so.0 + 0x9259)
                                                                    #6  0x00007faa7de885e3 __clone (libc.so.6 + 0xfe5e3)
                                                                    ELF object binary architecture: AMD x86-64
jan 22 01:09:07 tacijosip-systemproductname pulseaudio[2760]: GetManagedObjects() failed: org.freedesktop.DBus.Error.TimedOut: Failed to activate service 'org.>

My system information if it comes in handy:

  Kernel: 5.10.89-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=008a1ad2-4d62-4181-bc7d-f6deda59b775 rw apparmor=1
    security=apparmor udev.log_priority=3 3
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1
    vt: 1 dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
  Mobo: ASUSTeK model: PRIME Z590-P v: Rev 1.xx serial: <superuser required>
    UEFI: American Megatrends v: 0407 date: 01/14/2021
  Message: No system battery data found. Is one present?
  RAM: total: 31.18 GiB used: 4.02 GiB (12.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i9-10900K bits: 64 type: MT MCP arch: Comet Lake
    family: 6 model-id: 0xA5 (165) stepping: 5 microcode: 0xEC
  Topology: cpus: 1x cores: 10 tpc: 2 threads: 20 smt: enabled cache:
    L1: 640 KiB desc: d-10x32 KiB; i-10x32 KiB L2: 2.5 MiB desc: 10x256 KiB
    L3: 20 MiB desc: 1x20 MiB
  Speed (MHz): avg: 3256 high: 4403 min/max: 800/5300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 4401
    4: 4403 5: 4400 6: 4185 7: 4207 8: 3262 9: 1911 10: 1148 11: 799 12: 1211
    13: 3122 14: 4401 15: 4400 16: 4357 17: 4312 18: 4362 19: 4300 20: 4342
    bogomips: 148040
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush clflushopt
    cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts
    epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fxsr
    ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ibrs_enhanced ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx ospke pae pat pbe pcid pclmulqdq
    pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts rdrand rdseed
    rdtscp rep_good sdbg sep smap smep smx ss ssbd sse sse2 sse4_1 sse4_2
    ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer
    vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GK104 [GeForce GTX 760] vendor: CardExpert driver: nvidia
    v: 390.147 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1187
    class-ID: 0300
  Device-2: Anker PowerConf C300 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-1:7 chip-ID: 291a:3361 class-ID: 0e02 serial: <filter>
  Display: server: X.Org compositor: xfwm4 v: 4.16.1 driver:
    loaded: nvidia display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 108 s-size: 1204x342mm (47.4x13.5")
    s-diag: 1252mm (49.3")
  Monitor-1: HDMI-0 res: 2560x1440 hz: 60 dpi: 93
    size: 698x393mm (27.5x15.5") diag: 801mm (31.5")
  Monitor-2: DP-1 res: 2560x1440 hz: 60 dpi: 109
    size: 597x336mm (23.5x13.2") diag: 685mm (27")
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel vendor: ASUSTeK driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:f0c8 class-ID: 0403
  Device-2: NVIDIA GK104 HDMI Audio vendor: CardExpert driver: snd_hda_intel
    v: kernel bus-ID: 01:00.1 chip-ID: 10de:0e0a class-ID: 0403
  Device-3: Anker PowerConf C300 type: USB driver: snd-usb-audio,uvcvideo
    bus-ID: 1-1:7 chip-ID: 291a:3361 class-ID: 0e02 serial: <filter>
  Sound Server-1: ALSA v: k5.10.89-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: yes
  Device-1: Realtek RTL8125 2.5GbE vendor: ASUSTeK driver: r8169 v: kernel
    port: 3000 bus-ID: 04:00.0 chip-ID: 10ec:8125 class-ID: 0200
  IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: br-0694982e6234 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-2: br-09328cdb3ad8 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-3: br-299c54303482 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-4: br-a5b35a1874ea state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IP v6: <filter> scope: link
  IF-ID-5: br-b21038bda354 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-6: br-b9cfb6f204ba state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-7: br-c5b484a17ab6 state: up speed: 10000 Mbps duplex: unknown
    mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IP v6: <filter> scope: link
  IF-ID-8: br-cbf7f2817dd9 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-9: br-dbf159b50e41 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-10: br-e57a59c04c51 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-11: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  IF-ID-12: veth436a202 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-13: veth7fd7252 state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  IF-ID-14: veth8e1718d state: up speed: 10000 Mbps duplex: full
    mac: <filter>
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 2.27 TiB used: 150.21 GiB (6.5%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung
    model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 2B2QEXM7 temp: 33.9 C scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung model: SSD 980 PRO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 2B2QGXA7 temp: 36.9 C scheme: GPT
  ID-3: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 500GB
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 1B6Q scheme: GPT
  Optical-1: /dev/sr0 vendor: TSSTcorp model: CDDVDW SH-224DB rev: SB01
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 931.51 GiB size: 915.82 GiB (98.31%)
    used: 150.18 GiB (16.4%) fs: ext4 dev: /dev/nvme1n1p1 maj-min: 259:1
    label: N/A uuid: 008a1ad2-4d62-4181-bc7d-f6deda59b775
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 30.3 MiB (31.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
    label: N/A uuid: 503A-6965
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:4 size: 16 MiB fs: <superuser required>
    label: N/A uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:5 size: 930.91 GiB fs: ntfs label: N/A
    uuid: 786C3F226C3EDA98
  ID-3: /dev/nvme0n1p4 maj-min: 259:6 size: 499 MiB fs: ntfs label: N/A
    uuid: 42E00A9CE00A9677
  ID-4: /dev/sda1 maj-min: 8:1 size: 465.26 GiB fs: ntfs label: N/A
    uuid: D4442E59442E3F1C
  ID-5: /dev/sda2 maj-min: 8:2 size: 509 MiB fs: ntfs label: N/A
    uuid: E070639070636C6A
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:7 info: Anker PowerConf C300 type: Audio,Video
    driver: snd-usb-audio,uvcvideo interfaces: 4 rev: 2.0 speed: 480 Mb/s
    power: 500mA chip-ID: 291a:3361 class-ID: 0e02 serial: <filter>
  Hub-2: 1-2:3 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s
    power: 100mA chip-ID: 05e3:0610 class-ID: 0900
  Device-1: 1-3:4 info: SteelSeries ApS Kinzu V2 Gaming Mouse
    type: HID,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 1038:1366 class-ID: 0301
  Device-2: 1-11:5 info: SteelSeries ApS SteelSeries Apex Pro
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 5 rev: 2.0
    speed: 12 Mb/s power: 500mA chip-ID: 1038:1610 class-ID: 0300
  Device-3: 1-13:6 info: ASUSTek AURA LED Controller type: HID
    driver: hid-generic,usbhid interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 16mA
    chip-ID: 0b05:19af class-ID: 0300 serial: <filter>
  Hub-3: 2-0:1 info: Super-speed hub ports: 9 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 37 C
  Fan Speeds (RPM): N/A
  Processes: 437 Uptime: 8h 59m wakeups: 0 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1222
  pacman: 1204 lib: 326 flatpak: 0 snap: 18 Shell: Zsh v: 5.8
  running-in: xfce4-terminal inxi: 3.3.12

Thank you!

What is the output when you run startx.

If I run startx I get a blank screen, with no known (to me) way to come back to terminal, CTRL + ALT + F2 doesn’t work.

I saw the second error first, which shows something to do with a webcam error. Or something like that, as AFAIK uvcvideo handles webcam stuff.

Then upon inspection, I saw the first error, which very clearly states there is a Hardware error, albeit with the motherboard. But, and I don’t know if it’s so, if the webcam connects VIA USB, it might be picked up ass a problem with the motherboard…

So try without it, maybe it works then. If it does, then you know, if it doesn’t then report back.

Oh, I tried disconnecting the webcam and rebooting.
If I leave it running without interrupting I still get a blank screen, solvable only by a reset button.
If I log in via terminal and run startx it loads my desktop and windows as it should.
My question now is, how do I fix so that I can log in via xfce login screen instead of doing that manually?

systemctl enable lightdm.service

Try restoring that .Xinitrc backup you made.

my opinion:

Starting by booting into runlevel 3
and the directly starting the xfce session
works because the display manager is not involved.

Maybe you changed something in it’s settings
or didn’t fully update …

jan 22 01:08:42 tacijosip-systemproductname systemd-coredump[2917]: [🡕] Process 2830 (light-locker) of user 1000 dumped core.

whatever you did to it (if you did something) - reverse it
and run pacman -Syu again to be sure the update wasn’t a partial one

If I restore the .xinitrc startx command stops working and leads to a blank screen again.

Hi @Nachlese, thank you for your comment and suggestion

I ran the pacman -Syu again and my output suggests there is nothing to update

:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

Hi and thank you for your suggestion, if I run your command I don’t get any errors, but if I check the status it comes back as this:

○ lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: inactive (dead)
       Docs: man:lightdm(1)

OK, last thing I can suggest, see if you can sync again:


I have NO, 0, zip, if this will work or what the effect might be. this is wwhat my logic dictates. I don’t know if it’s correct or flawed. So continue at own risk!

pamac --enable-downgrade --overwrite $(pamac list --installed --quite | grep -i xfce)

there is something missing here

  • no reports of graphics for Intel® UHD Graphics 630
  • also this nvidia is still working with 390 series , or need nouveau ?

may be check and test with kernel 5.15 lts series

  • light-locker is not present on my side for Xfce

Are you sure that you cannot switch to another TTY?

This means it is enabled (but not immediately started) - it probably was enabled all along already.
It is started on next reboot - but starting it is what doesn’t work

systemctl start lightdm.service
will do that