Xfce reboot on logging in

Dear All,

I have Manjaro Linux running on Macbook Pro 2015 with xfce desktop.

After upgrading to 6.1, I find xfce reboot no sooner after I log in; however, if I log into Gnome for a while and then log into xfce the system is stable.

Please help me on solving this issue.

inxi report:
CPU: quad core Intel Core i7-4870HQ (-MT MCP-) speed/min/max: 799/800/3700 MHz
Kernel: 6.1.29-1-MANJARO x86_64 Up: 16m Mem: 3290.5/15874.0 MiB (20.7%)
Storage: 465.92 GiB (17.0% used) Procs: 271 Shell: Bash inxi: 3.3.27

uname -a:
Linux Galois 6.1.29-1-MANJARO #1 SMP PREEMPT_DYNAMIC Wed May 17 14:00:55 UTC 2023 x86_64 GNU/Linux

With my regards and all the very best wishes,



Please find the reports:

  1. inxi --admin:
  Kernel: 6.1.29-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/vmlinuz-6.1-x86_64
    root=UUID=0edafad0-514a-4b2c-8b55-92049b32041b rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 1 dm: LightDM v: 1.32.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Apple product: MacBookPro11,5 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-06F11F11946D27C5
    serial: <superuser required>
  Mobo: Apple model: Mac-06F11F11946D27C5 v: MacBookPro11,5
    serial: <superuser required> UEFI: Apple v: MBP114.88Z.0172.B09.1602151732
    date: 02/15/2016
  ID-1: BAT0 charge: 39.4 Wh (88.9%) condition: 44.3/99.8 Wh (44.4%)
    volts: 12.3 min: 11.4 model: SMP bq20z451 type: Li-ion serial: N/A
    status: full cycles: 358
  System RAM: available: 15.5 GiB used: 2.55 GiB (16.5%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Core i7-4870HQ bits: 64 type: MT MCP arch: Haswell
    gen: core 4 level: v3 note: check built: 2013-15 process: Intel 22nm
    family: 6 model-id: 0x46 (70) stepping: 1 microcode: 0x1C
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 6 MiB desc: 1x6 MiB
  Speed (MHz): avg: 1162 high: 3700 min/max: 800/3700 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 3700 2: 800 3: 800 4: 800
    5: 800 6: 800 7: 800 8: 800 bogomips: 39924
  Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
    bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
    rdtscp rep_good sdbg sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx
    vnmi vpid x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Venus XT [Radeon HD 8870M / R9 M270X/M370X] vendor: Apple
    driver: radeon v: kernel alternate: amdgpu arch: GCN-1 code: Southern Islands
    process: TSMC 28nm built: 2011-20 pcie: gen: 3 speed: 8 GT/s lanes: 8
    link-max: lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1
    bus-ID: 01:00.0 chip-ID: 1002:6821 class-ID: 0300 temp: 53.0 C
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1
    compositor: xfwm v: 4.18.0 driver: X: loaded: radeon unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: radeon display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 2880x1800 s-dpi: 96 s-size: 762x476mm (30.00x18.74")
    s-diag: 898mm (35.37")
  Monitor-1: eDP-1 mapped: eDP model: Apple Color LCD built: 2015
    res: 2880x1800 hz: 60 dpi: 221 gamma: 1.2 size: 331x207mm (13.03x8.15")
    diag: 390mm (15.4") ratio: 16:10 modes: max: 2880x1800 min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel 8 Series/C220 Series High Definition Audio
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000
    Series] vendor: Apple driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
    chip-ID: 1002:aab0 class-ID: 0403
  Device-3: Broadcom 720p FaceTime HD Camera driver: N/A pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 05:00.0 chip-ID: 14e4:1570 class-ID: 0480
  API: ALSA v: k6.1.29-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 0.125.0 status: off tools: N/A
  Server-2: PipeWire v: 0.3.70 status: off tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: 1: pulseaudio-alsa
    type: plugin 2: pulseaudio-jack type: module tools: pacat,pactl,pavucontrol
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple
    driver: brcmfmac v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 04:00.0 chip-ID: 14e4:43ba class-ID: 0280
  IF: wlp4s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Apple Bluetooth Host Controller driver: btusb,hid-generic,usbhid
    type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-8:2
    chip-ID: 05ac:8290 class-ID: fe01
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 465.92 GiB used: 79.17 GiB (17.0%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Apple model: SSD SM0512G
    size: 465.92 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 3A0Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 33.53 GiB size: 32.7 GiB (97.54%) used: 18.47 GiB (56.5%)
    fs: ext4 dev: /dev/sda6 maj-min: 8:6 label: N/A
    uuid: 0edafad0-514a-4b2c-8b55-92049b32041b
  ID-2: /boot raw-size: 477 MiB size: 451.7 MiB (94.69%)
    used: 126.6 MiB (28.0%) fs: ext3 dev: /dev/sda5 maj-min: 8:5 label: N/A
    uuid: 92a56c14-84eb-46dc-b11b-5a0ba0143f8c
  ID-3: /boot/efi raw-size: 200 MiB size: 196.9 MiB (98.45%)
    used: 28.2 MiB (14.3%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: EFI
    uuid: 67E3-17ED
  ID-4: /home raw-size: 350.69 GiB size: 344.12 GiB (98.13%)
    used: 60.55 GiB (17.6%) fs: ext4 dev: /dev/sda8 maj-min: 8:8 label: N/A
    uuid: 0ef962c2-2ab8-4f1b-b873-077898a2a4cd
  ID-5: /opt raw-size: 3.73 GiB size: 3.59 GiB (96.36%) used: 24 KiB (0.0%)
    fs: ext4 dev: /dev/sda7 maj-min: 8:7 label: N/A
    uuid: e8af44ea-4bf1-4d99-9313-154667f2883f
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 29.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda4 maj-min: 8:4 label: N/A
    uuid: 7da427a3-fd8b-4c39-99a9-6ec44c2cf073
  ID-1: /dev/sda2 maj-min: 8:2 size: 46.9 GiB fs: hfsplus label: Macintosh HD
    uuid: 40bd70e9-1711-3745-8572-94701a8703c6
  ID-2: /dev/sda3 maj-min: 8:3 size: 619.9 MiB fs: hfsplus label: Recovery HD
    uuid: 94480255-5c84-3363-9e65-e027ec4905c4
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 14 rev: 2.0
    speed: 480 Mb/s (57.2 MiB/s) lanes: 1 mode: 2.0 chip-ID: 1d6b:0002
    class-ID: 0900
  Device-1: 1-8:2 info: Apple Bluetooth Host Controller
    type: keyboard,mouse,bluetooth driver: btusb,hid-generic,usbhid interfaces: 6
    rev: 2.0 speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 chip-ID: 05ac:8290
    class-ID: fe01
  Device-2: 1-12:3 info: Apple Apple Internal Keyboard / Trackpad
    type: HID,keyboard,mouse driver: apple,bcm5974,usbhid interfaces: 5 rev: 2.0
    speed: 12 Mb/s (1.4 MiB/s) lanes: 1 mode: 1.1 power: 500mA
    chip-ID: 05ac:0274 class-ID: 0300 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 6 rev: 3.0
    speed: 5 Gb/s (596.0 MiB/s) lanes: 1 mode: 3.2 gen-1x1 chip-ID: 1d6b:0003
    class-ID: 0900
  System Temperatures: cpu: 54.0 C pch: 40.5 C mobo: N/A gpu: radeon
    temp: 53.0 C
  Fan Speeds (RPM): N/A
  Processes: 270 Uptime: 3m wakeups: 2 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1728 libs: 389 tools: gnome-software,pamac pm: flatpak pkgs: 0
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.27

Please let me know if you would require any other reports.

Hello @partha :wink:

Explain that please.

Dear @megavolt

As soon as I log in through xfce, after some initial checks, like bringing old session material up, it opens emacs, nautilus and finally firefox, and then blanks out for reboot.

However, if I log in through gnome this does not happen; the gnome sessions however do not not bring back the old session, so I have to start from scratch every time.

Another thing I noticed: if after some time on gnome I log out to get back to xfce the session works and everything is fine.

So, it seems there is something that is not getting aligned on initial xfce start; I do not know how to proceed and hence asked for help and support.

With my regards and all the very best wishes,


While on Gnome, try to run xfce4-session-settings (Session & Start in menu ?) and untick the 2 firsts check boxes. Then try to log on xfce.

I have read the original poster’s post a few times and it still is not clear to me. Is xfce and gnome installed on the same computer? Does it work okay with another LTS kernel e.g 5.15 or 6.2, 6.3?
Can you post a full inxi output? How about posting journal output?
Dual-booting? Is this installed or in a VM? There isn’t enough here to begin to guess what the issue is.

Dear @Denis_Pom,

Thanks for your hint; it helped; now xfce works, but I believe something was going wrong and that was not addressed… I have added my inxi, journalctl and dmesg reports above

With my regards and all the very best wishes,

Dear @jrichard326,

Please find inxi --admin report appended to my original query.

Please specify which journalctl -b report do you need; will it be the records for boots when the problem was occurring?

There is dual boot: mac and linux on my macbook; I have xfce as well as alternatively gnome desktops installed, kernel 6.1… there is no VM…

With my regards and all the very best wishes,


I wouldn’t mix desktop environments. It is just looking for trouble. Xwayland? Have you tried without xwayland? My understanding is that it is experimental at this point in time. Have you tried other kernels? If you want to experiment with Gnome or another DE, why not do it in a VM?

I would try to grab journal output from when the crash occurs and see if something looks off.