Wine is broken after the last big GNOME update

Wine has stopped working after the last big gnome update. I’ve tried downgrading the wine version, but it still won’t work. Are the manjaro devs aware of this?

GNOME 41.4
Kernel 5.10.105-1

Please detail.

It won’t launch any application I’ve installed. When I attempt to launch anything it just says in the gnome shell “Wine Windows Program Loader” for a time and nothing else happens. It’s literally just that. Not sure what else you want me to detail.

Wine version is 7.4

Try removing your .wine folder in your home directory. Then open a terminal and type winecfg
Yes, there were some issues with 7.4. Wine 7.5 was released this week and is currently in Unstable branch.

Keep in mind this would most likely remove all “installed” windows/wine programs itself unless you specificly used another (wine-)prefix for them in which case removing ~/.wine is a moot point altogether.

1 Like

Any particular issue?

I had some wine GUI issues after the last update with themes and fonts. I went into the wine configuration dialog and set Theme to (No Theme). I also installed winetricks to edit the registry to add fontsmoothing. Apps ran though. I’m on XFCE, wine-7.4.

I followed the thread in the previous Announcement.

This is the one I posted. It affected quite a few other programs. It has been resolved via patch and then in 7.5. Wine Bugzilla is the source to check for regressions, etc.

yep, somewhat nuclear approach there. I forget that I only use Wine for very few pieces of software and those are small footprint, standalone types. I have VM for tax software (USA) :frowning:

Didn’t work. Guess I’ll wait until the devs fix it.

Just an update on the situation:

After today’s update, wine is still broken.

@livrerego Well, there must be something wrong on your side. winecfg just works:

I would say you have to delete the ~/.wine folder and reinstall your applications, but anyway, it would be better to have a wine prefix for each application. bottles is still in development, but is very promising for normal applications.

pamac build bottles

1 Like

Each one of my applications had their own wine prefix, except for one. I’ve already deleted the /.wine folder and when I type “winecfg” in the terminal nothing happens, it just stays there.

EDIT: fixed it.

Apparently either mangohud or goverlay were messing up wine. I removed both and now everything seems to be working again.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.