Windows 10 has disappeared from GRUB menu

I have set up a dual boot in my laptop two months ago, and it has worked fine until recently, when the Windows 10 entry in GRUB menu has disappeared. It happened after a Windows update, but I don’t know how to get it back.

If I run sudo update-grub I get

Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Warning: os-prober will not be executed to detect other bootable partitions.
Systems on them will not be added to the GRUB boot configuration.
Check GRUB_DISABLE_OS_PROBER documentation entry.
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

I think the key is the error message os-prober will not be executed to detect other bootable partitions. Systems on them will not be added to the GRUB boot configuration. Check GRUB_DISABLE_OS_PROBER documentation entry.

os-prober seems to detect the Windows boot normally:

sudo os-prober 

returns

/dev/nvme0n1p1@/efi/Microsoft/Boot/bootmgfw.efi:Windows Boot Manager:Windows:efi

So I guess there is something I have to change in /etc/default/grub, something which involves the GRUB_DISABLE_OS_PROBER option, but I’d appreciate some guidance.

Ok, looking here (https://www.reddit.com/r/ManjaroLinux/comments/m22iyb/system_directly_boots_in_manjaro_without_showing/) it seems that it was Manjaro’s update that caused the problem.

Hi @MattG,

As per the latest update announcement:

  • Grub got some needed security updates . Note that os-prober is now disabled by default for security reasons: broken patch ; fixed patch . More infos about it here . To restore the old behavior, open a terminal and issue sudo echo GRUB_DISABLE_OS_PROBER=false >> /etc/default/grub && sudo update-grub
3 Likes

I should have read more carefully. I (wrongly) assumed that it was Windows’ fault. :slight_smile:

Hehehe, nope, not this time, man!

2 Likes

Have te same problem with Win 10 dissappeared after last update. Tried to fix grub by:

sudo echo GRUB_DISABLE_OS_PROBER=false >> /etc/default/grub && sudo update-grub

but received: ’ /etc/default/grub: Permission denied’

???

Should I try as a su? Or need to edit grub permissions?

Don’t do this.

You need to do it as root, so the sudo at the start of the command is correct. Why it’s not working is another story.

An alternative would be to enter a super user shell (at least according to me :stuck_out_tongue_winking_eye: ), aka root shell,

su

Then enter your root password.

When successfully in the shell, edit the /etc/default/grub file with a text editor, nano in this case:

nano /etc/default/grub

Scroll to the bottom and insert:

GRUB_DISABLE_OS_PROBER=false

Save and exit.

Once back in the command line, still as root run:

update-grub

If successful, pray for the best, hold your thumbs - not that tight - and reboot.

This should get you your grub back. If not, I’m innocent and not here.

4 Likes

@Mirdarthos

Works!!!

Thank you very much :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.