Wifi dongle not working anymore TP-Link TL WN823N RTL8192EU

Hi, bought the tp link wifi dongle, made it work using the instructions in this blog but I upgraded the kernel to 5.7 from 5.4 and it stopped working, tried redoing the steps in the blog and it didnt work, went back to the previous kernel and it still doesnt work. might be unrelated but I can no longer access the “hardware configuration” bit from “manjaro-settings-manager”. there are 5 packages that start with rtl8192 in the graphic package manager and none of them are marked as being installed.

In the old forum, I would have posted this in the newbie corner though noob is more accurate as I dont know how computer works. Here are some pastebins I thought might be useful.

lsusb

lspci

lsmod

modinfo 8192eu

modprobe -c | less

mkinitcpio -M

Thanks for the help.

See the this post in old forum: Tp-link TL-WN823N V3 - Networking - Manjaro Linux Forum

That sounds like your install is borked somehow.

The rest of your story sounds like mismagement …
That blog post shouldnt be followed … its just doing things outside the package manager for no reason, while we have packages available in the AUR.
ex - AUR (en) - Search Criteria: 8192

But lets check your first issue first…

sudo pacman-mirrors -f && sudo pacman -Syyu

Does that return nothing / is all good?
Also how is mhwd and such?

mhwd -l && mhwd -li
pacman -Qs 'mhwd|settings-manager'

here’s what sudo pacman-mirrors -f && sudo pacman -Syyu returns, seems fine ?

mhwd -l && mhwd -li

is not returning anything either as a superuser or as a normal user.

here is what pacman -Qs 'mhwd|settings-manager returns

So the packages seem installed … but mhwd not returning anything means … well mhwd isnt working (which is what MSM is using)

Maybe try removing and reinstalling:

sudo pacman -Rndd mhwd mhwd-db manjaro-settings-manager && sudo pacman -Syu mhwd mhwd-db manjaro-settings-manager

(then reboot and see if mhwd is working at all)

Okay so, I did sudo pacman -Rndd mhwd mhwd-db manjaro-settings-manager && sudo pacman -Syu mhwd mhwd-db manjaro-settings-manager and I rebooted and now I can access the hardware settings via manjaro-settings-manager and mhwd -l && mhwd -li returns this

But following @dagorret I then reisnatalled the headers and dkms and git and also did

sudo echo -e "blacklist rtl8xxxu" | sudo tee -a /etc/modprobe.d/blacklist.conf

and rebooted again and now mhwd again returns nothing, so I guess the blacklisting of rtl8xxxu might be causing the issue in some way ? also this post recommends that I uninstall any wifi drivers that were previously installed, is the software I downloaded and installed following the instructions in the blog I posted in my first commment a driver ? if so how do I remove it ? Also it seems adding the blacklisting rtl8xxxu makes me unable to reboot or shutdown properly. here’s a screenshot

.

Start again with my command, then we need to remove that git/dkms driver.

It seems (correct me if I am wrong) that the driver was only installed using dkms.
Then you would need to do

dkms remove rtl8192eu/1.0 --all

Then … we start again.

Most likely you just want the DKMS driver from the AUR?
https://aur.archlinux.org/packages/8192eu-dkms/

I dont know if you have a helper installed or not … so lets do this the good old fashioned way:

git clone https://aur.archlinux.org/8192eu-dkms.git
cd 8192eu-dkms
makepkg -sric

Start again with my command, then we need to remove that git/dkms driver.

which one ? I removed the blacklisting conf file from modprobe again, rebooted, and now mhwd seems to be working fine. shd I proceed with

?

Yes.
We might still need the blacklist … but lets remove the manually installed dkms driver first (with that command)
Then go ahead and install like above.

did both of these things, 1 2 and rebooted. dongle does not work, shows the wireless connections availaible but detects them all as having very low signal and I cant connect to mine.

OK. that means its at least kinda working.
Now lets tweak it … one step being to get rid of mac randomization:

echo -e "[device]\nwifi.scan-rand-mac-address=no" | sudo tee /etc/NetworkManager/conf.d/disable-random-mac.conf

I had done that when @dagorret linked it, also I jumped the gun again (sorry) and re-added the blacklisting rule again, rebooted and the wifi works fine, mhwd works again and I can reboot. is it good ?

1 Like

Seems good to me. And now you have a real package installed :slight_smile:
I dont know if the blacklist would still be required or not - you could always check one way or the other.
So really the steps were:

  • (!) Bonus - if manually installed driver previously, remove
  • 1 - Install available driver (if not in mhwd/repos … then check AUR … in this case: link)
  • 2 - Fix any driver quirks
    (known quirks with 8192EU: mac randomization, possible module collision with rtl8xxxu)

Thanks for the help, do you know if the dongle will keep on working if I upgrade my kernel via manjaro-settings-manager ?

It should.
DKMS means ‘dynamic kernel module support’ - and it should rebuild/add itself automatically when you add/change kernels.
Also as its a package it is recognized by the package manager.
Just keep in mind that it is an AUR package, so it may need to be updated or rebuilt itself from time to time.

Ill just leave some notes here too:
https://wiki.manjaro.org/index.php?title=AUR
https://wiki.archlinux.org/index.php/Dynamic_Kernel_Module_Support

alright, thanks for the help @cscs

Cheers. Have fun out there :nerd_face: