Wifi disabled issue

I just installed Manjaro for my Dell XPS 15 Laptop but I noticed the boot process was slow, I found the fix mhwd-kernel -li and then sudo mhwd-kernel -i linux54 rmc but when I restarted my pc wifi and bluetooth doesnt work. The network is connected to ethernet by default. How can I fix this?

Provide output of inxi -Fazy

  Kernel: 5.4.257-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64
    root=UUID=5fb79814-3d82-41ad-9f16-1b68f5e3ecc5 rw quiet splash
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 9500 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 0XWT2F v: A02 serial: <superuser required> UEFI: Dell
    v: 1.22.0 date: 03/16/2023
  ID-1: BAT0 charge: 74.0 Wh (87.8%) condition: 84.3/84.3 Wh (100.0%)
    volts: 12.8 min: 11.4 model: SMP DELL 70N2F95 type: Li-poly serial: <filter>
    status: charging
  Info: model: Intel Core i9-10885H bits: 64 type: MT MCP arch: Comet Lake
    gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
    model-id: 0xA5 (165) stepping: 2 microcode: 0xF8
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 16 MiB
    desc: 1x16 MiB
  Speed (MHz): avg: 3328 high: 3599 min/max: 800/5300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3469 2: 3364 3: 3393
    4: 3035 5: 3599 6: 3571 7: 3541 8: 3553 9: 3019 10: 3240 11: 3244 12: 3544
    13: 2717 14: 3539 15: 2921 16: 3514 bogomips: 76816
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: Split huge pages
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB
    filling, PBRSB-eIBRS: SW sequence
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Dell driver: i915
    v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: eDP-1 empty: DP-1,DP-2,DP-3 bus-ID: 00:02.0 chip-ID: 8086:9bc4
    class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: Dell
    driver: nvidia v: 535.129.03 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f95
    class-ID: 0302
  Device-3: Realtek Integrated_Webcam_HD driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-11:3 chip-ID: 0bda:5510
    class-ID: fe01 serial: <filter>
  Display: x11 server: X.Org v: 21.1.8 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,nv,vesa
    dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
    s-diag: 798mm (31.43") monitors: <missing: xrandr>
  Monitor-1: eDP-1 model: Sharp 0x14d0 built: 2020 res: 3840x2400 dpi: 290
    gamma: 1.2 size: 336x210mm (13.23x8.27") diag: 396mm (15.6") ratio: 16:10
    modes: 3840x2400
  API: EGL Message: No EGL data available.
  API: OpenGL v: 4.6 vendor: intel mesa v: 23.1.9-manjaro1.1 glx-v: 1.4
    es-v: 3.2 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
    device-ID: 8086:9bc4 memory: 30.38 GiB unified: yes
  API: Vulkan v: 1.3.264 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 1650 Ti driver: nvidia v: 535.129.03 device-ID: 10de:1f95
    surfaces: xcb,xlib device: 1 type: integrated-gpu name: Intel UHD Graphics
    (CML GT2) driver: mesa intel v: 23.1.9-manjaro1.1 device-ID: 8086:9bc4
    surfaces: xcb,xlib
  Device-1: Intel Comet Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci bus-ID: 00:1f.3 chip-ID: 8086:06c8
    class-ID: 0403
  API: ALSA v: k5.4.257-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.81 status: off with: pipewire-media-session
    status: active tools: pw-cli
  Server-3: PulseAudio v: 16.1 status: active with: pulseaudio-alsa
    type: plugin tools: pacat,pactl
  Device-1: Qualcomm QCA6390 Wireless Network Adapter vendor: Rivet Networks
    driver: N/A pcie: gen: 2 speed: 5 GT/s lanes: 1 link-max: gen: 3
    speed: 8 GT/s bus-ID: 6c:00.0 chip-ID: 17cb:1101 class-ID: 0280
  Local Storage: total: 476.94 GiB used: 9.43 GiB (2.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: PC601 NVMe 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 80002111 scheme: GPT
  ID-1: / raw-size: 282.42 GiB size: 276.92 GiB (98.05%) used: 9.43 GiB (3.4%)
    fs: ext4 dev: /dev/nvme0n1p8 maj-min: 259:8
  ID-2: /boot/efi raw-size: 1000 MiB size: 998 MiB (99.80%)
    used: 300 KiB (0.0%) fs: vfat dev: /dev/nvme0n1p9 maj-min: 259:9
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 19.53 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p7 maj-min: 259:7
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 348 Uptime: 9m wakeups: 616 Memory: total: 32 GiB note: est.
  available: 31.11 GiB used: 1.68 GiB (5.4%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1122 libs: 317 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30

The above is the output I get when I run the command inxi -Fazy

Provide output for

lsmod | grep 'ath11k'
sudo dmesg | grep 'ath11k'

Do i run the above command in the terminal or do I provide the output?

Run each of two commands and provide outputs for both

I just tried the two command. it did not give any output

Ok. Try this one

sudo modprobe ath11k_pci

If you won’t see any output check if wifi could be enabled

I got the output below:

modprobe: FATAL: Module ath11k_pci not found in directory /lib/modules/5.4.257-1-MANJARO

Interesting. Module ath11k_pci was supposed to be build-in since kernel 5.1.
Try newer LTS kernel, 5.15 or 6.1. Your laptop has a pretty new hardware, no need to use kernel 5.4

Okay, I will try that. I should restart after installing right?

Yes, you should

I have installed kernel 6.5.1 and restarted my pc. So the wifi and Bluetooth are enabled back. But the boot process is slow and it takes time.

It takes time before it Dell icon load and show password screen , how can I fix this?

Provide output for systemd-analyze

Startup finished in 5.154s (firmware) + 2.940s (loader) + 2.406s (kernel) + 8.069s (userspace) = 18.569s 
graphical.target reached after 8.068s in userspace.

This is the output

18 seconds is too long for you? :thinking:

Let me restart it and see.

The behavior seems somehow

I just restarted it and the screen is all black. Something seems to be a miss, can’t just say what exactly.

If I may , what do you think the command below does:

sudo pacman -Syyu haveged
sudo systemctl enable haveged --now

I saw it as a fix to the boot issue: Manjaro hangs on Dell logo during boot - #19 by Aragorn

That was just a suggestion not a fix cause it didn’t work.
Those commands install and start haveged service. But I believe it’s already installed and running on you system. Check
systemctl status haveged