Manjaro hangs on Dell logo during boot

Well, maybe it was the entropy after all? :smiley:

1 Like

LOL, I don’t want to it restart now, have to do some work :slight_smile:

Well, if you have the time later, then you can try again, and if it works, then we’ll know. :slight_smile:

Will do, but if it was supposed to work, wouldn’t it have worked on first try? It’s not like cranking and engine I hope

Logic suggests that it should indeed have worked the first time. I have no explanation for why it didn’t. :man_shrugging:

Well at least it’s consistent. I had to restart again and it booted on 4th time. Not sure if it means anything.

When the machine does boot up:

  • check journal for errors from previous failed boots
  • disable grub silent boot
    • edit /etc/default/grub
    • remove quiet from GRUB_CMDLINE_LINUX_DEFAULT
    • update-grub to re-generate grub.cfg

This should allow you to check messages on next (failing?) boot,

1 Like

Hello,

Question, have you installed anything lately that after this problem started. Also have you check your logs in /var/log to see if there is something that may be causing the delay in booting?

When it comes to windows, until you install the proprietary drivers, it uses a generic video driver. Also windows uses virt drivers until you put the proprietary ones on the system which is why windows works, it really never touches bare metal until all manufacturer drivers are installed.

I have the same issue, except:

  1. I had manjaro installed for just a few weeks before it started happening (a few days ago)
  2. I’m using gnome
  3. I am only using manjaro. I don’t have dual boot
  4. I have to restart the laptop 10 or more times before I get to the login screen
  5. I can consistently open grub and see the manjaro entry. But once I select it the dell logo flashes 3 times and then gets stuck

I will try to remove quiet from grub and after work I’ll see if that gives me any useful information.

This is Xorg.0.log in /var/log, the only readable one. The other one is Calamares.log, not sure if it’s relevant, sorry I can’t post links for some reason - pastebin com/raw/9cY18Ztm

I found a temporary solution:

after removing quiet from grub I saw that there was no error reported: all steps were passing.
The last step before the booting stopped were either
Started TLP system startup/shutdown
or
Started CUPS scheduler

Thanks to this reddit post I found out that once it’s stuck there if I press ctrl-F2 and then ctrl-F1 I can get to the manjaro login screen.

I then tried to upgrade the kernel from version 5.7 to 5.8 but that didn’t solve the issue. I wasn’t able to downgrade to 5.4 (I can’t find out how to switch kernel: in grub I don’t see the different versions listed) so I can’t say about it.

1 Like

Does this help? :arrow_down:

Or this? :arrow_down:

1 Like

Ok finally installing kernel 5.4 (latest LTS) and removing 5.7 and 5.8 solved the issue.

I used
mhwd-kernel -li
and then
sudo mhwd-kernel -i linux54 rmc
after I made sure I only had 5.8 installed and running.

1 Like

Did you enable the service after installing the package?

1 Like

I only installed Docker, java and some development libraries. Nothing shows up in the logs.

Yes, same thing.

Can confirm this fix. After downgrading to 5.4 LTS the issue is fixed. I was tested by restarting 4 times and it was successful every time.

Note that if you want to drop from linux-latest to linux-lts you’ll have run

sudo pacman -Rcsnu linux-latest

As described in forum.manjaro. org/t/cannot-remove-linux57-breaks-dependency-required-by-linux-latest-something/7679 (can’t add links for some reason, may be because I am new)

Thank you @Ciack404!

I’ve got the same problem, although the weird thing is that if I switch to another TTY and then back again, it continues booting just fine. For example, when I get stuck on the Dell logo, I can press: Ctrl + Alt + F2 followed by Ctrl + Alt + F1. The Dell logo then disappears and it shows the display manager like it should.

Edit: this was already mentioned above, I’m stupid.

This is without any doubt a consequence of your CPU developing too little entropy at boot time. Install haveged and you will be fine. :wink:

sudo pacman -Syyu haveged
sudo systemctl enable haveged --now

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.