VS Code is not opening at all

I’ve installed Manjaro Gnome almost 2days Ago and I also installed the VS- Code as well, but yesterday when i tried to open VS-code it did not open and run at all it IDK why but I’m very upset as i’m a beginner with Manjaro Gnome…

Hi @M.Vaince, and welcome!

Well, the DE (Gnome) doesn’t matter in this regard, it could just as easily have been Xfce or KDE. I use VS code every day, so I know it works. Question is, how did you install it?

i just installed it after reading a random article on the internet usin “yay” package manager

initially it was working , but yesterday when i intalled docker and Kubernetes it just stopped working…

There is no need to use yay

sudo pacman -Syu code


pamac install code

Which package?

 $ pamac search vscode --no-aur
code  1.84.2-1                                                   extra
    The Open Source build of Visual Studio Code (vscode) editor
vscode-markdown-languageserver  1.84.0-1                         extra
    Markdown language server
vscode-json-languageserver  1.84.0-1                             extra
    JSON language server
vscode-html-languageserver  1.84.0-1                             extra
    HTML language server
vscode-css-languageserver  1.84.0-1                              extra
    CSS/LESS/SCSS language server

Why would you be?

And Linux is not Windows.

Unix was not designed to stop its users from doing stupid things, as that would also stop them from doing clever things.
— Doug Gwyn

Sounds strange …

Well, that’s a Bad Idea :tm: .

About those, I’m the last person that could offer any useful advice…

a Better idea, but not the best in my opinion as yay isn’t native. Please, before going further with you Linux journey, work through this:

You’ll save yourself much headaches. If you decide to continue, then go through this:

Regarding VS Code, this might help:


I recommend pamac instead of pacman, especially for newcomers as pamac was developed by Manajaro (developers) for Manjaro and just takes care of more thing than pacman. For example:

1 Like

Could you please paste the address of this random article?

Your privileges don’t allow pasting live links yet, however, you can paste it between backticks when you use </> from the toolbar, like this:


Yes, yes;
and we both know new users seldom follow the links they are given. :wink:

Yup, I know. But to be honest, that’s not on me/us…

Sad, but true.

1 Like

Ok, That’s cool… I’ve read those articles I just want to mention some more things…
I’m currently an internee in a Software company on DevOps and I was using Debian pretty smoothly on my " DELL -Latitude E-5420" but that was a very old machine like (2nd Gen Core i5 with 8 gig ram and 320 gigs of hdd) it went down and out one day and I decided to by New-Machine ) I had some money and my family also supported me to get a brand new machine it was “HP-OMEN 16-k0033DX” Gaming Laptop With ( 12th Gen Intel-Core™ i9-1200H @2.50GHz and Nvidia GeForce RTX 3060[6GB])
So when i installed Ubuntu 22.04 LTS on it, it’s sound did not worked and when I shuts down the pc it just hangs still with a blank grey Screen and do nothing …despite my best efforts i could not fix it … After that i tried Pop OS … and it’s shutdown and start was working fine but the sound issue remained there… Now after searching the internet i found Manjaro which is just running perfectly fine but now I i have a problem with the Code-studio… I’ll implement the solutions again which shared in the article i hope that’ll work fine…

Again, could you please paste the address of this random article?

Kumpel - the source seems irrelevant as installing from the repo will work.

Yes, but it would be interesting to know what those instructions were, and how they might have contributed to the OP’s issue. Otherwise, I agree.

bro i’m not good at saving history in my broser…

In that case, all I can suggest is:

sudo pacman -Syu code

Good luck.

Thank You so Much Guys … My issue has been resolved…

Yes you were correct, I made the same mistake, Infact i searched the repo with the GUI “Add/Remove Software” and I found “Code-OSS” in the result which i simply neglected it considering another tool… and After reading an Article Shared by @Mirdarthos i found that Code-OSS is the VS -Code…

There is multiple custom scripts in AUR providing variations over Visual Studio Code.

The ones I have mentioned is those in the official repo - inherited from Arch repo.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.