Version `GLIBC_2.33' not found (required by pacman)

I tried to update Manjaro after 8 months but package manager was always freezing at “synchronizing databases” step. I found some suggestion to install yay, but when I tried installing yay, I had to install git first. While installing git, some of updates were installed and I started getting error ‘version `GLIBC_2.33’ not found’.

While all the responses to this question suggest to run some commands, running any suggested commands for me results into exact same error. I can just do a fresh install and but I have some customisations that it would be nice to not lose them.

It would be great if someone can help out here. Let me know if I should provide any additional info.

Right now I am running live installation and have chrooted into old installation.

Welcome here, @zorrohere77,

This is too long to expect you still can update. Better backup your data and re-install, re-implementation of your customizations is by far easier than to update after such a long time.

Manjaro is a rolling release distro and if you want to avoid these issues update at least every two months and read announcements, first.

1 Like

You can also update your system while chrooted.

Otherwise you can try updating through pacman-static:

sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu
1 Like

Alright, thanks for responding, I will consider re-installling.

Just curious, as I am still not too familiar with Linux in general and though I wanted to adopt it as my main OS several issues stopped me from doing that. But still I would like to keep Manjaro on my PC and use it time to time.

If I did read announcement, and was careful before trying to do any update, was it possible to successfully update after such long time?

You can try what @maycne.sonahoz suggested, but in general as I said you need to update in time. Announcements provide tips and hints before doing it, so better read them upfront. If you note what kind of customization you do to your system it won’t be difficult to re-implement this next time, so no need to be afraid of a re-install.

Unfortunately I get error while running sudo pacman -Syy command, I can’t even check for updates.

[manjaro pkg]# pacman -Syy
pacman: /usr/lib/ version `GLIBC_2.33' not found (required by pacman)
pacman: /usr/lib/ version `GLIBC_2.33' not found (required by /usr/lib/

Try to update your mirrors, first:

sudo pacman-mirrors -f

Try this


If you plan on using your computer only occasionally, Manjaro may not be the best distribution : as @Wollie said, this is a rolling distribution, with frequent updates and thus to be frequently updated.
You may have a better experience with fixed release distributions, more so with long term support, like in the Debian, SUSE or Mandriva families for instance.

Thanks for the input, I think I will give up on saving this installation and consider other distros as Maycne suggested.

Moson’s suggestion helped but glemlins.db fails to download from all mirrors. I think I messed up badly and won’t be able to do anything. Thanks!

This is not part of Manjaro.

Remove that section from your pacman.conf file and try again.

1 Like

Thanks, removing that helped. I had conflicts with lib32-libcanberra-pulse lib32-libcanberra-gstreamer libcanberra-pulse libcanberra-gstreamer. I removed them as suggested in the announcement thread.

After that I was able to install all updates, had to update grub to detect windows. Now everything works without issues. Thanks everyone!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.