USB Installer Boots but unable to Install KDE

I have created a USB Installer, and am able to boot from it with my Lenovo IdeaPad 5i Pro (11th Gen Intel(R) Core™ i5-1135G7 @ 2.40GHz 2.42 GHz). However, the screen flickers on/off once at the Desktop, if I click the screen goes black until I click again. Therefore, I am unable to try out / install Manjaro.
For information, I have created other USB Installers for different distros, and they all behave in the same way.
I would really like to install Manjaro KDE, is there anything I can do to resolve this issue?
Thank you.

Which version of Manjaro are you trying to install ?
Can you download the latest version here: Release 202211150747 · manjaro/release-review · GitHub

1 Like

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
    (Wisdom lies in reading :wink: )

Thank you. But I am unable to get to the terminal to obtain this information. The graphics is too broken for me to be able to do anything. Currently, I have Windows 11 installed.

Hi, I have created a Live USB from the latest KDE Plasma full download from I have experienced this issue with broken graphics, making it impossible to do anything on other distros too.

secure boot needs to be disabled in bios
fast boot disabled in bios - you may not have this option
fast startup disabled in windows…

and try booting the iso with this parameter:
here is a link where you add this parameter during booting the usb

You haven´t tried to download the image from Github.

Adding this parameter worked perfectly, and enabled me to boot the USB Live CD. I was then able to install Manjaro.
However, when I boot I get the same issue as before. Is there a permanent fix? Do I need to add the parameter again? If so, how?

Thank you

yes, you need to make it permanent, so in the grub menu press E, and add the parameter again, for example after udev.log_priority=3 i915.enable_psr=0, and boot with it, and now open this:
kate /etc/default/grub
and in this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything from there!, just add it to existing parameters, save the file, update grub:
sudo update-grub

Thank you for the instructions. However, I do not see Grub on boot. And when I reach the Desktop, the display is so broken it’s unusable. How should I proceed? Thank you again.

you mentioned above that you are using windows, so i assumed you were dual booting… so you installed only manjaro?
so boot normally and enter into TTY, press ctrl+alt+f2 - or f1-f6 keys, enter your username/password, and do this:
sudo nano /etc/default/grub
and in this line: GRUB_CMDLINE_LINUX_DEFAULT inside the quotes add this parameter:
dont remove anything from there!, just add it to existing parameters, save the file with ctrl+x, update grub:
sudo update-grub
systemctl reboot

Thank you so much. This worked perfectly. (Yes, I decided to erase Windows and just use Manjaro).

I now have another issue. The display resolution is set at 2880 x 1800. Whereas the default resolution for my laptop should be 2240 x1400. This setting is not present in Settings - Display Configuration though. How can I fix this please?

first update your system, reboot;
install the 6.0 kernel - not the rc/rt one - reboot, you should automatically boot with it, just to be sure check with: uname -r if you are running the 6.0, and check the resolution…
also check with:
xrandr -q
if the resolution is detected

Thank you. I have poor internet over the weekend, so will follow your instructions, and update my system on Monday then report back :smile:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.