Update failing due to mutter conflict

Hi everyone, I’m running Manjaro Budgie and haven’t had any major issues for the past years. Recently the latest update triggers the following message:

Conflicting dependencies: -mutter43 and mutter are in conflict

This causes the update to fail.
I have tried individual packages which broke the system. Gave up trying to fix the broken system and clean reinstalled Manjaro Budgie from a freshly downloaded image in the hope this would fix the issue but the issue when updating the system occurred.
I tried a fix I found in the Endeavour forums but this also broke the system.
Any ideas on how to resolve this issue with mutter would be much appreciated.

On unstable here those two packages conflict.
I wonder what the dependency web looks like and which one you need more …

pactree -r mutter43
pactree -r mutter

Mutter is newer than mutter43 so uninstall it first you may have to use sudo pacman -Rdd mutter43

budgie-desktop depends on mutter43 … are you sure it works with mutter (44) ?

Some Gnome Apps need the newer Mutter version. Budgie however is not yet updated to the newer 44 version.

You may have to mark mutter43 as not upgradable in pamac, not sure if that will stop mutter trying to be installed.

  • gnome-shell (requires libmutter-12.so), simply remove that.

Thanks Robin, I’ve marked mutter 43.2-1 as not upgradable. I’m now getting the following conflict:

conflicting dependencies:

  • mutter43 and mutter-x11-scaling are in conflict

Thanks CSCS, As per screen snip below:


Oh you dont have mutter43 currently installed. (your current mutter is version 43)
But the exchange wants to upgrade mutter and install mutter43 … and cant.

Thanks philm, libmutter-12.so isn’t visible in Pamac, what would the terminal command be to remove it? I’m not total familiar with the terminal but happy to follow instructions :slight_smile:

I have tried a few more fixes after a bit googling.
Reading the post below it appears Budgie may have frozen updating mutter due to some issues:

I’m guessing the gnome components Budgie relies on are trying to update beyond what Budgie can?
I have tried the fix mentioned here for Arch users but still get the conflict.

I have also tried a fix from the EndeavourOS forums here:
While it worked the Budgie desktop was unusable after rebooting leaving me with a dark grey screen, right clicking it gave a menu with system settings and Budgie desktop settings options.

Reading Redit here: https://www.reddit.com/r/archlinux/comments/13afa2z/pacman_mutter_conflict/
I can see another Manjaro user having the same issue, but this person appears to have completely removed both budgie and gnome desktops and components, re-installed budgie and then completely updated everything.
Anyone’s thoughts, guidance, or alternative options would be much appreciated. I’m happy to have a go at what this person’s done but would need some instructions if anyone’s willing to provide these?

Hi everyone, I logged back in today to find the desktop was back to being plain grey, no menu’s, no icons & most keyboard shortcuts not working :angry:
It looks like something I had tried yesterday had updated something in the background to get back to this point, anyway nothing to lose with attempting another fix as I was basically running a fresh install of the minimal Budgie image.
@philm your comments about the gnome shell had stuck with me and actually held the answer.
Here’s what I did to fix this:
Updated Budgie: sudo pacman -S budgie
- When asked which budgie options I wanted selected “all” by pressing enter.
- When asked if you want to upgrade to mutter43 select “yes”.
As I was planning to remove gnome and wasn’t sure that the Nautilus terminal would still work after this I installed LXterminal: sudo pacman -S lxterminal
I’m not sure I needed to do this, but just in case…
Next I removed gnome: sudo pacman -Rdd gnome
- Select to remove all by pressing enter
Then updated the system: sudo pacman -Syyu
And it successfully updated!!! :smiley:
Next I updated the Budgie desktop: sudo pacman -S budgie
- Select the default option when asked (#1)
I notice this installed a couple of extra gnome based dependencies at this point.
Then I shut down from the terminal: systemctrl poweroff
On rebooting I had the Budgie desktop back and usable, I notice I’m missing some of the gnome apps like Gcalc, but I can re-install these as needed.

Just a couple of caveats, while I have some understanding of Linux I’m not an expert user, I haven’t fully understood everything actioned here, use at own risk.
I must say this has been a good learning experience, thank you all for everyone’s support - you have all helped in someway :slightly_smiling_face:

1 Like

A post was split to a new topic: Unable to satisfy dependencies updating budgie-desktop

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.