Update causing dualboot failure?

Update yesterday ( sudo pacman -Syyu ) resulting in a failure of the dualboot function in Grub. On booting the only alternative now is Manjaro Linux, not as before Manjaro Linux AND Windows10.
Remembering earlier attempts to “solve” different issues myself I would appreciate some guidance before I have worsened the problem. Thanks!

System info following:

lars@lars-pc ~]$  inxi -Fazy
  Kernel: 4.19.177-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-4.19-x86_64 
  root=UUID=3aff4f56-ceff-40d6-958f-4431518a1485 rw quiet 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop System: LENOVO product: 10126 v: Lenovo H515s serial: <filter> 
  Mobo: LENOVO model: Kabini CRB v: 31900058 STD serial: <filter> UEFI: LENOVO 
  v: I9KT36AUS date: 11/04/2013 
  Info: Dual Core model: AMD E1-2500 APU with Radeon HD Graphics bits: 64 
  type: MCP arch: Jaguar family: 16 (22) model-id: N/A stepping: 1 
  microcode: 700010F L2 cache: 1024 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 5599 
  Speed: 800 MHz min/max: 800/1400 MHz Core speeds (MHz): 1: 800 2: 800 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full AMD retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Kabini [Radeon HD 8240 / R3 Series] vendor: Lenovo 
  driver: radeon v: kernel alternate: amdgpu bus ID: 00:01.0 
  chip ID: 1002:9838 class ID: 0300 
  Display: x11 server: X.Org 1.20.10 driver: loaded: ati,radeon 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1280x1024 s-dpi: 96 s-size: 338x270mm (13.3x10.6") 
  s-diag: 433mm (17") 
  Monitor-1: VGA-0 res: 1280x1024 hz: 60 dpi: 96 size: 337x270mm (13.3x10.6") 
  diag: 432mm (17") 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 4.19.177-1-MANJARO LLVM 11.1.0) 
  v: 4.5 Mesa 20.3.4 direct render: Yes 
  Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:01.1 chip ID: 1002:9840 class ID: 0403 
  Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1022:780d class ID: 0403 
  Sound Server: ALSA v: k4.19.177-1-MANJARO 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo 
  driver: r8169 v: kernel port: e000 bus ID: 01:00.0 chip ID: 10ec:8136 
  class ID: 0200 
  IF: enp1s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8188EE Wireless Network Adapter vendor: Lenovo 
  driver: rtl8188ee v: kernel port: d000 bus ID: 02:00.0 chip ID: 10ec:8179 
  class ID: 0280 
  IF: wlp2s0 state: down mac: <filter> 
  Local Storage: total: 465.76 GiB used: 37.94 GiB (8.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital 
  model: WD5000AAKX-08U6AA0 size: 465.76 GiB block size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1H19 
  scheme: GPT 
  ID-1: / raw size: 143.98 GiB size: 140.72 GiB (97.74%) 
  used: 37.94 GiB (27.0%) fs: ext4 dev: /dev/sda9 maj-min: 8:9 
  ID-2: /boot/efi raw size: 512 MiB size: 511 MiB (99.80%) 
  used: 300 KiB (0.1%) fs: vfat dev: /dev/sda7 maj-min: 8:7 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sda8 maj-min: 8:8 
  System Temperatures: cpu: 49.6 C mobo: N/A gpu: radeon temp: 50.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 141 Uptime: 1h 28m wakeups: 0 Memory: 3.31 GiB 
  used: 1.42 GiB (42.8%) Init: systemd v: 247 Compilers: gcc: 10.2.0 Packages: 
  pacman: 1396 lib: 434 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: xfce4-terminal inxi: 3.3.01 
[lars@lars-pc ~]$

To “/etc/default/grub” manualy adding the line “GRUB_DISABLE_OS_PROBER=false”
and then running in terminal “sudo update-grub” not work?


Thank you, AIGil!
I have tried to follow your instructions but I cannot find GRUB_DISABLE_OS_PROBER=true in the GRUB-file.

Hey @prismaled,
You can add the line if it is not there.

Hi garvitjoshi9!
New problem: even in sudo mode I am not allowed to write into the GRUB-file

sudo nano /etc/default/grub not working?

Isn’t ur user in sudoers group??

Hi Computer_Email23!
Yes, nano opens up the file but refuses me to quit nano accepting the new text.

I am the only user of my computer and sudo should let me make this change, I suppose.

Try ‘sudo su’
Then try to edit…check if it helps

This works, I have added the line in the GRUB-file.
Now, should I “sudo update-grub” as ALGil proposed or is the command different with “sudo su”?

just sudo update-grub

so, this only affected people dual booting?
i have a manjaro only system and a arch linux only system, and none of the two had problems after update.

Would using timeshift to take the system back to an earlier time correct the problem? I’ve been running Manjaro for more than a year as a dual boot with Win 10 with no problems until now. I have an image of the harddrive so I just restored everything. Just afraid to update Manjaro now with this new problem.

Welcome to the forum😃

Yes if u have 2 operating systems then u need to activate os prober, otherwise u r fine.

Welcome to the forum😃

This isn’t a problem & it only takes 1 minute to add the line to grub & update it( if u update ur manjaro installation & after that it directly boots to manjaro, then edit the grub file and add the required line & update grub, u r back to normal again)

If ur problem is solved, pls mark ur favourite & appropriate reply as a solution.

Magic to me! Updating grub solved the problem. Thank you all for your help! :blush:

@prismaled here you go:

Grub got some needed security updates. Note that os-prober is now disabled by default for security reasons: broken patch; fixed patch. More infos about it here. To restore the old behavior, open a terminal and issue echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

Thank you, philm! Dualboot functions now but I will study your commands to get more understanding. Trying to learn.
I hope I closed this topic by writing solved in my latest reply, but perhaps there is some special ikon or rule to use to stamp the question as solved.