[update 04-28] Displays issue after update. 2 gpu's, 2 monitors

Issue appeared just after updating. I have integrated intel graphics and nvidia gpu card gtx 1050 ti. At first launch after update i got login screen on monitor, connected to nvidia card (let’s call it main), and black screen on another monitor(extra), - it’s normal situation. After login main monitor becomes black as extra, and nothing happens.

I didn’t used bumblebee drivers, because all worked well without them. I tried to install bumblebee, but got another problem: main monitor stucks at screen with motherboard manufacturer name, extra monitor is black. But if i connect extra after boot, i get login screen on extra, can login and work, but i can’t setup resolution.

I’ve deleted bumblebee drivers and installed just nvidia drivers. Now i can boot only without extra monitor, and if i connect it after boot, nothing happens.

Graphics:  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics driver: i915 v: kernel 
           Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] driver: nvidia v: 390.143 
           Display: x11 server: X.org 1.20.11 driver: loaded: nvidia resolution: <missing: xdpyinfo> 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.143

The same exact thing happened to me a while ago. Here’s my fix:

I hope it works :grin:

1 Like

Also, if you prefer to switch to only your NVIDIA graphics card and to completely disable your integrated GPU (this greatly increases performance for me), you can install a program called optimus-manager (only works on laptops). Here’s how to install it:

sudo pacman -S optimus-manager

sudo pacman -S optimus-manager-qt

After the install, a little Nvidia icon should appear on your taskbar after a restart. Just right click it to switch!

1 Like

Unfortunately, didn’t work. It’s situation with just bumblebee installation described below - main doesn’t work, extra works if it’s connected after boot.

I can’t disable integrated gpu, because it is connected to extra monitor.

By the way, about your method of disabling integrated gpu. Maybe you didn’t know, you can disable it in bios settings.

Why? video-hybrid-intel-nvidia-prime works fine on a GTX 1050 TI…


I suppose, bumblebee is not prime. I don’t have prime in recommended drivers list.

  • Print this page so you have it as a reference while in TTY2

  • Log off

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

    sudo mhwd-kernel --install linux54
    sudo mhwd-kernel --install linux510
    sudo mhwd --listinstalled
  • remove everything that the last command showed you with the following command:

    sudo mhwd --remove pci szEveryDriverOnePerLine
  • Now install Intel-nVidia prime:

    sudo mhwd --install pci video-hybrid-intel-nvidia-prime
  • to ensure grub is showing, execute:

    sudo nano --backup /etc/default/grub
  • Change (or add?) the following 3 lines:


    (3 or higher is fine, add the # before the lines above if those lines are present)

  • Ctrl+X Y Enter to save if there is anything to save

  • If you did save, execute:

    sudo update-grub
  • Reboot

  • Go to grub’s Advanced options

  • Choose the LTS kernels above and try them out one by one and see if that helps.


Try to install video-hybrid-intel-nvidia-prime, i get “Error: config ‘video-hybrid-intel-nvidia-prime’ does not exist!”

Tried to install bumblebee, not prime, then started every mentioned kernels, nothing happened. Just as always only extra monitor works.

Interesting thing.

I had feeling, that problem is with desktop/monitor/screen initialization or something like that. I removed all drivers, installed only video-linux and video-modesetting. After that i went to bios settings, set primary display, which is connected to IGPU (integrated, intel in my case, extra monitor, mentioned above), rebooted. And it worked.

After that i tried to install bumblebee, got nothing new. Then i installed just nvidia driver, and system loaded successfully. I’ll test performance and edit this post.

I wonder, if it’s a solution? Because i still don’t know, how does it work.

It is for your hardware, so I’ve marked it as such.

In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

I didn’t mark it, because i wanted to test it. I couldn’t boot today morning. Means, still searching for solution.

Now if i disconnect extra, manjaro boots successful, main monitor works and then i connect extra and it works too. But if i boot with two monitors connected, none of them works, it can’t boot. And there are some problems with resolution on extra monitor. Manjaro determines it as “unknown display”.

How did you install prime? I can’t see it in recommended drivers list…

This is weird indeed as Fabby said, this 1050 card should be compatible with latest driver, and should then have the prime hybrid drivers available.

What does pacman -Qs nvidia report?

1 Like

Although you can disable it in BIOS, I use optimus-manager because it has the feature to only use my Dedicated GPU when my laptop is plugged into a power source, and it switches to only using my Integrated GPU when the laptop is running off of it’s battery. which greatly increases my battery life.

Also, I did some research, and Optimus Manager is incompatible with bumblebee, so that is probably why Optimus Manager didn’t work.

If you go to Hardware Manager in settings, is video-hybrid-intel-nvidia-prime an option that shows up under the display controller menu or any menus under the display controller menu? If not that is probably why the installer didn’t recognize video-hybrid-intel-nvidia-prime as an option.

I didn’t: I run on nVidia only on a 1070 TI, but according to your inxi and nVidia that combination does work…


~ >>> pacman -Qs nvidia                                                        
local/egl-wayland 1.1.6-1
    EGLStream-based Wayland external platform
local/lib32-libvdpau 1.4-1
    Nvidia VDPAU library
local/lib32-nvidia-390xx-utils 390.143-1
    NVIDIA drivers utilities (32-bit)
local/libvdpau 1.4-1
    Nvidia VDPAU library
local/linux510-nvidia-390xx 390.143-2 (linux510-extramodules)
    NVIDIA drivers for linux.
local/linux54-nvidia-390xx 390.143-2 (linux54-extramodules)
    NVIDIA drivers for linux.
local/linux59-nvidia-390xx 390.143-1 (linux59-extramodules)
    NVIDIA drivers for linux.
local/mhwd-nvidia 460.73.01-1
    MHWD module-ids for nvidia 460.73.01
local/mhwd-nvidia-340xx 340.108-1
    MHWD module-ids for nvidia 340.108
local/mhwd-nvidia-390xx 390.143-1
    MHWD module-ids for nvidia 390.143
local/nvidia-390xx-utils 390.143-1
    NVIDIA drivers utilities
local/xf86-video-nouveau 1.0.17-1 (xorg-drivers)
    Open Source 3D acceleration driver for nVidia cards

No, it does not. Bumblebee 390, nvidia 390 and standard set of open source linux drivers (video linux, modesetting and vesa)

I see you have kernel 5.9 it is not supported anymore. Are you still running this kernel? This shouldn’t be related to your issue but just in case I would remove it and run 5.10 if it is not already done.

Please give the output of inxi -Fazy for full proper inxi (and when you paste it in your reply, select it, and click the </> button to format it correctly, not like in your initial inxi where you have made some weird thing the output is not like it should)

I see you have the Nvidia 460 IDs for MHWD installed so it should have what it needs to recognize your video card and give you the option to install Prime, hence the full inxi report needed to be sure of your hardware ID.

Can you also post the output of cat /var/lib/mhwd/ids/pci/nvidia.ids

1 Like

I’ve installed 5.10

~ >>> sudo inxi -Fazy                                                          
  Kernel: 5.10.32-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=17bb424a-dc17-48af-a2d3-e4ea97264bee rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.29 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: Gigabyte model: Z87-HD3 v: x.x serial: N/A 
  UEFI: American Megatrends v: F8 date: 08/12/2014 
  Info: Quad Core model: Intel Core i7-4790K bits: 64 type: MT MCP 
  arch: Haswell family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: 
  L1: 256 KiB L2: 8 MiB L3: 8 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 63849 
  Speed: 4375 MHz min/max: 800/4400 MHz base/boost: 4200/7000 volts: 1.1 V 
  ext-clock: 100 MHz Core speeds (MHz): 1: 4375 2: 4385 3: 4378 4: 4391 
  5: 4390 6: 4387 7: 4385 8: 4389 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: Gigabyte driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0412 
  class-ID: 0300 
  Device-2: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: Micro-Star MSI 
  driver: nvidia v: 390.143 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
  chip-ID: 10de:1c82 class-ID: 0300 
  Display: server: X.org 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia unloaded: nouveau alternate: fbdev,intel,nv,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.143 
  direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c 
  class-ID: 0403 
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 
  class-ID: 0403 
  Device-3: NVIDIA GP107GL High Definition Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fb9 
  class-ID: 0403 
  Device-4: C-Media USB Audio Device type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-9:5 chip-ID: 0d8c:0012 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.10.32-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.26 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Gigabyte driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
  Local Storage: total: 1.24 TiB used: 39.14 GiB (3.1%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Plextor model: PX-128M5S 
  size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 1.05 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Kingston model: SA400S37240G 
  size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: 0010 scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Western Digital 
  model: WD1003FZEX-00K3CA0 size: 931.51 GiB block-size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 
  scheme: MBR 
  ID-1: / raw-size: 223.27 GiB size: 218.77 GiB (97.98%) 
  used: 39.14 GiB (17.9%) fs: ext4 block-size: 4096 B dev: /dev/sdb2 
  maj-min: 8:18 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat block-size: 512 B dev: /dev/sdb1 maj-min: 8:17 
  Alert: No swap data was found. 
  System Temperatures: cpu: 30.0 C mobo: 29.8 C gpu: nvidia temp: 34 C 
  Fan Speeds (RPM): cpu: 793 fan-2: 0 fan-3: 0 fan-4: 0 fan-5: 0 gpu: nvidia 
  fan: 45% 
  Power: 12v: N/A 5v: N/A 3.3v: N/A vbat: 3.24 
  Processes: 264 Uptime: 2m wakeups: 0 Memory: 15.46 GiB 
  used: 1.92 GiB (12.4%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 Packages: 1346 pacman: 1330 lib: 388 flatpak: 9 snap: 7 
  Shell: Zsh (sudo) v: 5.8 running-in: gnome-terminal inxi: 3.3.04 
~ >>> sudo cat /var/lib/mhwd/ids/pci/nvidia.ids                                                                              
# List generated by mhwd. Do not edit manually.
0fc0 0fc1 0fc2 0fc6 0fc8 0fc9 0ff3 0ff9 0ffa 0ffd 0ffe 0fff 1001 1004 1005 1007 1008 100a 100c 1021 1022 1023 1024 1026 1027 1028 1029 102a 102d 103a 103c 1180 1183 1184 1185 1187 1188 1189 118a 118e 118f 1193 1194 1195 11b4 11ba 11c0 11c2 11c3 11c4 11c5 11c6 11c8 11cb 11fa 1280 1281 1282 1284 1286 1287 1288 1289 128b 1340 1341 1344 1346 1347 1348 1349 134b 134d 134e 134f 137b 1380 1381 1382 1390 1391 1392 1393 1398 1399 139a 139b 139c 139d 13b0 13b1 13b2 13b3 13b4 13b6 13b9 13ba 13bb 13bc 13c0 13c2 13d7 13d8 13d9 13da 13f0 13f1 13f2 13f3 13f8 13f9 13fa 13fb 1401 1402 1406 1407 1427 1430 1431 1436 15f0 15f7 15f8 15f9 1617 1618 1619 161a 1667 174d 174e 179c 17c2 17c8 17f0 17f1 17fd 1b00 1b02 1b06 1b30 1b38 1b80 1b81 1b82 1b83 1b84 1b87 1ba0 1ba1 1ba2 1bb0 1bb1 1bb3 1bb4 1bb5 1bb6 1bb7 1bb8 1bb9 1bbb 1bc7 1be0 1be1 1c02 1c03 1c04 1c06 1c07 1c09 1c20 1c21 1c22 1c23 1c30 1c31 1c60 1c61 1c62 1c81 1c82 1c83 1c8c 1c8d 1c8f 1c90 1c91 1c92 1c94 1c96 1cb1 1cb2 1cb3 1cb6 1cba 1cbb 1cbc 1cbd 1cfa 1cfb 1d01 1d02 1d10 1d11 1d12 1d13 1d16 1d33 1d34 1d52 1d81 1db1 1db3 1db4 1db5 1db6 1db7 1db8 1dba 1df0 1df2 1df5 1df6 1e02 1e04 1e07 1e30 1e36 1e81 1e82 1e84 1e87 1e89 1e90 1e91 1e93 1eb0 1eb1 1eb5 1eb6 1eb8 1ec2 1ec7 1ed0 1ed1 1ed3 1ef5 1f02 1f06 1f07 1f08 1f09 1f0a 1f0b 1f10 1f11 1f12 1f14 1f15 1f36 1f42 1f47 1f50 1f51 1f54 1f55 1f76 1f82 1f91 1f95 1f96 1f97 1f98 1f99 1f9c 1f9d 1fb8 1fb9 1fbb 1fdd 1ff9 20b0 2182 2184 2187 2188 2189 2191 2192 21c4 21d1 2204 2206 2484 2486 249c 249d 24dc 24dd 2503 2520 2560 1140 11a0 11b6%

Interesting moment. If i try to load with 2 monitors connected, i get main monitor with gigabyte picture stuck and black extra monitor. Then i press power off button and get power off console on main monitor and gigabyte picture on extra with 3 dots (like loading). Computer shuts down correctly.

I though I replied the other day but I guess not.

Your GPU is definitely in the list and should theoretically allow Prime install with the latest drivers

But I also noticed recently on a friend computer that MHWD GUI tool wasn’t presenting the option for Nvidia 390 to him, and back then I installed manually Nvidia 340 for my friend, but the other day while trying to troubleshoot why he couldn’t have proper tear free experience on his computer anymore after an update, I removed everything regarding Nvidia, removed video-linux from MHWD, and after restarting the MHWD GUI tool, the option to install Nvidia 390 was there… I don’t know what unlocked the situation, but doing these steps seemed to have refreshed something somewhere and allowed the installation which was not possible before…

Try to do some random steps like I did, remove everything, restart the tool, and see if Prime magically appears in the list of available drivers to install. Make a restoration point from Timeshift, of a working state of your Manjaro installation, and try to mess with it (this way you can restore computer to previous state if you really mess something in the process).

Your goal (to me) is to install Prime drivers, I wouldn’t stick to and try to troubleshoot the outdated 390 driver with Bumblebee…

//EDIT: did you try to manually install from terminal the video-hybrid-intel-nvidia-prime driver? command should be something like sudo mhwd -i pci video-hybrid-intel-nvidia-prime