Unstable Wifi conection recently

Hi all,

Recently the Wifi connection has been quite unstable, even the signals of the two Wifies I connect are strong. Previously I thought it was the wifi’s problem, but I realised that when my PC failed to connect to the internet, my phone connected with the same wifi worked normally.

If I switch to another wifi, it works sometimes. So the safer way is to disable the wifi and enable it again, but it won’t last long. So I usually connect my phone’s hotspot.


Some information:

KDE Plasma Version: 5.27.11
KDE Frameworks Version: 5.115.0
Qt Version: 5.15.12

$ uname -a
Linux mBio 6.6.19-1-MANJARO #1 SMP PREEMPT_DYNAMIC Fri Mar  1 18:16:16 UTC 2024 x86_64 GNU/Linux

$ sudo lshw -c network
       description: Wireless interface
       product: QCNFA765 Wireless Network Adapter
       vendor: Qualcomm Technologies, Inc
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlp1s0
       version: 01
       serial: 04:7b:cb:b2:4e:10
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath11k_pci driverversion=6.6.19-1-MANJARO firmware=N/A ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:91 memory:98000000-981fffff

Hi @shenwei356,

I see this is not your first post, so why didn’t you provide the required information:

From the tutorial: [HowTo] Provide System Information:

So please, we need the information specified there, starting with:

inxi --full --admin --filter --width

Sorry, I didn’t know that rule. Here are more details:

$ inxi --full --admin --filter --width
  Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: hpet avail: acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=3e1bd41d-01aa-436b-a9d0-6b5b401365b4 rw quiet splash
  Desktop: KDE Plasma v: 5.27.11 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_wayland vt: 1 dm: 1: LightDM v: 1.32.0 note: stopped
    2: SDDM Distro: Manjaro base: Arch Linux
  Type: Laptop System: LENOVO product: 21CMA001CD v: ThinkPad X13 Gen 3
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 21CMA001CD v: ThinkPad serial: <superuser required>
    part-nu: LENOVO_MT_21CM_BU_Think_FM_ThinkPad X13 Gen 3
    uuid: <superuser required> UEFI: LENOVO v: R22ET49W (1.19 )
    date: 06/24/2022
  ID-1: BAT0 charge: 49.8 Wh (100.0%) condition: 49.8/54.7 Wh (91.0%)
    volts: 17.3 min: 15.4 model: Sunwoda LNV-5B10W51855�� type: Li-poly
    serial: <filter> status: full cycles: 76
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse B330/M330/M331
    serial: <filter> charge: 55% (should be ignored) rechargeable: yes
    status: discharging
  Info: model: AMD Ryzen 7 PRO 6850U with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 3+ gen: 4 level: v3 note: check built: 2022 process: TSMC n6 (7nm)
    family: 0x19 (25) model-id: 0x44 (68) stepping: 1 microcode: 0xA404102
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB
    desc: 1x16 MiB
  Speed (MHz): avg: 836 high: 1400 min/max: 400/4768 scaling:
    driver: amd-pstate-epp governor: powersave cores: 1: 400 2: 400 3: 400
    4: 1397 5: 1400 6: 400 7: 1397 8: 1397 9: 400 10: 1397 11: 400 12: 1397
    13: 400 14: 400 15: 400 16: 1397 bogomips: 86284
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Vulnerable: Safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: HDMI-A-1 off: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, DP-5, DP-6 bus-ID: 33:00.0 chip-ID: 1002:1681
    class-ID: 0300 temp: 39.0 C
  Device-2: Bison Integrated Camera driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 5-1:2 chip-ID: 5986:2148
    class-ID: 0e02
  Display: wayland server: X.org v: with: Xwayland v: 23.2.4
    compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: HDMI-A-1 res: 2560x1440 size: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
    device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
    drv: radeonsi inactive: gbm
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 24.0.2-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: AMD Radeon Graphics (radeonsi
    rembrandt LLVM 16.0.6 DRM 3.54 6.6.19-1-MANJARO) device-ID: 1002:1681
    memory: 1000 MiB unified: no display-ID: :1.0
  API: Vulkan v: 1.3.279 layers: 4 device: 0 type: integrated-gpu name: AMD
    Radeon Graphics (RADV REMBRANDT) driver: mesa radv v: 24.0.2-manjaro1.1
    device-ID: 1002:1681 surfaces: xcb,xlib,wayland
  Device-1: AMD Rembrandt Radeon High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 33:00.1 chip-ID: 1002:1640 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Lenovo
    driver: snd_pci_acp6x v: kernel alternate: snd_pci_acp3x, snd_rn_pci_acp3x,
    snd_pci_acp5x, snd_acp_pci, snd_rpl_pci_acp6x, snd_pci_ps,
    snd_sof_amd_renoir, snd_sof_amd_rembrandt, snd_sof_amd_vangogh pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 33:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: Lenovo driver: snd_hda_intel
    v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 33:00.6
    chip-ID: 1022:15e3 class-ID: 0403
  API: ALSA v: k6.6.19-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pw-jack type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Qualcomm QCNFA765 Wireless Network Adapter vendor: Lenovo
    driver: ath11k_pci v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 link-max:
    gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 17cb:1103 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  Info: services: NetworkManager, systemd-timesyncd, wpa_supplicant
  Device-1: USI driver: btusb v: 0.8 type: USB rev: 1.1 speed: 12 Mb/s lanes: 1
    mode: 1.1 bus-ID: 1-3.1:3 chip-ID: 10ab:9309 class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 5.3
    lmp-v: 12 status: discoverable: no pairing: no class-ID: 6c010c
  Local Storage: total: 1.82 TiB used: 477.49 GiB (25.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO 2TB
    size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 3B2QJXD7 temp: 37.9 C
    scheme: GPT
  ID-1: / raw-size: 80 GiB size: 78.19 GiB (97.74%) used: 39.64 GiB (50.7%)
    fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p4 maj-min: 259:4
  ID-3: /home raw-size: 1.72 TiB size: 1.69 TiB (98.37%)
    used: 437.85 GiB (25.3%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) zswap: yes
    compressor: zstd max-pool: 20%
  ID-1: swap-1 type: partition size: 20 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/nvme0n1p1 maj-min: 259:1
  System Temperatures: cpu: 41.0 C mobo: N/A gpu: amdgpu temp: 40.0 C
  Fan Speeds (rpm): fan-1: 0
  Memory: total: 16 GiB note: est. available: 14.4 GiB used: 5.75 GiB (39.9%)
  Processes: 386 Power: uptime: 1h 9m states: freeze,mem,disk suspend: s2idle
    wakeups: 0 hibernate: platform avail: shutdown, reboot, suspend, test_resume
    image: 5.75 GiB services: org_kde_powerdevil, power-profiles-daemon,
    upowerd Init: systemd v: 255 default: graphical tool: systemctl
  Packages: pm: pacman pkgs: 1918 libs: 514 tools: pamac,yay pm: flatpak
    pkgs: 0 Compilers: clang: 16.0.6 gcc: 13.2.1 Shell: Bash v: 5.2.26
    running-in: yakuake inxi: 3.3.33

According to Qualcomm QCNFA765 Wireless Network Adapter :

The device is supported by kernel versions 5.14 and newer according to the LKDDb

So I don’t know what to suggest, except perhaps trying a different kernel, perhaps 6.1:

sudo mhwd-kernel --install linux61

And reboot into it :

All available kernels installed on your system will be presented upon booting up. GNU GRUB is visible with a couple of options. Choose “Advanced Options for Manjaro Linux” by using the arrow keys on your keyboard and then ↵ Enter.

On the next screen (as illustrated) are backup copies of each kernel version installed (which will also be automatically removed if or when a kernel version is deleted). To select a kernel, simply use the arrow keys to highlight the desired version, and then press ↵ Enter.

Unfortunately, it does not help. It might be still the wifi’s problem. The Wifi is weak but stable at home (sorry I forgot to mention this.).

Then I can honestly think of nothing further to do, especially if it works even with a weaker signal elsewhere. Makes me think it’s not your Manjaro or even your PC.

Have you tried a different channel, if possible? It could be bluetooth interference (I think.)

Good point, but they are two public WIFIs, which I can’t configure the channel. I reported this to the IT colleagues days ago, while it’s not helpful.
I appreciate your help.

It could also be a poor quality interface; it seems to be an Atheros chipset which is generally good, but it could also be from the lower end of their product line.

Apart from that possibility, and as @Mirdarthos suggests, the cause likely falls back to your environment; which we can’t help much with.