[Unstable Update] December 2023 Edition

Whatever was changed between yesterday and today has brought my reboot-on-shutdown issues back. Nothing in the last session logs, but the same MCEs as previously in the reboot after:

[    1.047089] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 5: bea0000001000108
[    1.047090] mce: [Hardware Error]: TSC 0 
[    1.047091] ADDR ffffffa10ef9f0 
[    1.047097] MISC d012000100000000 SYND 4d000000 IPID 500b000000000 
[    1.047098] mce: [Hardware Error]: PROCESSOR 2:a20f10 TIME 1702506399 SOCKET 0 APIC 0 microcode a20102b

Edit: Interestingly, I cannot recreate that failed shutdown again. What I had updated in that session were these:

[2023-12-13T17:44:51+0200] [ALPM] upgraded thin-provisioning-tools (1.0.9-1 -> 1.0.9-2)
[2023-12-13T17:44:51+0200] [ALPM] upgraded thunderbird (115.5.1-1 -> 115.5.2-1)
[2023-12-13T17:44:51+0200] [ALPM] upgraded thunderbird-i18n-en-gb (115.5.1-1 -> 115.5.2-1)
[2023-12-13T17:44:51+0200] [ALPM] upgraded thunderbird-i18n-en-us (115.5.1-1 -> 115.5.2-1)
[2023-12-13T17:44:51+0200] [ALPM] upgraded thunderbird-i18n-fi (115.5.1-1 -> 115.5.2-1)
...
[2023-12-14T00:25:51+0200] [ALPM] upgraded lib32-libdrm (2.4.117-1 -> 2.4.118-1)
[2023-12-14T00:25:51+0200] [ALPM] upgraded xorg-server-common (21.1.9-1 -> 21.1.10-1)
[2023-12-14T00:25:51+0200] [ALPM] upgraded xorg-server (21.1.9-1 -> 21.1.10-1)

Perhaps some of these were relevant, in one way or another.

Is it normal to have this message on non GNOME desktops ? I think the message talks about GNOME extensions while I’m running Plasma.

yay -S pamac-gtk3                                                                                                                                                   
...
==> Enable Pamac Updates Indicator via
    Extensions
...

Good catch. I’ll remove that bit with pamac-gtk3 10.6.0-3.

1 Like

A post was split to a new topic: Issues with Libadwaita / GTK4 applications

The current update gives the following error:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing icu (74.2-1) breaks dependency 'icu<74.2' required by manjaro-settings-manager

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

The icu 74 rebuilds were just pushed. Wait for your mirror(s) to sync.

On Intel iGPU, latest mesa 23.3.1-1 breaks all pure GTK4 and libAdwaita apps.

It’s fixed by downgrading mesa (1:23.3.1-1 -> 1:23.1.9-1)

6 posts were split to a new topic: File not found during Plymouth mkinitcpio build hook

A post was merged into an existing topic: File not found during Plymouth mkinitcpio build hook

Which one’s in the wrong here?

warning: directory permissions differ on /usr/share/polkit-1/rules.d/
filesystem: 750  package: 755

Usually with those warnings you follow the package unless you know better.

:information_source: I’ve downgraded filesystem back to 2023.09.22-1 and plymouth back to 22.02.122-14 due to issues with the new Plymouth version 23. They both must be downgraded at the same time as the two packages are interdependent on one another.

What about us who don’t use plymouth? Best to downgrade anyway? I see other packages relying on filesystem.

If I’m correct the only change on filesystem was adding a logo to it.

Yes. plymouth depends on filesystem. There were changes with the newer versions that go together, so both must be downgraded together to match.

Not quite. The logo was moved from plymouth to filesystem, that’s why the old and new packages must be downgraded / upgraded together.

750 is correct in this case. So we have to figure out which package is not matching that folder via pacman -Qo /usr/share/polkit-1/rules.d

1 Like

On my both laptops, I installed 3 years ago Manjaro KDE via Minimal ISO,

But now I don’t find plymouth installed nor configured in /etc/default/grub nor HOOKS in /etc/mkinitcpio.conf
Even /var/log/pacman.log doesn’t contain any install/remove/upgrade related to it,

Was it added later ? And should I add it to avoid problems ?

plymouth is entirely optional, in fact it sometimes causes problems, and is one of the first things I would remove.

4 Likes

:information_source: I’ve just made major changes with plymouth 22.02.122-17 that removed the old unneeded cruft in preparation for the new upstream v23.51.283:

:warning: WARNING: The plymouth-encrypt and sd-plymouth hooks no longer exist in the package. You should replace them with encrypt and plymouth hooks in your mkinitcpio.conf. The lxdm-plymouth.service, lightdm-plymouth.service and sddm-plymouth.service systemd service files no longer exist in the package. You should enable lxdm.service, lightdm.service or sddm.service instead.

A post was split to a new topic: The package grub-update does NOT need to be required by grub