File not found during Plymouth mkinitcpio build hook

Result of mkinitcpio -P:

==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64.img --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
==> ERROR: file not found: '/usr/share/plymouth/manjaro-logo.png'
==> ERROR: file not found: '/usr/lib/plymouth//label.so'
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64-fallback.img -S autodetect --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
==> ERROR: file not found: '/usr/share/plymouth/manjaro-logo.png'
==> ERROR: file not found: '/usr/lib/plymouth//label.so'
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64-fallback.img'
==> WARNING: errors were encountered during the build. The image may not be complete.

Result of pacman -Ql filesystem | grep logo:

filesystem /usr/share/pixmaps/manjaro-logo-text-dark.png
filesystem /usr/share/pixmaps/manjaro-logo.png

Based on those errors some is off. @Yochanan can you check again on your system if you see similar errors?

@Alden20 can you confirm if you stay on testing branch that you don’t have those issues?

I confirm that the testing branch does not give the error:

rondo-um580% sudo manjaro-downgrade plymouth     
:: Retrieving packages...
 plymouth-22.02.122-15-x86_64          1056,7 KiB  1360 KiB/s 00:01 [######################################] 100%
loading packages...
warning: downgrading package plymouth (23.51.283-1 => 22.02.122-15)
resolving dependencies...
looking for conflicting packages...

Packages (1) plymouth-22.02.122-15

Total Installed Size:   1,89 MiB
Net Upgrade Size:      -0,25 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                      [######################################] 100%
(1/1) checking package integrity                                    [######################################] 100%
(1/1) loading package files                                         [######################################] 100%
(1/1) checking for file conflicts                                   [######################################] 100%
(1/1) checking available disk space                                 [######################################] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
First run mode (config file not found)
Selected default snapshot type: BTRFS
Using system disk as snapshot device for creating snapshots in BTRFS mode
Mounted '/dev/nvme0n1p2' at '/run/timeshift/37497/backup'
btrfs: Quotas are not enabled
Creating new backup...(BTRFS)
Saving to device: /dev/nvme0n1p2, mounted at path: /run/timeshift/37497/backup
Created directory: /run/timeshift/37497/backup/timeshift-btrfs/snapshots/2023-12-21_01-11-35
Created subvolume snapshot: /run/timeshift/37497/backup/timeshift-btrfs/snapshots/2023-12-21_01-11-35/@
Created control file: /run/timeshift/37497/backup/timeshift-btrfs/snapshots/2023-12-21_01-11-35/info.json
BTRFS Snapshot saved successfully (0s)
Tagged snapshot '2023-12-21_01-11-35': ondemand
------------------------------------------------------------------------------
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.6-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.6-x86_64.img
Found initrd fallback image: /boot/initramfs-6.6-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-12-21 01:11:35 | timeshift-btrfs/snapshots/2023-12-21_01-11-35/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-12-21 00:30:06 | timeshift-btrfs/snapshots/2023-12-21_00-30-06/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found 2 snapshot(s)
Unmount /tmp/grub-btrfs.ZjiHH8InBq .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done
:: Processing package changes...
(1/1) downgrading plymouth                                          [######################################] 100%
:: Running post-transaction hooks...
(1/4) Reloading system manager configuration...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64.img --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64.img'
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64-fallback.img -S autodetect --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64-fallback.img'
==> Image generation successful
(4/4) Refreshing PackageKit...

I’ll do some further investigating…

EDIT: Eureka! I think I figured it out… Fix incoming…

EDIT @Alden20 plymouth 23.51.283-2 should fix the issue.

I’m sorry, but it continues failing:

rondo-um580% sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syu
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  1.831 Taiwan         : https://mirror.archlinux.tw/Manjaro/
  1.249 Switzerland    : https://mirror.init7.net/manjaro/
  0.092 Global         : https://mirrors2.manjaro.org/
  0.371 United_Kingdom : http://manjaro.mirrors.uk2.net/
  0.444 Germany        : https://ftp.gwdg.de/pub/linux/manjaro/
::INFO Writing mirror list
::Global          : https://mirrors2.manjaro.org/unstable
::United_Kingdom  : http://manjaro.mirrors.uk2.net/unstable
::Germany         : https://ftp.gwdg.de/pub/linux/manjaro/unstable
::Switzerland     : https://mirror.init7.net/manjaro/unstable
::Taiwan          : https://mirror.archlinux.tw/Manjaro/unstable
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronizing package databases...
 core is up to date
 extra                                    8,6 MiB  22,3 MiB/s 00:00 [######################################] 100%
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (2) libheif-1.17.6-1  plymouth-23.51.283-2

Total Download Size:   1,46 MiB
Total Installed Size:  3,36 MiB
Net Upgrade Size:      0,25 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 plymouth-23.51.283-2-x86_64           1120,2 KiB  4,91 MiB/s 00:00 [######################################] 100%
 libheif-1.17.6-1-x86_64                371,8 KiB  8,44 MiB/s 00:00 [######################################] 100%
 Total (2/2)                           1492,1 KiB  3,80 MiB/s 00:00 [######################################] 100%
(2/2) checking keys in keyring                                      [######################################] 100%
(2/2) checking package integrity                                    [######################################] 100%
(2/2) loading package files                                         [######################################] 100%
(2/2) checking for file conflicts                                   [######################################] 100%
(2/2) checking available disk space                                 [######################################] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
First run mode (config file not found)
Selected default snapshot type: BTRFS
Using system disk as snapshot device for creating snapshots in BTRFS mode
Mounted '/dev/nvme0n1p2' at '/run/timeshift/55359/backup'
btrfs: Quotas are not enabled
Creating new backup...(BTRFS)
Saving to device: /dev/nvme0n1p2, mounted at path: /run/timeshift/55359/backup
Created directory: /run/timeshift/55359/backup/timeshift-btrfs/snapshots/2023-12-21_01-40-00
Created subvolume snapshot: /run/timeshift/55359/backup/timeshift-btrfs/snapshots/2023-12-21_01-40-00/@
Created control file: /run/timeshift/55359/backup/timeshift-btrfs/snapshots/2023-12-21_01-40-00/info.json
BTRFS Snapshot saved successfully (0s)
Tagged snapshot '2023-12-21_01-40-00': ondemand
------------------------------------------------------------------------------
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.6-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.6-x86_64.img
Found initrd fallback image: /boot/initramfs-6.6-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-12-21 01:40:00 | timeshift-btrfs/snapshots/2023-12-21_01-40-00/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-12-21 01:11:35 | timeshift-btrfs/snapshots/2023-12-21_01-11-35/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-12-21 00:30:06 | timeshift-btrfs/snapshots/2023-12-21_00-30-06/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found 3 snapshot(s)
Unmount /tmp/grub-btrfs.IxcgxxBDe3 .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done
:: Processing package changes...
(1/2) upgrading libheif                                             [######################################] 100%
(2/2) upgrading plymouth                                            [######################################] 100%
:: Running post-transaction hooks...
(1/5) Reloading system manager configuration...
(2/5) Arming ConditionNeedsUpdate...
(3/5) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64.img --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
==> ERROR: file not found: '/usr/share/plymouth/pixmaps/manjaro-logo.png'
==> ERROR: file not found: '/usr/lib/plymouth//label.so'
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64-fallback.img -S autodetect --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
==> ERROR: file not found: '/usr/share/plymouth/pixmaps/manjaro-logo.png'
==> ERROR: file not found: '/usr/lib/plymouth//label.so'
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64-fallback.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
error: command failed to execute correctly
(4/5) Refreshing PackageKit...
(5/5) Probing GDK-Pixbuf loader modules...

Er… sorry. How about 23.51.283-3? That fixes the logo location, anyway.

I still have no idea where that’s coming from.

OK, I confirm you the logo location is fixed, and as you say, the other error is pending of resolution:

rondo-um580% sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syu
::INFO Downloading mirrors from Manjaro
::INFO => Mirror pool: https://repo.manjaro.org/mirrors.json
::INFO => Mirror status: https://repo.manjaro.org/status.json
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  0.517 United_States  : https://coresite.mm.fcix.net/manjaro/
  0.077 Global         : https://mirrors2.manjaro.org/
  0.581 United_States  : https://uvermont.mm.fcix.net/manjaro/
  0.111 Global         : https://mirrors.manjaro.org/repo/
  ..... Japan          : http://ftp.tsukuba.wide.ad.jp/Linux/manjaro/
::INFO Writing mirror list
::Global          : https://mirrors2.manjaro.org/unstable
::Global          : https://mirrors.manjaro.org/repo/unstable
::United_States   : https://coresite.mm.fcix.net/manjaro/unstable
::United_States   : https://uvermont.mm.fcix.net/manjaro/unstable
::Japan           : http://ftp.tsukuba.wide.ad.jp/Linux/manjaro/unstable
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronizing package databases...
 core is up to date
 extra                                    8,6 MiB  16,5 MiB/s 00:01 [######################################] 100%
 multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) plymouth-23.51.283-3

Total Download Size:   1,09 MiB
Total Installed Size:  2,14 MiB
Net Upgrade Size:      0,00 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 plymouth-23.51.283-3-x86_64           1120,2 KiB  2,83 MiB/s 00:00 [######################################] 100%
(1/1) checking keys in keyring                                      [######################################] 100%
(1/1) checking package integrity                                    [######################################] 100%
(1/1) loading package files                                         [######################################] 100%
(1/1) checking for file conflicts                                   [######################################] 100%
(1/1) checking available disk space                                 [######################################] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
First run mode (config file not found)
Selected default snapshot type: BTRFS
Using system disk as snapshot device for creating snapshots in BTRFS mode
Mounted '/dev/nvme0n1p2' at '/run/timeshift/73187/backup'
btrfs: Quotas are not enabled
Creating new backup...(BTRFS)
Saving to device: /dev/nvme0n1p2, mounted at path: /run/timeshift/73187/backup
Created directory: /run/timeshift/73187/backup/timeshift-btrfs/snapshots/2023-12-21_01-54-02
Created subvolume snapshot: /run/timeshift/73187/backup/timeshift-btrfs/snapshots/2023-12-21_01-54-02/@
Created control file: /run/timeshift/73187/backup/timeshift-btrfs/snapshots/2023-12-21_01-54-02/info.json
BTRFS Snapshot saved successfully (0s)
Tagged snapshot '2023-12-21_01-54-02': ondemand
------------------------------------------------------------------------------
First run mode (config file not found)
Selected default snapshot type: BTRFS
Mounted '/dev/nvme0n1p2' at '/run/timeshift/73328/backup'
btrfs: Quotas are not enabled
Selected default snapshot device: /dev/nvme0n1p2
------------------------------------------------------------------------------
Removing snapshot: 2023-12-21_00-30-06
Deleting subvolume: @ (Id:260)
Deleted subvolume: @ (Id:260)

Deleted directory: /run/timeshift/73328/backup/timeshift-btrfs/snapshots/2023-12-21_00-30-06
Removed snapshot: 2023-12-21_00-30-06
------------------------------------------------------------------------------
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-6.6-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-6.6-x86_64.img
Found initrd fallback image: /boot/initramfs-6.6-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
Adding boot menu entry for UEFI Firmware Settings ...
Detecting snapshots ...
Found snapshot: 2023-12-21 01:54:02 | timeshift-btrfs/snapshots/2023-12-21_01-54-02/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-12-21 01:40:00 | timeshift-btrfs/snapshots/2023-12-21_01-40-00/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found snapshot: 2023-12-21 01:11:35 | timeshift-btrfs/snapshots/2023-12-21_01-11-35/@ | ondemand | {timeshift-autosnap} {created before upgrade} |
Found 3 snapshot(s)
Unmount /tmp/grub-btrfs.hdDfEGVKly .. Success
Found memtest86+ image: /boot/memtest86+/memtest.bin
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe: warning: unknown device type nvme0n1.
done
:: Processing package changes...
(1/1) upgrading plymouth                                            [######################################] 100%
:: Running post-transaction hooks...
(1/4) Reloading system manager configuration...
(2/4) Arming ConditionNeedsUpdate...
(3/4) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64.img --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
==> ERROR: file not found: '/usr/lib/plymouth//label.so'
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64-fallback.img -S autodetect --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-5-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [plymouth]
==> ERROR: file not found: '/usr/lib/plymouth//label.so'
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64-fallback.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
error: command failed to execute correctly
(4/4) Refreshing PackageKit...

Theres a typo or some other error in parsing the data … double slashes.

That’s a fair guess, however /usr/lib/plymouth/label.so is no longer part of plymouth as of 23.51.283. It was there in the previous version.

True, no package currently provides anything *plymouth/label.so
But right now it wouldnt matter if there were, because its looking for /usr/lib/plymouth//label.so.

Turns out label.so was replaced by label-freetype.so & label-pango.so. Fixing now…

Update: The issue is with /usr/lib/initcpio/install/plymouth and /usr/lib/initcpio/install/sd-plymouth. I’ve tried replacing label.so with both label-freetype.so & label-pango.so in those files and the initramfs builds fine. However, the Plymouth logo is not displayed on boot with either. More investigation is required.

@Alden20 For now, either remove the plymouth hook from your /etc/mkinitcpio.conf or downgrade filesystem and plymouth.

OK, I have commented the plymouth hook from my /etc/mkinitcpio.conf as you have indicated and has done it correctly. I restarted the machine and logged in again to see that Linux was indeed booting correctly.

The only thing is that I understand that we cannot leave the current version of the package (23.51.283-3) in the repository, since anyone who updates the packages in the unstable branch will experience the same thing as me, and if that user does not pay attention to the error message, he or she will not be able to boot Linux afterwards. It would have to be replaced with the version that now exists in the testing branch (22.02.122-15).

I was able to fix the issue with the missing label.so on my end, but then I realized there’s other things that need to be changed as well. I was not able to get it working properly after the changes, so I’ve just reverted filesystem and plymouth to their previous versions for now.

@Alden20

<snip>


Moderator edit: Removed screenshot of terminal output

Post preformatted text, not images. How many times does this need to be said?

==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64.img --microcode /boot/amd-ucode.img
==> Starting build: '6.6.8-1-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [encrypt]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64.img'
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64-fallback.img -S autodetect --microcode /boot/amd-ucode.img
==> Starting build: '6.6.8-1-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [encrypt]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64.img'
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux66.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-6.6-x86_64 -g /boot/initramfs-6.6-x86_64-fallback.img -S autodetect --microcode /boot/amd-ucode.img
==> Starting build: '6.6.8-1-MANJARO'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [encrypt]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-6.6-x86_64-fallback.img'
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux-lqx.preset: 'default'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-linux-lqx -g /boot/initramfs-linux-lqx.img --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-lqx1-1-lqx'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [kms]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [encrypt]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-linux-lqx.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
==> Building image from preset: /etc/mkinitcpio.d/linux-lqx.preset: 'fallback'
==> Using default configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-linux-lqx -g /boot/initramfs-linux-lqx-fallback.img -S autodetect --microcode /boot/amd-ucode.img
==> Starting build: '6.6.7-lqx1-1-lqx'
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [kms]
==> WARNING: Possibly missing firmware for module: 'ast'
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: 'aic94xx'
==> WARNING: Possibly missing firmware for module: 'bfa'
==> WARNING: Possibly missing firmware for module: 'qed'
==> WARNING: Possibly missing firmware for module: 'qla1280'
==> WARNING: Possibly missing firmware for module: 'qla2xxx'
==> WARNING: Possibly missing firmware for module: 'wd719x'
==> WARNING: Possibly missing firmware for module: 'xhci_pci'
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [consolefont]
==> WARNING: consolefont: no font found in configuration
  -> Running build hook: [encrypt]
  -> Running build hook: [plymouth]
  -> Running build hook: [filesystems]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: '/boot/initramfs-linux-lqx-fallback.img'
==> WARNING: errors were encountered during the build. The image may not be complete.
1 Like

What is linux-lxq? :thinking:

I tested on three machines all with 6.1, 6.5 & 6.6 installed before pushing to the repos with no errors.

It’s the Liquorix Kernel: https://liquorix.net

Well, I don’t want to say that it failed, I’m just pointing out the message at the end, since I hadn’t seen it before.

Then I’ll get brave and restart the machine to see what happens, since I still haven’t figured out how to restore a btfrs timeshift snapshot.

Then you’re on your own. That is not supported by Manjaro.

Then why are you using BTRFS to begin with? Kind of defeats the purpose if you haven’t figured out how it works. :wink: