[Unstable Update] 2022-11-25 - Mkinitcpio, NVIDIA, Qt, Gtk, SDL, LibreOffice, Cinnamon

No issues/hangs with mesa 22.3.1-1, but I notice that it adds a tiny bit of time during boot - a second or two in firmware. Mostly because I’m booting to a mechanical drive (could have been the first boot only as well). Anyway, that’s nothing Manjaro should worry about.

$ systemd-analyze blame
2.662s dev-sda6.device
2.103s systemd-fsck
2.101s ModemManager.service
1.976s systemd-fsck
1.510s tlp.service
1.401s polkit.service
1.207s avahi-daemon.service
1.183s dbus.service
1.127s systemd-logind.service
 997ms systemd-tmpfiles-setup-dev.service
 897ms lvm2-monitor.service
 811ms NetworkManager.service
 804ms udisks2.service
 769ms systemd-modules-load.service
 761ms iwd.service
 560ms systemd-udevd.service
 536ms systemd-resolved.service
 493ms bluetooth.service
 441ms user@1000.service
 411ms colord.service
 403ms systemd-tmpfiles-setup.service
 376ms systemd-random-seed.service
 327ms boot-efi.mount
 308ms systemd-udev-trigger.service
 258ms swapfile.swap
 245ms lm_sensors.service
 176ms systemd-binfmt.service
 174ms home.mount
 138ms upower.service
 131ms systemd-rfkill.service
 126ms modprobe@fuse.service
 119ms systemd-timesyncd.service
 119ms sys-kernel-debug.mount
$ systemd-analyze
Startup finished in 9.724s (firmware) + 3.003s (loader) + 3.268s (kernel) + 15.090s (userspace) = 31.087s 
graphical.target reached after 13.558s in userspace.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

No it didn’t. the firmware time is your UEFI/BIOS time.

I have this problem with the latest Xfce4 (4.18):
xfce4-notes-plugin 1.9.0-1

If you downgrade xfce4-panel to 4.16.5-1 it looks ok.

Looks like mesa 22.3 broke the HW accerleration (VA-API) on my Intel cpu, vainfo, still working though.
missing package intel-vulkan solved it.

For Intel, the GPU accelerated video decoding is done by the Intel driver (i915 or iHD) and not mesa.

thanks for the info I mistook it and reported it very soon.

You mean vulkan-intel, right?

Sure :+1:

As note: linux6.1 consumes too much size of swapfile and suspected in possible ignoring of the `vm.swappiness = 1` config parameter

I used kernel of linux6.1-rcX since X was about from 2 to last one 8.
It was good.

Since about linux6.1 got released and remove the rcX suffix, for several days I noticed I got a huge amount of pagefile data usage. I am sure it is abnormal and unusual for a couple of years for the same PC hardware configuration.

Operating System: Manjaro Linux
KDE Plasma Version: 5.26.4
KDE Frameworks Version: 5.101.0
Qt Version: 5.15.7
Kernel Version: 6.1.0-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × Intel® Core™ i5-8250U CPU @ 1.60GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620

File system: BTRFS

❯ pacman -Qi btrfs-progs | grep -i versio
Version         : 6.0.2-1
❯ lsblk
NAME                                          MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
nvme0n1                                       259:0    0 465.8G  0 disk  
├─nvme0n1p1                                   259:1    0   300M  0 part  /boot/efi
└─nvme0n1p2                                   259:2    0 465.5G  0 part  
  └─luks-7969cb36-1291-4c2e-ae53-2e4af46a0f31 254:0    0 465.5G  0 crypt /var/lib/docker/btrfs
❯ cat /etc/fstab                         
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=9F9A-268C                            /boot/efi      vfat    umask=0077 0 2
/dev/mapper/luks-7969cb36-1291-4c2e-ae53-2e4af46a0f31 /              btrfs   subvol=/@,defaults,noatime,autodefrag,compress=zstd 0 0
/dev/mapper/luks-7969cb36-1291-4c2e-ae53-2e4af46a0f31 /home          btrfs   subvol=/@home,defaults,noatime,autodefrag,compress=zstd 0 0
/dev/mapper/luks-7969cb36-1291-4c2e-ae53-2e4af46a0f31 /var/cache     btrfs   subvol=/@cache,defaults,noatime,autodefrag,compress=zstd 0 0
/dev/mapper/luks-7969cb36-1291-4c2e-ae53-2e4af46a0f31 /var/log       btrfs   subvol=/@log,defaults,noatime,autodefrag,compress=zstd 0 0
/swap/swapfile swap swap defaults 0 0

❯ swapon -s -v    
Filename                                Type            Size            Used            Priority
/swap/swapfile                          file            10485756        154784          -2

Currently I have 5.4 GB of RAM in use and already 151 MB of page file usage. This is a brand new behavior on the PC with the same H/W config.

❯ free -m
               total        used        free      shared  buff/cache   available
Mem:           31853        5969        3109        1520       22774       23903
Swap:          10239         151       10088

A very long time ago I did setup the vw.swappiness to be as

❯ sudo sysctl -a | grep 'swappiness'
vm.swappiness = 1

I have a feeling that the setting is currently ignoring since the linux6.1 release.
Again: with every rcX since 2-nd or 3rd till the last rc8-th there was no any sign of such big change in behavior.

Earlier I had
0 bytes (zero, nothing at all) of swap file usage until about 15-18 GB RAM in use.
100-200 MiB of swap file usage if it is about 20-23 GB RAM in use.

Now it is
10-12 GB of RAM usage leads to 1-2 GB of swap file usage.

It is completely abnormal at least for whole last year in any prev. kernel families: linux60, linux519, linux518, etc.

I do not use any other kernel version, so currently did not test them.

I am not seeing that here on xfce/ext4 running 6.1.0-1

free -h                                                               [1]
               total        used        free      shared  buff/cache   available
Mem:           7.6Gi       1.6Gi       4.3Gi        61Mi       1.7Gi       5.8Gi
Swap:          8.5Gi          0B       8.5Gi
vm.swappiness = 10
Ok, now it is 2.5 GB while physical RAM usage is < 8 GB:
❯ free -m
               total        used        free      shared  buff/cache   available
Mem:           31853        7413        1101        1008       23339       22972
Swap:          10239        2606        7633

Need to reboot soon to prevent fulfill of whole swapfile’s space (10 GB) and to prevent possible data loss.

and just 10 minutes later 6.1 GB Phys used (out of 32 GB) vs 3.1 GB swapped:

❯ free -m
               total        used        free      shared  buff/cache   available
Mem:           31853        6620         287         960       24945       23812
Swap:          10239        3166        7073

sort of memory leak? IDK.
I just typically watching Youtube videos, nothing else.
ok, I see that qbittorrent is also running. Closed it.
after it’s process gone:

❯ free -m
               total        used        free      shared  buff/cache   available
Mem:           31853        6486        9821         934       15545       23972
Swap:          10239        3222        7017

@Yochanan pardon me if the team is on holidays, but looks like unstable has not synced with arch stable in 9hrs now. there are few important bug fix rebuilds pending for dolphin and libraw dependents in KDE, thanks

I would call the ones for Plasma, Dolphin, etc… important nothing is crashing because of any current KDE bug.

I am getting back the “WARNING: consolefont: no font found in configuration”, but I thought it was patched? Does it need additional intervention, @Yochanan?

I have removed the consolefont hook without any ill effect on Manjaro xfce, EndeavourOS and Arch VM’s. That being said here is the fix:

To fix it, you need provide the console font name in /etc/vconsole.conf, here is mine:


To find the correct console font’s names, you could view the list of them in /usr/share/kbd/consolefonts/.

Then run sudo mkinitcpio -P

Yes, in 2012. :wink:


My eyes :eyes:! :joy:
I did a clean install in one of my machines and thought it was something new, sorry for the inconvenience, everyone!

you can update Manjaro ISO images on your media: these images got a few stable updates this year

1 Like

New change added to the wiki post:

EDIT: The change has been reverted.

1 Like

Unless one isn’t using the (default) stable branch: a /etc/pacman-mirrors.pacsave gets created and one has to manually (re-)set the branch in that case.