[Unstable Update] 2021-03-27 - Gnome 40, Kernels, Browsers, Haskell, Pipewire, AMDVLK, Wine

I’m so glad that you mentioned this @philm. I’ve been dying to ask you this ever since I saw your post, “After looking at it again, it was one of the best decision by XFCE team to do it. I would even liked they did the full switch IMHO.” I felt it was too late to ask then and decided I’d watch and learn.

I want to get on the happy-csd-train too :slight_smile: What was the technical lightbulb moment for you, when you got onboard with CSD and the direction GTK is going?

Thank you.

1 Like

Possible typo in ISO build workflow

Wine 6.5-1 and 6.5-2 do not work for me. I downgraded to 6.4-1 and it works again (xfce). Can anybody confirm?


I am using wine-staging 6.5-2 and is working.

The two Windows apps that I run through Wine (version 6.5-2) both open and perform as expected.

1 Like

Latest fontconfig-update changed the location of the 11-lcdfilter*.conf files from /etc/fonts/conf.avail to /usr/share/fontconfig/conf.avail/.
If anybody has symlinked one of those in /etc/fonts/conf.d/ - the symlinks will need to be adjusted accordingly.

edit: Just “found” the noto-fonts-compat package on one of my systems, which probably wants to adopt those path changes as well @philm?


I installed wine-staging 6.5-2 to see if it would make a difference. It does not launch, however, via command line I do get the program (QuickPar) to launch. Here is the output from terminal:

002c:fixme:winediag:LdrInitializeThunk wine-staging 6.5 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
MESA-INTEL: warning: Ivy Bridge Vulkan support is incomplete
0024:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION

If this is related to the Mesa-Intel warning, I am uncertain how to fix it. Any ideas?

It might be related to 1924933 – mesa 21 breaks some wine programs
WineHQ Bugzilla – Bug 50869 – Killing Wine process in Wine 6.5 doesn't terminate the application because of the new use of start.exe

edit#2: I get the same error when running via CLI in 6.4-1, but the program launches.

I found the fix:
cp -a ~/.wine/drive_c/windows/command/start.exe ~/.wine/drive_c/windows/

That blue in pamac-gtk is a little too strong and a bit “off” in my opinion, the eye “falls” on that instead of the program’s icon. I would prefer something from Manjaro’s turquoise palette.

1 Like

pipewire is not working manjaro kde. cant detect headphones or anything else.

Edit: in the comments it got pointed out a better and simpler way to do this.

dont use this

use the link above, better method

mmv “/etc/pipewire/media-session.d/.conf" “/etc/pipewire/media-session.d/#1.conf.old”
mmv "/etc/pipewire/media-session.d/
.pacnew” “/etc/pipewire/media-session.d/#1
systemctl --user start pipewire-media-session

You should always handle your systems pacnew files: System maintenance - ArchWiki

Hey if you can tell me th the exact command or something else I should have used/done it would be great. I read the article but didn’t get what to do.

I read this two threads about pipewire:


For clickybunty: “pacnew-chaser”

1 Like

man pacdiff
For a listing use pacdiff -o

1 Like

I just did a fresh install of the Budgie community edition, and after running full updates and getting things set up how I liked them, I rebooted, and then switched to the unstable branch. After running updates and rebooting, immediately after login from LightDM, I get the dreaded “Oh no! Something has gone wrong. A problem has occurred and the system can’t recover. Please log out and try again.” message. This happens every time, and no amount of reboots or logging out and back in helps.

I assume this is because mutter got upgraded from 3.38 to 40.0? I can still access the panel in Budgie, and even launch programs just fine, so it could be much worse. That said, the desktop is essentially out of commission with that mentioned error message taking the place of the normal desktop background. Also, some window-related operations don’t seem to work at all, or work unreliably, such as moving windows around or resizing them.

Thanks for any suggestions. I have debated trying to downgrade mutter, but I assume this will come with its own issues. Maybe if I wait it out, this will get fixed in due time?

Yes. You can try downgrading Mutter for now or switch to another branch. We’re working on holding back the GNOME 40 updates for other branches until Arch updates everything.

1 Like

Thank you for the information.

To get around Budgie not working correctly, I had to downgrade mutter and gnome-settings-daemon to 3.38. Everything seems to be working correctly now.

What I did

sudo pacdiff

If no pacnew are found it will show nothing, if found example below

pacnew file found for /etc/fonts/fonts.conf
:: (V)iew, (S)kip, ( R)emove pacnew, (O)verwrite with pacnew, (Q)uit: [v/s/r/o/q]

Select ‘o’ and you are done for each pacnew file you have to select ‘o’.

NO! don’t blindly replace config files. You’re up for surprise when you’ll replace your shadow file or similar critical files like that.