[Unstable Update] 2020-09-13 - Kernels, Qt 5.15.1, Browser, Pamac

Hello community,

Another unstable branch update with some interesting updates for you!


All about Qt … #stayhome, #staysafe, #stayhealthy

  • We updated some of our KDE-git packages plus most of our Kernels
  • Pamac 9.5.10 got released
  • Qt5 got updated to 5.15.1 which might break some
  • Some browsers got updated
  • Usual Python and Haskell package updates and rebuilds

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Mikah 20.1 release! XFCE, KDE and Gnome


sudo pacman -Syy
sudo pacman -S pacman-static
sudo pacman-static -Syyu

Our current supported kernels

  • linux44 4.4.236
  • linux49 4.9.236
  • linux414 4.14.198
  • linux419 4.19.145
  • linux54 5.4.65
  • linux57 5.7.19 [EOL]
  • linux58 5.8.9
  • linux59 5.9-rc4
  • linux54-rt 5.4.58_rt35
  • linux56-rt 5.6.19_rt12

A list of package changes may be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

2 Likes

I see lots of QT5 updates in Unstable, but no qt5-base. @schinfo

:: Starting full system upgrade...
warning: linux59: local (5.9rc4.d0910g7fe1009-1) is newer than core (5.9rc4.d0830.gf4d51df-1)
warning: linux59-headers: local (5.9rc4.d0910g7fe1009-1) is newer than core (5.9rc4.d0830.gf4d51df-1)
resolving dependencies...
looking for conflicting packages...

Packages (43) falkon-3.1.0-12  kwin-5.19.5-2  libakonadi-20.08.1-2
              libxkbcommon-1.0.1-1  libxkbcommon-x11-1.0.1-1  llvm-10.0.1-3
              llvm-libs-10.0.1-3  manjaro-hello-0.6.5-14  manjaro-release-20.1-1
              pamac-cli-9.5.9-2  pamac-common-9.5.9-2  pamac-gtk-9.5.9-2
              pyside2-5.15.1-1  python-shiboken2-5.15.1-1  qt5-charts-5.15.1-1
              qt5-connectivity-5.15.1-1  qt5-datavis3d-5.15.1-1
              qt5-declarative-5.15.1-1  qt5-graphicaleffects-5.15.1-1
              qt5-imageformats-5.15.1-1  qt5-location-5.15.1-1
              qt5-multimedia-5.15.1-1  qt5-networkauth-5.15.1-1
              qt5-quickcontrols-5.15.1-1  qt5-quickcontrols2-5.15.1-1
              qt5-remoteobjects-5.15.1-1  qt5-script-5.15.1-1
              qt5-sensors-5.15.1-1  qt5-serialport-5.15.1-1  qt5-speech-5.15.1-1
              qt5-svg-5.15.1-1  qt5-tools-5.15.1-1  qt5-translations-5.15.1-1
              qt5-virtualkeyboard-5.15.1-1  qt5-wayland-5.15.1-1
              qt5-webchannel-5.15.1-1  qt5-webengine-5.15.1-1
              qt5-webglplugin-5.15.1-1  qt5-webkit-5.212.0alpha4-7
              qt5-websockets-5.15.1-1  qt5-webview-5.15.1-1
              qt5-x11extras-5.15.1-1  qt5-xmlpatterns-5.15.1-1

Total Download Size:   171.15 MiB
Total Installed Size:  752.64 MiB
Net Upgrade Size:        1.25 MiB
2 Likes

Yes, we need new qt5-base please.

Is there still a need have an overlay qt5-base and not take it from arch directly?
I found this in the archived forum:


But the oldest now available kernel is 4.14.
1 Like

qt5-base 5.15.1-3 is in the repo.
i am going to test it.

edit: i have just rebooted and the most of the functionality is there again.
i still notice some bugs in firefox window borders and conky background.

Hmm, just applied all qt updates and rebooted.
Qt Apps won’t want to start though.

Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)

They all need to be recompiled against 5.15.1 ?

edit

Not sure what is going on. Even if I recompile an application against qt 5.15.1 on my system I still get that message above.

No problems with launching Qt apps in Plasma after this update, QtEmu built with v5.15.0 runs fine, Cantata (from repos) also works as expected.
Thanks for the quick build of qt5-base, @oberon!

Figured it out. Some theme thing.
I had gtk2 style selected in qt5ct. With kvantum it’s ok.

arch wiki saved my ass again :wink:
https://wiki.archlinux.org/index.php/Qt
(at the very bottom)

1 Like

All my qt apps failed also. Looks like qt5-styleplugins needs to be rebuilt for Qt 5.15.1. (@schinfo?)

If you don’t want to wait for the new Manjaro package, it can also be rebuilt using AUR. That worked for me.

3 Likes

Ahh, that’s the one. Thanks.
No problem, I can wait. I was just a bit a amazed that a patch version of qt could break so many things.

1 Like

I’ve just uploaded a rebuild to unstable

4 Likes

Unfortunately, plasma5-applets-plasma-pstate causes Plasma to crash now (after updating to Qt 5.15.1) :frowning_face:

Krusader does not start because of conflicting QT-libraries, some other apps do the same.
(12.09.2020) - I reverted to testing.

I had kvantum style selected in qt5ct. Error:

Cannot mix incompatible Qt library (5.15.0) with this library (5.15.1)

installed qt5-styleplugins (5.0.0.20170311-23)
and did the update “unstable” again (13.09.2020):
Krusader works again.

1 Like

I haven’t ran the update yet, but people on Arch are reporting massive issues after the qt5 update to 5.15.1, and I know some of them seem to be solved here, but the multi-monitor one mentioned on reddit (why can’t we post links here?) isn’t mentioned in this thread. I suppose I can update and maybe downgrade if I encounter issues, but I have to have dual-monitor functionality so it’ll be a PITA if it’s borked. Someone here mentioned that qt5-base is on 5.15.1-3 in the repos, but my update is only showing 5.15.1-1. Fingers crossed, will report back.

Weird, I’m on qt5-base 5.15.1-1 and I don’t have the issue others are talking about with dual monitors. Awesome. Anyways, fully updated, everything is fine (except obviously the gparted bug which I bisected and reverted).

Discussing that question would be very off-topic for this thread, but maybe just a little off-topic would be to suggest that, if you cannot post a link, simply paste it in your post, then highlight it, then click the preformatted text icon (</>)

gparted issue is fixed with 5.8.9-2 (xfce)

2 Likes

One more strange issue is Plasma has begun half-loading on a separate display: laptop’s one loads fine on startup, but the external one shows only Latte dock and top panel, the remaining space is simply black and doesn’t react to right-clicks, for example. Restarting Plasma manually makes it load properly, but on the next login I see the same behavior. Reproducible with another user’s account (test acc, default settings).

Summary

Problems for me too on a triple monitor setup, I have a black box on the wallpaper, and I can’t see and reach the icons on the top of the desktop, the notification appears on the left top angle of the center monitor instead of the top right, even the startup splash screen seems to be off center.

Are you sure?
Phil’s top post links to: https://gitlab.manjaro.org/-/snippets/541/raw
and I see:

 qt5-base             5.15.0-5             5.15.1-1

Which matches mine in unstable KDE-Dev:

$ pacman -Qi qt5-base
Name            : qt5-base
Version         : 5.15.1-1
Description     : A cross-platform application and UI framework
Architecture    : x86_64
URL             : https://www.qt.io
Licenses        : GPL3  LGPL3  FDL  custom
Groups          : qt  qt5
Provides        : None
Depends On      : libjpeg-turbo  xcb-util-keysyms  xcb-util-renderutil  libgl  fontconfig
                  xdg-utils  shared-mime-info  xcb-util-wm  libxrender  libxi  sqlite
                  xcb-util-image  mesa  tslib  libinput  libxkbcommon-x11  libproxy  libcups
                  double-conversion  md4c  icu
Optional Deps   : qt5-svg: to use SVG icon themes [installed]
                  qt5-wayland: to run Qt applications in a Wayland session [installed]
                  qt5-translations: for some native UI translations [installed]
                  postgresql-libs: PostgreSQL driver
                  mariadb-libs: MariaDB driver
                  unixodbc: ODBC driver
                  libfbclient: Firebird/iBase driver
                  freetds: MS SQL driver
                  gtk3: GTK platform plugin [installed]
                  perl: for fixqt4headers and syncqt [installed]
Required By     : appstream-qt  attica-git  bluez-qt-git  breeze-gtk-git  karchive-git
                  kcodecs-git  kconfig-git  kcoreaddons-git  kdnssd  kdsoap  kholidays-git
                  kitemmodels-git  kitemviews-git  kjs  kuserfeedback-git  kwayland-server-git
                  kwidgetsaddons-git  libaccounts-qt  libdbusmenu-qt5  libkdcraw  libkexiv2
                  manjaro-settings-manager  modemmanager-qt-git  networkmanager-qt-git  octopi
                  packagekit-qt5  phonon-qt5  polkit-qt5  poppler-qt5  prison-git
                  pulseaudio-qt  python-pyqt5  qca  qt5-declarative  qt5-multimedia  qt5-script
                  qt5-sensors  qt5-svg  qt5-tools  qt5-translations  qt5-x11extras  qtermwidget
                  signond  solid-git  sonnet-git  syntax-highlighting-git  threadweaver-git
                  vlc
Optional For    : avahi  cmake  libde265  openal  pinentry  v4l-utils
Conflicts With  : qtchooser
Replaces        : None
Installed Size  : 64.06 MiB
Packager        : Bernhard Landauer <oberon@manjaro.org>
Build Date      : Sat 12 Sep 2020 10:57:56 AM EDT
Install Date    : Sun 13 Sep 2020 05:41:43 PM EDT
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature