Unable to mount fat or ntfs drives after updating

before updating I was able to mount both of my drives i have a external ntfs drive and a internal ssd formatted fat. I have tried mutiple kernels im currently sitting on rc4- but i have also tried -6.1.55-1 any help would be appreciated i have noticed this prob only happens on arch installs and they work before i update the system, after they will no longer mount i get the error:

An error occurred while accessing ‘Elements’, the system responded: The requested operation has failed: Error mounting /dev/sde1 at /run/media/medec/Elements: wrong fs type, bad option, bad superblock on /dev/sde1, missing codepage or helper program, or other error

any help would be appreciated thank you.

Welcome to the forum! :vulcan_salute:

Please read through this tutorial below. :point_down:

My kernel is

 $ uname -r

The message indicates a filesystem error - if ntfs you need to boot into windows and run a chkdsk drive: /f

1 Like
chkdsk /f X:

X denoting the respective drive letter. If X: = C: chkdsk will prompt a reboot allowing actions to be performed at next boot, before Windows shell loads.

long time since I had to use Windows - it was not intended to be a copy paste - just a reference to what must be done - I am sure the chkdsk program is able to tell the correct syntax

1 Like

I’m usually hesitant to make that assumption about any software from our friends at Redmond.

After the last update, I had the same problem. At the moment, the only solution I found was to install ntfs-automount, from AUR.

This worked for me thankyou, only prob now is my FAT drive will no mount like i said everyting worked before the update

I just had the exact same problem with a ntfs drive.

Did that. Took a second to fix it. Done & dusted. Same thing might work on FAT.
Thanks to @akya

Now I going to step away from ntfs & stick with linux file systems.

Are you mounting this drive via /etc/fstab or manually?

i have tried to mount it through dolphin and i have also tired though command line the error i keep getting is failed mouting wrong fs type bad option bad superblock. i was able to get my ntfs drive mounted but was never able to get the fat32 drive to mount installeing ntfs-automount was able to fix half my problem.

Are you aware that fat (fat16) and vfat (fat32) are different filesystems?

Perhaps your fat formatted drive is actually vfat; which is more common and likely. Although, as I understand it, mount should determine that automatically; unless I’m mistaken.

Manual mounting (edit for your specific use case):

  • mount -t vfat /dev/sdbX /media/usbX (for fat32/vfat)
  • mount -t msdos /dev/sdbX /media/usbX (for fat16/fat)

Or, in /etc/fstab, (edit for your specific use case) add:

  • /dev/sdbX /media/usbX vfat defaults 0 0 (for fat32/vfat)
  • /dev/sdbX /media/usbX msdos auto (for fat16/fat)

You might also try using the gnome-disk-utility which appears in KDE simply as Disks.

Additionally, ‘bad superblock’ usually indicates corruption or damage to the drive. In some cases this can be fixed using fsck (man fsck / fsck); but as its traditionally a Microsoft filesystem, you might also try chkdsk /f X: (where X is the drive letter) in Windows.

Same problem here. Before doing the last update these days Manjaro recognized ntfs and fat systems on several external drives. After the update it shows the error mentioned above. Other linux systems do not have that problem. So it seems not to be a Windows system failure to repair with chdsk but related to the Manjaro update.

1 Like

This happened to me yesterday with my external USB drive, the ext4 partition worked fine but the NTFS one had the same error.

I tried the ntfstools option but it didn’t work for me.

I then fired up a Win10 VM and it popped up the “there is a problem with this drive” type error, I chose the scan and repair option and it sorted it.

See if the following helps… :point_down:

sudo pacman -S ntfs-3g
sudo bash -c 'echo "blacklist ntfs3" > /etc/modprobe.d/disable-ntfs3.conf'

Reboot after the changes.


‘Bad superblock’ usually indicates corruption or damage to a drive; in fact, it can’t mean much different to that. The suggested usage of chkdsk /f X: from within Windows, as an alternative to fsck in Linux, is valid; despite your apparent strawman hypothesis to the contrary; which itself was irrelevant.

In simpler English, a bad superblock can be corrected by either fsck or chkdsk, and has nothing to do whatsoever with any issue resulting from a Manjaro update; whether perceived or actual.

As this was your first post, welcome, and I’m happy to direct you to additional resources before making your next:

1 Like

This helped and solved all my issues.

@soundofthunder I don’t know why you have to be so passive aggressive in your comments. This isn’t a drive problem, thousands of people didn’t suddenly do something to their drives right after the update. Aragorns two commands fixed all my issue and I bet most people issues.


I were being passively aggressive I am confident that you would not even recognize it as such; however, let me address your misguided assumptions in context:

  1. Information provided by Medec5:

This clearly indicated a drive problem. In fact the error bad superblock has no other interpretation; as far as I am aware.
Based on that information my response was valid. If you have another interpretation, please enlighten us ( ← that was passive aggressiveness ).

  1. Post from Cornwol:

This also supported my stance.

While I’m glad that your issue was solved, the commands provided by Aragorn fixed issues that were unrelated to a ‘bad superblock’:

sudo pacman -S ntfs-3g … installs ntfs-3g; we might think of it as a translation assistant for NTFS.
sudo bash -c 'echo "blacklist ntfs3" > /etc/modprobe.d/disable-ntfs3.conf disables a similar translation assistant that isn’t playing nicely.

In short, stating that;

… also has nothing to do with my response to a bad superblock error.

I hope this helps. Cheers.

How do you know he hasn’t already got ntfs-3g.? I already have that one installed. It’s included with Manjaro. ntfs3 isn’t installed on my system.?

Pacman would indicate that it was already installed, and ask for permission to reinstall it; reinstalling would likely cause no harm.