Can't login into X11 and deepin is installed after last update

Hi, I’m completely confused on what happened. I’m using KDE plasma. Today I ran an update (as requested by the system) then my computer crashed and upon reboot I discovered a new menu to pick up either X11 (plasma), deepin (wayland) and deepin (plasma). I don’t even know what Deepin is and how it got installed on my computer. I tried to login on X11 (plasma) but it freezed and I get back to the splash page with my login and password. I’m able to login on Deepin (wayland) but I am completely lost with the interface. What should I do? I don’t use much the console so if you could explain in details, it would be great. Thanks a lot.

Welcome to the forum! :vulcan_salute:

Well, it didn’t install itself, so you must have installed it at some point. :man_shrugging:

Deepin Desktop Environment is a different user interface, but a lot of it is based upon modified versions of KDE software, such as a modified version of kwin. :point_down:

By consequence, when you installed it, you must have damaged the proper Plasma configuration files, and that is why Plasma won’t start anymore.

Well, you could try uninstalling all Deepin-related packages, reinstalling Plasma, and then cleaning out your ~/.config, ~/.local/share and ~/.cache directories, and starting afresh with a stock Plasma desktop. But if you’re not experienced enough, then you’re probably going to be better off just reinstalling the whole system from a fresh ISO. :man_shrugging:


Thanks a lot for the detailed answer. I’m 100% sure that I never installed another user interface. Something got severely messed up during the update. But that’s actually very worrying on the security of Manjaro. I will reinstall manjaro KDE.

It is not possible for any desktop environment to get installed without the user’s consent, let alone outside of the user’s knowledge, and certainly not during an update.

Manjaro uses the same package management as Arch proper, and if this sort of thing were possible, then Arch proper and all other Arch derivatives — Endeavour OS, Garuda, et al — would be affected as well. I too run Plasma as my desktop environment, and I too updated my system yesterday, but I’m not seeing what you are seeing.

You must have done something to make this happen. :man_shrugging:

There was another user that had accidental deepin on their kde …

I’m not saying it is surely the case … but it does make it seem more possible that some combination of dependencies could inadvertently pull some deepin deps.
(the user quoted had old python packages, openrc, gnome, and more)

In the case of the user here … we could

grep -i deepin /var/log/pacman.log

And we might find out :slight_smile:

1 Like

Hmm… Perhaps something from the AUR then? :thinking: