Unable to connect my Manjaro Plasma Pinephone to the 4G network

Good morning everyone.

I try to write here on the forum in the hope that someone can help me solve this annoying problem that does not allow me to use my Pinephone as a daily driver.

To put it in a nutshell, I can’t find a way to connect my system with Manjaro Plasma to my carrier’s 4G network, which I was able to do without problems in the Phosh edition of the OS.
When I open the “Cellular Networks” > “Access Points” menu in the Settings app, in fact, the checkbox that normally allows to enable the connection is not selectable.

I also tried to use the CLI, but the command mmcli (which I read is the program that manages the modem settings) only returns error: couldn't find the ModemManager process in the bus.

I thank in advance anyone who can help me solve this annoying problem.


Make sure you use at least the latest beta2 image

Write it again either to eMMC (use jumpdrive for that) or SD card with imagewriter.

Probably you could switch branches to arm-testing and refresh mirrors and then run:
sudo pacman -Syyuu

Yes, I saw that it was posted, but I thought that regularly updating the system with pacman -Syyu from any image was enough to get all the updates.
Is it really necessary to change the image every time a new one comes out?

Well, it depends on what branch you are. For now the working one is on arm-testing … If you are on different branch, then some things might be broken.

In theory, I should be on the correct branch…
The command is sudo pacman-mirrors -aS testing, right?

The command is sudo pacman-mirrors -aS testing, right?

Yes, explained here:

OK, thank you. I wanted to make sure that arm-testing didn’t have a different name.
I have now flashed the new image, changed branch and started the update. Hopefully the problem will be resolved.

OK, I’ve flashed the new image (Beta 2) of Manjaro Plasma, changed the Pacman branch using the command I gave above, and started the full upgrade, but the problem described at the beginning keeps occurring; I’m not able to enable 4G connection from the settings and mmcli says it can’t find ModemManager on DBus.

Maybe there is a special issue related with your provider … not your provider fault, but the code.
I can make Calls, connect to mobile data, but each time it switches to 2G from 3G, or at least that is what i see, while on your case

sounds more like the modem is not even available?

I thought the same thing too, but I can make phone calls without issues…
How can I check if the modem is working properly?

How can I check if the modem is working properly?

Might wanna check out the test image from our PostmarketOS friends.
More here: Pinephone Starter Guide - مستندات Google

Well then, your modem is working and maybe there is still this issue

I don’t think it’s a hardware problem. On Manjaro Phosh image the 4G works perfectly.
By “check if the modem is working properly” I rather meant to see if the service that runs it has crashed / won’t start / etc…

This problem also seems to affect phone calls and seems to occur regardless of the operating system, while on Manjaro Phosh 4G works without any problems without changing carrier.

Is because of this

On Phosh the only thing i know to be broken atm is GPS … the rest is almost flawless. PlaMo and Lomiri still wip … :slight_smile:

OK, now I see what the problem is.
Stupid question: if I were to switch to the unstable branch also on Plasma would this package be present? Or would it not be installed anyway?

It might not even boot on unstable now. Have some patience as the devs are working on it … :slight_smile:

Okay. Thank you very much for your help.

Any update on this? I heard there was a large push of new updates yesterday and I wonder if this was addressed :slight_smile:

The last update I received (on testing branch) was last Saturday and I didn’t notice any particular changes.
The 4G connection still doesn’t work and most of the time the phone doesn’t receive incoming calls. Outgoing calls and SMS seem to continue to work, however.

1 Like