Unable to connect my Manjaro Plasma Pinephone to the 4G network

Well - I do think this is carrier related - because I have zero issues with 4G - but I am living in Denmark.

I read a older blogentry on postmarket os web - comparing the pinephone with librem 5

I noted that the Pinephone supports the broadest range of various connection types - but with such thing as a modem - I think with that broad range of standards and carriers - there’s bound to something not working as well as you hoped.

Maybe it is prudent to add in - I am using phosh - not plasma.

1 Like

Today I finally found some time to flash the latest Plasma Mobile dev image on my Pinephone.

While I still have no luck in connecting it to the 4G network, I found this - I guess - new module in the Settings application:

Despite my various attempts to make it work, however, it seems to forget the data I enter. Is there any way to save the APN or is this screen just some kind of test that doesn’t work yet?

I got some advice from Plasma Mobile matrix chat resident dev Bhushan Shah.

qdbus --system org.ofono /quectelqmi_0 org.ofono.SimManager.GetProperties

Take a note of the SubscriberIdentity here. (You can ignore that command and instead find IMSI from system settings cell information.)

After that, in settings > Cellular Network > Access Points, check which of the context or APN makes most sense for your network if is e.g. 1st. Then

sudo nmcli c add type gsm con-name "/quectelqmi_0/context1/<IMSI_HERE>" ifname quectelqmi_0

And one last thing is to disable context from ofono side to let nm handle that [by running this python script - cd to the directory you saved this script and run python3 deactivate-all].


After that activating newly added connection should work ™️

I’d love to hear if any other users are able to get mobile data running with these instructions because so far it didn’t work for me :grimacing: I just get the following from nmcli m

quectelqmi_0: using connection '/quectelqmi_0/context1/46xxxxxxxxxxxx67'
quectelqmi_0: connecting (prepare)
quectelqmi_0: connection failed
quectelqmi_0: disconnected

It doesn’t work for me either.

I tried to execute all the commands even if the context proposed in Settings > Cellular Network > Access Points (the one you see in the post I published at the beginning of the thread) does not resemble in any way the APN of my operator (the one reported on the site is mobile.vodafone.it) and, in fact, once launched the command nmcli d connect quectelqmi_0 I get the following error: Error: Connection activation failed: (25) No carrier could be established.
I also tried rescanning the operators with ofonoctl operators, but the error keeps showing up.

I think it’s something with ofono and networkmanager fighting for control over the same resources. I will update if I learn more!

Ok I ran the deactivate all script again and then did nmcli n off followed by nmcli n on (note if you are using SSH via network you will lose the connection so best do this second step from the phone’s terminal). May be worth noting I ran all of the above sudo.

4G now works! :tada:

Do you have to redo these steps after a reboot?

No, you’re right. deactivate-all is not persistent. I guess that’s the next step :sweat_smile:

It seems deactivate-all has died (no longer works for me).

A fix that will hopefully let mobile data work out of the box is coming today or tomorrow according to plasma mobile dev :pray:

Ok the issue was simply after an update, everything gets reverted. So here at the complete steps again:

(Recommended doing via SSH for easy copy/paste)

  1. Run qdbus --system org.ofono /quectelqmi_0 org.ofono.SimManager.GetProperties
  2. Copy CardIdentifier number
  3. Run sudo nmcli c add type gsm con-name "/quectelqmi_0/context1/<CardIdentifier>" ifname quectelqmi_0
  4. Download this script to your phone via wget: https://git.kernel.org/pub/scm/network/ofono/ofono.git/plain/test/deactivate-all
  5. Run script: cd to the place you downloaded it and run python3 deactivate-all
  6. From the phone (because you will lose SSH connection) run nmcli n off followed by nmcli n on

Note steps 5 and 6 must be done after each boot. A permanent solution is coming soon :tm:

Hi all. Today I flashed the latest dev image once again and the system finally shown an error message related to the 4G issue.
Every five minutes or so, in fact, it pops up a notification with the following error: “Modem (quectelqmi_0) - The modem shows no carrier”.

I know that this isn’t much, but maybe it is easier to find a solution for a specific error rather than a generic problem…

That notification also happens if the connection is working, so it’s not much to go on. :stuck_out_tongue:

The 4G connection stack is under development these days.


Oh. OK :upside_down_face:
Then I’ll keep waiting. Thank you very much.

Got the same issue, tried to manually configure the file /var/lib/ofono/<card_number>/gprs with correct apn, but gprs still doesn’t work and the settings → cellular info → SIM Card displays again the “defaul-lte” connection.
I can’t accept the idea that after 20 years of distro/DE battles we are still in the same situation having a user interface like phosh that is totally out of time but working properly for the essential stuffs a phone have to do, and a UI like KDE/plasma, modern and fascinating, but useless if you need gprs working. Specifically networkmanager works flawlessly, ofono doesn’t. Moreover there’s not a clear way to work on it.
In my case phone calls and SMS are working out of the box, after SIM is unlocked. Is there anyone able to configure gprs in ofono?

1 Like

Just got my pinephone. Is there any way to get gprs working? How do I even know I have the latest image/software/whatever I need?

If you need to use gprs the only way is to install phosh version, I can’t still figure out why in plasma-mobile the gprs connection point to that default-lte APN, and creating a new conf file (as explained in my last post), with correct gprs parameters, is totally useless.

Are there any updates regarding this issue?

Reading the old Pine64 blog posts I noticed this pach that should facilitate the “compatibility” between NetworkManager and Ofono. Do we have to wait for its development to be finished?

I don’t really have an update on this.

My best guess is that we need to wait for development in the proper places.

I see.

And may I ask what these “proper places” are? It would be useful to have at least a bug tracker thread in which to look for updates about the issue…

You can follow our Plasma Mobile issue tracker and/or join #plasmamobile:kde.org on matrix for development stuff.