Unable to build sway for RPi4 with either .iso or github

Help please - having a lot of trouble with Sway.

I’m trying to build the manjaro-sway edition for RaspberryPi 4B.

First I tried the main webpage Download, but that didn’t work. manjaro-sway-22.0.4-230430-linux61.iso will install but won’t boot - see my post at

SWAY version stuck on first start - no ideas left

which has had no replies.

Then I tried to use manjaro-arm-tools and buildarmimg.

Cloned the git-hub repository

git clone https://manjaro-sway/manjaro-sway.git

cd manjaro-sway

sudo buildarmimg -d rpi4 -e sway

(note buildiso is not available in the aarch64 repository - could be useful)

During the build I get the following error

Cannot stat /var/lib/manjaro-arm-tools/tmp/root/boot/* No such file or directory

and though the flashed image produces both BOOT_MNJARO and ROOT_MNJARO, /boot is empty and so is /root/boot.

I have used the same process with the Gnome edition. The flashed image produces a populated /boot partition without the need to extract files from /root/boot. It boots to desktop, but I cannot get into any apps (including terminal) or TTY2. For now I am leaving it there.

I have built the Sway image twice with the above buildarmimg command with the same result.

What am I doing wrong? Have posted this as a Discussion under the manjaro-sway repository, but had the response that it is an issue for the Manjaro forum.

So far it has proved impossible for me to make this work. Any help appreciated.


from another post here it appears buildarmimg is broken with a couple of packges and it aborts. It looks like you tried to install an x86 iso. The image should be


Thanks for the reply.

The original iso was from the ARM section of the Manjaro Downloads page

That was AARCH64 and built. As I said though it built it did not boot as outlined in my OP. I have tried to track down why not via the posts quoted, but so far to no avail.

The github link is to the git repository for Manjaro SWAY. I believed that the cloned git repo can be built in whichever architecture you run buildarmimg in. But that could be wrong.

Do you have an alternative link to download an RPi4 specific repo? I could try the arm-generic version but am troubled by the fact that buildarmimg built Gnome OK with the boot partition, but not Sway. That suggests to me that the Sway github repo has a fault. However, as I said they directed me to the forum.

If you think that’s wrong, feel free to respond to the Discussion on github at

And could you direct me to the posts you mentioned re buildarmimg bugs? I haven’t found those …

Tks for pitching in


Click on “Show all 26 assets” for sway to show up



Good luck. I do not maintain or use the sway image. @appelgriebsch does. I have not seen him post in a while but I have been out recovering from a heart attack and 4 surgeries.

Thanks - I downloaded the rpi specific image from your first link and flashed again - same problem as my original post.

I replied to the post on your second link, because I had got further than that. Perhaps that might lead to a way forward.

Good luck with your convalescence, I had a double bypass four years ago, so only one surgery, but enough.



Have just seen your post in the conversation

which gave me some hope. My /boot/cmdline.txt has the root PARTUUID set and I am running V 1.5.3-1.

Same error - won’t boot.

Can we reopen that discussion?


Sorry - am running v 1.5.3-1 of manjaro-arm-installer.


I built this image this mourning and it seems to work. I did not mess with it much as I do not care for tiling DE’s. It reminds me of the days many years ago when I was using linux even before a graphical DE was stable. Every program had shortcuts to learn. Being 72 years old I do want to take the time to learn them.

I ran into 2 issues with packages getting installed:

gitui had a dependency issue with a lib version. I ran into a similar issue while playing with arch-arm’s vlc-rpi package where it was looking for a lib with a -64 extension. I had to modify their lib package to add provides= and add a symbolic link. I am thinking it is probably the same issue. For now I disabled the gitui package here locally in the manjaro-arm profiles.

I saw another error with the package nerd-fonts-terminus not being found. I can not see it in arch-arm repo or AUR or as an overlay in manjaro-arm. Some one some where got rid of the package. When testing the image I saw a warning that whatever terminal it defaulted to was not capable of monospace but the warning could be disabled in sways’s config file somewhere. So disabled it here locally also.

Any time in a script if there is an error it will exit out of the script at that point and does not complete. The building of images has many scripts.

Here is the image I made. In first couple of boots you will see the spinning circle a little longer than usual and some black screen; just wait as there are a lot of first time setting things up for first time usage…

c86dd821f33e2308bb7050cd3ee49009 Manjaro-ARM-sway-rpi4-05.14.23.img.xz


Many thanks for this!

I got so far as discovering that manjaro-arm-flasher builds the sway rpi4 image with only cmdline.txt and config.txt in /boot, and nothing in /root/boot. No firmware - no initramfs etc.

I got the same error messages as you quote during build.

I quite enjoy i3 which I have played with for testing only. My goal is to build a system acting as server to run multiple concurrent instances of one program, bit also accessible over VNC. Hence needs to be light on ram and fast.

Hoping this will be a good basis.

Thanks again. I will keep pushing for an updated release.


Well that’s fascinating.

At the initial bootup, I got the same ‘discover_other_daemon :1’ message as on the official image, and the same frozen “arm” splash screen. See the first quoted post in my OP in this thread.

TTY2 yielded to root. Exploring showed /home/oem. $su oem disclosed a bunch of files including .bashrc and README.md, which I did.

Logging into TTY2 as oem pw oem seems to give full access. sudo needs no pw. No timezone set but KB=UK.

I’ve configured nmcli to get online via wifi and connected via ssh. So can get output and copy externally eg to this forum.

I’ve stopped there as (i) this is further than I’ve got before (ii) obviously this isn’t intended to happen - I haven’t been through configuring user etc - but (iii) you built it so you may have some ideas on fixing it.

I do think the gnome-keyring-daemon has been started by some other process, but

$ rg gnome-keyring-daemon

returns nothing so gives me no clue unless it is somewhere in PAM (twice?). Which is a closed book.

Happy to continue via pm if you wish, or here, or prps on my original original OP re the gnome error message.

On a personal note - I’m only two years behind you at 70. Also after tomorrow I won’t be able to get to my pi for a fortnight. So happy to get a quick hint about what I could do next, but also happy to leave it til the end of the month.

Interesting that your image and the official image give the same error.



@ rico1, use xzcat & dd.
btw, new img look good except ugly fonts.

1 Like

No clue what is going on there. The image booted up fine here into the initial setup then rebooted into the DE with out any issues.

Some where there has to be a PKGBUILD for nerd-fonts-terminus. I have no clue if it was arch-arm or manjaro.

@rico1 I used this here. Adjust if necessary for your destination.

sudo xzcat Manjaro-ARM-sway-rpi4-05.14.23.img.xz | sudo dd of=/dev/mmcblk0 bs=1M status=progress conv=fsync

replaced by ttf-terminus-nerd, guess?

Will try those if this doesn’t work. Systemd.firstboot.service has a condition that machine-id is not set - ie that /etc/machine-id does not exist.

I will delete the file, reboot and report back. Later … it’s 4:45 am here. Sure youve been there.

Best R

Well, I tried deleting /etc/machine-id and no change. I then checked if firstboot is used on your image, and it doesn’t seem to use the socket/service, only the target.

So then I dd’d to USB and got exactly the same error as before.

Stymied at this point.

I did look up the nerd fonts family, The terminus package adds a lot of icons which I think are probably used by zsh. Your image seems to use icons fine in zsh so my working assumption is that the nerd font is replaced by something in the zsh font package. In any event it doesn’t seem critical.

I have limited time to play now, only thing left is to see if I can build on a different computer. May try later if time.


Looks like you are right. I installed ttf-terminus-nerd / rebooted and seems to be working. Notice arch-arm’s PKGBUILD for it.

btw, foot did not read foot.ini ?

foot.ini where?