Unable to boot pc

I rebooted my pc from terminal and now when it starts it comes up with

[FAILED] Failed to start VMware Networks.

And it wont boot at all its just stuck on this what do I do?

Don’t know about the problem with the networking driver/module/service, but i guess you can always uninstall vmware altogether.

If you can press ctrl-alt-f2 and that gives you login/command prompt you can do it with pamac. Remove vmware with dependencies. (I’m not sure how the package is named)

Or you can chroot from live usb system an do it that way.

For the ctrl + alt + f2 when do I press it? Or do I hold it whilst it’s booting? I tried it and it still shows up with the error.
Edit: I found it but it says target not found: VMware when I do panache remove VMware

When you are stuck at the error. But try to remember the name of the package you installed first. You need it.
Actually, you can see it in /var/log/pacman.log

cat /var/log/pacman.log |tail 50

And then

sudo pacman -Rns xxxxxxxxxxx

I can’t do the |tail 50 part of the command as my keyboard doesn’t have |

Do it without then, not that important…lets hope it will be on the last couple of rows in the log.

it does have it - but anyway:
less /var/log/pacman.log
and scroll to the end
will achieve the same

tac /var/log/pacman.log
which will list the file backwards - newest entry first

the | (pipe) is usually accessed via:
CTRL + ALT_GR (the right ALT key)

journalctl -f
is also a good tool to watch what is happening

I found it, I done sudo pamac remove vmware-workstation and now when I boot my pc it’s stuck on the logo on boot

No idea what you mean by having found it.

vmware-workstation is an AUR package that simply might need to be re-built

reading the logs
… various methods suggested …
could still shed some light on the issue

Vmware is removed now but my pc is stuck on the logo when I boot it and doesn’t load.

chroot then

and still:
read the logs
or provide them here, so people here can see and possibly advise …

That’s what shows up when I do
cat /var/log/pacman.log tail50

post the text output, not a picture of it

I can’t post it because I can’t copy and paste it or anything. I can’t even boot onto desktop

but to a TTY perhaps?

if not:
it is, then … :wink:
to fix the system

I’ve booted into tty with ctrl alt f2 but I’m just lost at what to do and English isn’t my best language and I’m getting confused with these words it’s showing

Well removing it didn’t help. I suppose it’s some service or module left…but i am not proficient in vmware.
In order for others to help, you have to collect some info/logs. There is a topic like “how to properly ask for help” or smth similar describing how to collect logs.
And to be easier for you you may want to boot from an live usb and then chroot (see the tutorial above) and then you have gui, and copy paste etc.

I’ve tried running the command startx and I get the error

Fatal server error:
(EE) no screens found (EE)

And then at the bitten it says

xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error

Could this be the reason it’s not booting?

Also when I run cat /var/log/Xorg.0.log I get another error

(EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the systems kernel log for additional error messages and consult the NVIDIA README for details.
(EE) No devices detected.

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as descrribed above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

For more information, please see:

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.