Unable to boot - error: symbol `grub_alloc' not found

Today I updated Manjaro using pacman -Syu, and afterwards rebooted for them to take effect. However, it did not boot, instead it stopped at the boot command line with an IRQ Handler error above. It would not register any inputs or functions, however Ctrl+Alt+Del worked so an Arch friend of mine suspected it was GRUB offing itself.

I followed the wiki page to restore the GRUB installer in order to fix it, but all it has done is change the error on booting my main drive to that in the title. Everything on the screen is printed below:

error: symbol `grub_alloc’ not found.
Entering rescue mode…
grub rescue>

All I could find on Google about this error was from Ubuntu and Arch. The arch page [ guess I can’t link to it ] was not for x86_64, however I tried the solution in the comments that did mention x86. It had no effect, despite grub-install saying there were no issues

boot on usb iso manjaro ( UEFI)
open a terrminal

sudo manjaro-chroot -a ( type 1 if one line 0 appears )
cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi
efibootmgr -v
exit ( quit chroot )
1 Like