Boot Error after Update - error: symbol `grub_alloc’ not found

I ran into some problems after updating my system, however I’m not sure if the update was related since there were no major changes. Anyway, when I restarted my PC my system is not booting up, instead I’m lead to the grub rescue console, provided with the error written in the topic. I tried to use timeshift vie a live USB medium but it is not completing successfully. In the section Re-installing Grub2 bootloader I get the following message:

Installing for i386-pc platform.
grub-install: warning: this GPT partition label contains no Bios Boot Partition;embedding won’t be possible.

I followed the this topic, but I’m already getting an error while running sudo manjaro-chroot -a.

grub-probe: error: cannot find a Grub drive for /dev/sdd1. Check your

How do I go on from this point?

Ok. Let’s start with the manjaro-chroot error. That error is expected (it’s your USB stick). Do you get any other output from the command?

For the boot problem, are you sure the system update ran until the end? After you have chrooted, you should do a pacman -Syu to be sure.

And for the grub reinstall problem. There are to two modes to boot a system: BIOS and UEFI. Do you know what type were your system using? From the error I would say that you tried to use the BIOS method in a UEFI system. You should boot your live USB in the same mode than your Manjaro System.

The complete Output of chroot is:

[manjaro@manjaro ~]$ sudo manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your
grub-probe: error: cannot find a GRUB drive for /dev/sdd1.  Check your
==> Mounting (ManjaroLinux) [/dev/sda2]
--> mount: [/mnt]
--> mount: [/mnt/boot/efi]
--> mount: [/mnt/mnt/internal/data]

Do you meant that I should run sudo pacman -Syu after I executed the command above, or is there something else I need to do? I’m sure my system rebooted correctly, but I wanted to load the Bios setup before the next start. It wasn’t working though. It was already not booting correctly, than I updated my Bios to the latest version, however this wasn’t helping.

I’m not 100 % sure but i think I used a UEFI install. My live USB is definitely booting with UEFI.

I just realized, that my manjaro installation is not among the mounted devices, also /mnt/boot/efi does not exist.

From the output it seems that it is correctly mounting your Manjaro system. Your Manjaro root partition is /dev/sda2. Don’t pay attention to the /mnt. After you do the manjaro-chroot, your Manjaro system is in / and your EFI partition is in /boot/efi/.

Do the pacman -Syu after you have chrooted, just to be sure that your system is up to date. No need to do anything special.

The output also confirms that your system is in UEFI, so you can reinstall grub, but use the UEFI method, not the BIOS method. Something like this:

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --recheck

This have to be run also after the chroot.

(base) [manjaro neu]# pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] y
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] y
:: Replace qca with extra/qca-qt5? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer

so I guess something is wrong.

Do a pamac update instead then. It’s going to solve the dependency problem

I ran:

and it solved the boot problem. Afterwards I completely updated my system and it is working, however the reboot is really slow now, but this might be an other problem.

Many thanks to you! You are a blessing. :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.