Ubisoft Connect error on Linux

Hello all! I have mostly been on Mint for the last 3 years. I have also tried pop os and now Manjaro. I really like Manjaro! I was hopping because I can’t get Ubisoft connect to open on my mint
, pop,and now manjaro installations. Everytime it has a network connection error and try again later.

I can usually get connect to work in windows 10 but its not that great. I’m trying to fully rid myself of windows in about two years and connect is my only problem.

I have tried 3 different os’s, Lutris,Bottles,games on linux,and other programs .Ubi says they don’t support their games on Linux.I don’t have the best internet but I 've downloaded tera bytes of games through Steamand I never get error codes like this.
And in my travels I have winetricks and connect is listed there but I get a wine type error of uplaywebcore not responding. The last few months I’ve tried many hours to get connect to open.Strangely the proton list in the help sticky lists most of the far cry games but there’s no entry for Ubi connect.

Any help is appreciated.

So you tried this?


Indeed I have but I havn’t tried Lutris on Manjaro.It has been a while since I did try Lutris on Mint so I’ll try it now. Thanks! I’ll report back.Would it be ok to install via CLI? I don’t want an account with Lutris.Then I can launch it from CLI I think?

EDIT:downloading through cli.

Welcome to the forum! :wave:

Please see:

1 Like

Sorry about that.I now have Lutris. Connect is listed by itself as well as under games now .If I try to launch connect I get 3 little wine de bugger pop ups and the outline of the connect program is shown.The wine de bugger windows don’t stop and connect never opens. Could I have the wrong version of wine on my system?I have a winetricks entry from before all this.
The outline of connect and the little window with a debugger main page but flashes off too fast for me to read it. And it lists a few of my games but it’s through Lutris’ interface so that makes it more confusing. :neutral_face:

I managed to run Ubisoft Connect trough Steam, I made a post about it (at the time I wanted to run Gameforge Launcher): Gameforge Launcher on Manjaro!
There are guides about it if you google a bit.

Each game has it’s own Proton or Wine prefix. I don’t recommend installing launchers separately and trying to play different games.

I suggest reverting everything you just did, then choose the game(s) you want to play from Steam or Lutris. The requirements will be installed in the game prefix including the launcher if necessary.

1 Like

Launching connect in steam causes the exact error situation as through Lutris but I will only try to do it through Lutris instead for now.What should I revert? Since I installed manjaro mainly to try getting connect to work I think I installed the winetricks part a while ago. If needed I can reinstall Manjaro again with a new install.

Maybe nothing. Some Ubisoft games via Lutris have a Uplay version script, but not necessarily all of them.

Tip: If you bought the game via Steam, play it via Steam. If you bought if via Ubisoft, install it via Lutris with the Uplay version install script (if available).

That may be due to a WebKitGtk bug. Try launching Lutris or Steam with WEBKIT_DISABLE_DMABUF_RENDERER=1; i.e.,


There is no problem opening Lutris. When I try to open Ubisoft Connect a wine de bugger and the beginning of the connect app to start.

I’m sorry for any confusion. I can get almost all of my games on steam to work in Linux. On windows I was able to add connect as a game then open connect and play Far cry 6 and others. Even if you buy a ubisoft game through Steam their launcher is mandatory even for single player games.
I’ve posted this problems a few times in other forums and still no answer for me.
The culprit is only Connect,basically.

I know. The bug affects the webview loading the login for game stores like Epic or maybe Ubisoft.

1 Like

I opened lutris through the konsole as instructed and still get the 3 wine de bugger and the window for connect starts to appear but doesn’t proceed.

The konsole has an error of AE1 (thread xxx),starting de bugger…
wine;unhandled exception0x0000003 in thread xxx at address 116A4
The xxx is an always changing number.

Did you check Lutris discord? They help a lot solving Lutris related problems: Lutris

1 Like

I think I posted my problem on Discord. It’s not the friendliest software.It seems just like social media or something.No big deal I have win 10 for a couple more years to play my far crys on connect. Gabe and many others are getting better all the time regarding games on linux.

Try Proton 8.0-4. It should automatically update opening Steam:

  • Fixed Ubisoft Connect not working after its recent update.

I have tried almost all of the protons in steam. ideally i want to launch connect through steam. But i get the connection error and to try again later through connect. And it does sometimes update to a newer version of connect and still never opens.Then if I close steam and open it again i click play on connect it’ll say there is a newer version of connect already installed and i click to open the new version of connect and get the connection error.

The other proton versions don’t work for me either.

Hey @LamarrtheStrelok,

It’s a longshot, but could you please try to run sudo sysctl net.ipv4.tcp_mtu_probing=1 in terminal and give another try to Ubisoft Connect.

Note: before trying, please make sure that no VPN connection is active.

1 Like

Just tried it in my Lutris install and it stalled on launch with “looking for updates” message and kept spamming my pihole log with “wpad” domain. Launched it again with a current wine version and it self-updated and then keeps crashing with multiple errors. Probably some windows dependency is updated/introduced, will look into this if I have some free time today.

1 Like

Cyberoto I tried the code you provided and on mint os and manjaro os it displays ‘net.ipv4.tcp_mtu_probing = 1’

Which way do you want me to try opening Connect?I can get wine to open it but I get a different error code doing that, and I have entries for connect on Steam and Lutris I can use to open connect.
I’m on my Manjaro drive now to make sure we are on the same page.

I used Lutris install for Ubisoft Connect (Ubisoft Connect - Lutris, Wine Latest version last published 3 months, 3 weeks ago option) configured with Lutris-GE-Proton8-15.

I have successfully installed and run Ubisoft Connect with GE-Proton8-11/16 on Steam.

I mainly use Lutris to play Ubi games.

1 Like