Ubisoft Connect error on Linux

I have now tried every proton available for Connect. I can’t even get a ubi connection error page.I have nosed around Glorious egg proton but am intimidated by it. It seems so complex.I read something about making a page(?) and putting GE into it.

I will yahoogle how to add GE to steam for Connect tonight .I guess I could do it through Lutris but there are so many options going that way I’d like to keep it as simple as possible. I have read rave reviews about Glorious egg so I just gotta do it.

Its simply wine-ge-custom in the aur.

Proton is much easier to manage in userspace with something like ProtonUp-Qt. That’s what I use. I also maintain protonup-qt in the AUR.

1 Like

I just meant on ‘how to install glorious eggroll’ … for folks that literally use it for nothing else and only need the one installed … then thats it.

Oh, forgot to mention wine-ge-custom (out of date) builds from source. No fun and very hard to maintain. I used to test a proton-native-something package and worked with the maintainer. He eventually gave up and deleted it.

I guess there’s also wine-ge-custom-bin–which is up to date.

I still stand by my preference of managing Proton-GE / lutris-GE-Proton / whatever in userspace. Note that in the screenshot above everything is installed by Lutris itself except for lutris-GE-Proton. I usually keep one old version around just in case.

Ok please remember I only have about 3 years in Mint and Manjaro is brand new to me.The easiest way to get connect to work is preferred.I think I enabled AUR in the add remove software app. What is userspace? Is proton up a separate app I install?
I’d like to get GE installed on steam as that will make it easier.All the different things people can adjust is overwhelming and confusing.

See User space and kernel space - Wikipedia

In this case, I was referring to the Proton installation being in one’s Home directory rather than installed to the system. Lutris keeps it’s runtimes in ~/.local/share/lutris/runtime/, for example.

The easiest way would be with ProtonUp-Qt like I mentioned above. Install it from Add/Remove Sotware as a Flatpak or AUR package.

I’ll let Liam explain the rest…

  • Load ProtonUp-Qt.
  • Make sure it’s set to Steam at the top and select to install GE-Proton.
  • Reload Steam to update the compatibility layer list.
  • In Steam:
    • Desktop: right click a game and go to Properties.
    • Steam Deck: find the game in your library, go to the little cog on the right and then select Properties.
  • Compatibility menu → Tick the box, select GE-Proton from the drop-down

GE-Proton 8-16 released with tweaks for Genshin Impact, Resident Evil and Wine upgrades | GamingOnLinux

1 Like

I get ‘a failure occurred in prepare,aborting’ message when I run protonup.Above that it says ‘line 21 patch: command not found’

Install patch

Or install base-devel that way you get everything for building packages from AUR

1 Like

I downloaded patch from add/remove app.Ran proton up and transaction completed. I’m now downloading GE but it says it’s installing on steam. Should I have it installed on Lutris like the screenshot earlier in this thread?

I downloaded all the GE protons and still get the 3 blinking wine de bugger error along with the Connect app almost starting.I used proton up and they appeared in Steam and Lutris after I downloaded them.I tried all 4 of the GE entries that showed up with protonup. (Neat progrum by the way.) :slightly_smiling_face:

You’re missing the prerequisites for using the AUR (Arch User Repository)

1 Like

I was able to find and apply the base-devel part .So I think I now have the prerequisites.But for the life of me I can’t remember my next step though. Thanks to all of you for the help.

I still have the 3 flashing wine de bugger windows and the connect app almost starts to run.Even though connect doesn’t launch I still learned a lot from this thread . I used the konsole and confirmed that patch and base devel components are applied.I was able to get GE proton to appear in steam so that’s progress I guess. It’s on to my next attempt to get connect to run on linux. Updates come all the time.