Two VPN/proxy levels for the system. Wireguard/OpenVPN and then next one (Shadowsocks?) - experience?


on Windows i had Wireguard or OpenVPN as a main system proxy and then on top of that i had Shadowsocks which i have used just for my web browsing (

Is there anyone who have experience with this (two levels of proxies, multiple proxies one for system other for app like web browser). I am a beginner in Manjaro, XFCE.

Maybe you are not using Shadowsocks, but i have found it is doable on Manjaro:

1 - OR electron-ssr-x.x.x.pacman
2 - Shadowsocks - ArchWiki
3 - How can i do wide system proxy xfce

Regarding Wireguard, i am in early stage of using it. I activated it in commands like:
sudo pacman -S wireguard-tools
cd /path/to/wg_conf_and_ovpn_client_files/
cp -p wg-client-name.conf wg0.conf
nmcli connection import type wireguard file wg0.conf

Then internet stopped working (i was using OpenVPN). I had to disable WG service ( systemctl disable wg-quick@wg0.service ; systemctl stop wg-quick@wg0.service )
I will have to discover what is wrong.

I have not yet tried second level proxy like Shadowsocks. Do you have any ideas how to go about that second level proxy? Thank you

As far as I know shadowsocks provides a SOCKS proxy, and thus it shouldn’t interfere with lower level VPNs (such as Wireguard, OpenVPN).

1 Like

Are you running your own VPS or using a paid VPN service?

I have setup my system with multiple proxies using v2ray. Using this, you have the ability to create several local https/socks5 listeners and route them to several types of upstream servers. It’s aimed at Chinese users, so it doesn’t natively support protocols like ovpn/wireguard which are easily detected and blocked in China, but can be configured.

More info here:

own VPS server for WG, OVPN and SS…

@pobrn was right, shadowsocks apparently works as a second level proxy.

sudo pacman -S shadowsocks-libev shadowsocks-qt5
From Manjaro menu, type shadow and click the SS gui app and add your SS connection configs (got from server or server provider) in it. Make the app to start at boot and set one connection to autoconnect.