Tuxedo InfinityBook Pro 14 Gen 8 Intel Iris Xe + NVIDIA GeForce RTX 3050

I’ve got a TUXEDO InfinityBook Pro 14 Gen 8, with the TUXEDO OS preinstalled. The laptop has an integrated Intel Iris Xe and an NVIDIA GeForce RTX 3050 6GB.
Everything worked smoothly and quite well, but the OS is Ubuntu based and I started to have too many problems in configuring some software which is only available as a flatpack (not to mention language/locale problems, which I could not debug even after reading several posts about it).

As a Manjaro user since 2016, I decided to switch to it, especially after being told by the customer service that it should work fine after installing TUXEDO’s software and drivers provided by the Manjaro’s official repos and AUR.

However, I’m currently facing several issues, the most significant of which is related to the graphics card. I am unable to adjust the screen resolution or scale factor. Every time I try to do it, I get a black screen, and the only solution is to reboot via a TTY.

List of installed video card drivers (obtained via mhwd -li in the terminal):

Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
     video-modesetting               2020.01.13       true                 PCI
video-hybrid-intel-nvidia-prime      2023.03.23       false                PCI

Warning: No installed USB configs!

My hardware configuration shows the following:

And the output of glxinfo | grep renderer is

OpenGL renderer string: NVIDIA GeForce RTX 3050 6GB Laptop GPU/PCIe/SSE2

I suppose this command lists the graphics card used by default, right? Shouldn’t it be Intel?

In addition, TUXEDO Control Center does not show any info related to the NVIDIA GPU, and it used to do when I was using TUXEDO OS:

I have already installed the tuxedo-drivers-dkms package.
How can I properly configure the graphics card?
[I have other concerns, but this is the most relevant at the moment.]

Details about my system obtained with inxi -Fazy:

  Kernel: 6.7.0-0-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.7-x86_64
    root=UUID=d389c6f1-9bfe-4eff-a4c9-4964e7d6f10d rw rootflags=subvol=@ quiet
    splash udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: TUXEDO product: TUXEDO InfinityBook Pro Gen8 (MK2)
    v: Standard serial: <superuser required>
  Mobo: NB02 model: PH4PG31 v: Standard serial: <superuser required>
    UEFI: American Megatrends LLC. v: N.1.10A06 date: 09/25/2023
  ID-1: BAT0 charge: 66.5 Wh (67.0%) condition: 99.2/99.2 Wh (100.0%)
    volts: 15.9 min: 15.5 model: standard type: Li-ion serial: <filter>
    status: discharging
  Info: model: 13th Gen Intel Core i7-13700H bits: 64 type: MST AMCP
    arch: Raptor Lake gen: core 13 level: v3 note: check built: 2022+
    process: Intel 7 (10nm) family: 6 model-id: 0xBA (186) stepping: 2
    microcode: 0x411C
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 449 high: 846 min/max: 400/4800:5000:3700 scaling:
    driver: intel_pstate governor: powersave cores: 1: 400 2: 400 3: 400 4: 400
    5: 400 6: 400 7: 400 8: 400 9: 400 10: 400 11: 598 12: 400 13: 400 14: 750
    15: 400 16: 846 17: 400 18: 400 19: 400 20: 400 bogomips: 116780
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Enhanced / Automatic IBRS, IBPB: conditional,
    RSB filling, PBRSB-eIBRS: SW sequence
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] vendor: Tongfang Hongkong
    driver: i915 v: kernel arch: Gen-13 process: Intel 7 (10nm) built: 2022+
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:a7a0 class-ID: 0300
  Device-2: NVIDIA GN20-P0-R-K2 [GeForce RTX 3050 6GB Laptop GPU]
    vendor: Tongfang Hongkong driver: nvidia v: 545.29.06
    alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current (as of
    2023-11; EOL~2026-12-xx) arch: Ampere code: GAxxx process: TSMC n7 (7nm)
    built: 2020-2023 pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16
    ports: active: none empty: DP-3 bus-ID: 01:00.0 chip-ID: 10de:25ac
    class-ID: 0300
  Device-3: SunplusIT FHD Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-6:2 chip-ID: 2b7e:c757
    class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.10 compositor: kwin_x11 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2880x1800 s-dpi: 75 s-size: 978x611mm (38.50x24.06")
    s-diag: 1153mm (45.4")
  Monitor-1: eDP-1 mapped: eDP-1-1 model-id: CSO 0x140c built: 2021
    res: 2880x1800 hz: 90 dpi: 242 gamma: 1.2 size: 302x188mm (11.89x7.4")
    diag: 356mm (14") ratio: 16:10 modes: 2880x1800
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
    drv: nvidia x11: drv: nvidia inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3050 6GB Laptop
    GPU/PCIe/SSE2 memory: 5.86 GiB
  API: Vulkan v: 1.3.274 layers: 1 device: 0 type: discrete-gpu name: NVIDIA
    GeForce RTX 3050 6GB Laptop GPU driver: nvidia v: 545.29.06
    device-ID: 10de:25ac surfaces: xcb,xlib
  Device-1: Intel Raptor Lake-P/U/H cAVS vendor: Tongfang Hongkong
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
    bus-ID: 00:1f.3 chip-ID: 8086:51ca class-ID: 0403
  Device-2: NVIDIA vendor: Tongfang Hongkong driver: snd_hda_intel v: kernel
    pcie: gen: 4 speed: 16 GT/s lanes: 8 link-max: lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:2291 class-ID: 0403
  API: ALSA v: k6.7.0-0-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Raptor Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:51f1 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
    speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:3 chip-ID: 8087:0033
    class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Local Storage: total: 3.64 TiB used: 57.15 GiB (1.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 990 PRO 4TB
    size: 3.64 TiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 0B2QJXG7 temp: 27.9 C
    scheme: GPT
  ID-1: / raw-size: 3.64 TiB size: 3.64 TiB (100.00%) used: 57.14 GiB (1.5%)
    fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 3.64 TiB size: 3.64 TiB (100.00%)
    used: 57.14 GiB (1.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 3.64 TiB size: 3.64 TiB (100.00%)
    used: 57.14 GiB (1.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  Alert: No swap data was found.
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: nvidia temp: 38 C
  Fan Speeds (rpm): N/A
  Processes: 426 Uptime: 1h 25m wakeups: 0 Memory: total: 32 GiB note: est.
  available: 31.09 GiB used: 7.75 GiB (24.9%) Init: systemd v: 255
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1266 libs: 358 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.2.21 running-in: konsole inxi: 3.3.31

Since the new version, this has also been the case for me.

tuxedo-tomte (2.14.0) jammy; urgency=medium

  • added disablegucfix for TUXEDO InfinityBook 14/16 Gen8 with boardnames:
    PH4PRX1_PH6PRX1, PH4PG31, PH6PG01_PH6PG71

add i915.enable_guc=2 to Kernel Commandline

I run the same system - albeit without - Nvidia.

I suggest you log into your tuxedo account and navigate to downloads.

Then find firmware section. You will note there is two distinct firmwares - one using only Iris and one when Nvidia is installed. Please compare the versions - you may need to update the firmware.


Tuxedo packages

Possibly related

Other thoughts

As I recall there has been a recent topic on the size of initrd caused by new Nvidia drivers added.

Perhaps those drivers need kernel arguments to work?

I found in the tomte source references to nvidia kernal arguments but I have no means of testing - so I don’t know if they are related.

For your reference


Thanks for your message.

The section is empty, I suppose because the system was up to date just before I installed Manjaro.
I’ll check the parameters you suggested.

@linux-aarhus, I realise you’re part of Manjaro’s team. It would be interesting to develop synergies with TUXEDO to fine-tune Manjaro for their machines. Are there any plans for this?

That is strange - I you need to be logged into your account to see the downloads.

I use Tuxedo a Tuxedo InfinityBook Pro 14 gen8 and I have orderd the Tuxedo Pulse gen3 as AMD has grown on me.

At one point I saw that Tuxedo offered Manjaro preinstalled so there must have had some dealings with Tuxedo. I don’t know where it stands as of now - nor do I know of any future dealings.

I am part of Manjaro Community Team and as such I am not participating in anything outside the community.

I have personal interest in adding the necessary tweaking, but the in-house Tuxedo tool is exclusively for their Tuxedo OS and other supported OS.

This does not include Manjaro - other than the guides on the tuxedo web.

Other than my personal projects - I don’t know.

1 Like

I am, but I can’t see anything other than the section title and the footer…

That’s a pity. The computers look pretty good and I’d like to see Manjaro have the same level of performance on those machines as TUXEDO OS. Perhaps we can achieve this if the community continues to share their solutions as they find them.

I can say that My Tuxedo running Manjaro is better than using the Tuxedo OS.

I did choose my Tux based on the low power consumption when excluding the Nvidia GPU - also knowing that Nvidia and Linux is a sub optimal combo.

Just a thought
You are aware that to make the tuxedo drivers work - as they are based on dkms - you need headers for your kernel and dkms - right?

Honestly, I didn’t know. Unfortunately, my knowledge of Linux/Arch/Manjaro hasn’t reached that point yet. What should I do to install them or how should I proceed?

That’s precisely what I’d like to achieve.
The TUXEDO team got back to me, giving me some basic tips and saying that Manjaro is not an officially supported distribution. So if I want to stick with Manjaro, I’ll have to do it on my own.

Since we have the same computer, you wouldn’t be able to help me or point me to some sources of information where I can achieve the same level of performance as yours?
My only interest in the Nvidia graphics card is for prototyping machine learning models, so I can perfectly well have it switched off by default and only switch it on to run specific code.

can you check that onevpl is installed ?

pacman -Qs onevpl
pacman -Qs onevpl-intel-gp

OK, I found your post about kernels/headers/dkms. I installed the headers for my kernels (6.5, 6.6, and 6.7), and reinstalled TUXEDO Control Center and the TUXEDO drivers.
One difference stands out: Control Centre now shows more information about the CPU and other options have become available (keyboard back-light and battery charging options, for example).
However, I still can’t change the screen resolution.

onevpl yes, onevpl-intel-gpu no. I installed it.
Output of pacman -Qs onevpl:

local/libvpl 2.10.1-1
    Intel Video Processing Library
local/onevpl-intel-gpu 24.1.1-1
    oneVPL runtime implementation for Intel GPUs (Tiger Lake and newer)

I restarted the computer and, as before, I still can’t change the screen resolution.

I had to install dkms for the drivers to work.
What say

dkms status

Just a thought that came to me … last night

Usually the iGPU is used but as Tuxedo provides customized firmware - it is entirely possible that systems with dGPU has been configured to use that.

Do you have somewhere in the firmware an option to prioritise the primary GPU?

I created topic to collect what we know - [How To] Configure your Tuxedo Laptop

1 Like
tuxedo-drivers/4.0.3, 6.5.13-7-MANJARO, x86_64: installed
tuxedo-drivers/4.0.3, 6.6.10-1-MANJARO, x86_64: installed
tuxedo-drivers/4.0.3, 6.7.0-0-MANJARO, x86_64: installed

It seems they are installed.

I had a look and no, I don’t.

This is gold. :coin: Thanks a million!

I have followed the steps you described in your [How To]. Everything seems to be working now, except changing the resolution of the video card.

I had optimus-manager and optimus-manager-plasma installed. I removed them and defaulted to envycontrol. Now, the output of glxinfo | grep renderer is

    GLX_MESA_copy_sub_buffer, GLX_MESA_gl_interop, GLX_MESA_query_renderer, 
    GLX_MESA_copy_sub_buffer, GLX_MESA_gl_interop, GLX_MESA_query_renderer, 
Extended renderer info (GLX_MESA_query_renderer):
OpenGL renderer string: Mesa Intel(R) Graphics (RPL-P)

I have tried both “hybrid” (currently selected) and “integrated” in the Optimus GPU Switcher, but the results are the same, i.e., no way to change the resolution of the video card.

I am considering reinstalling Manjaro, but I would rather not do that and find a solution…

Hmm - I don’t know - perhaps the resolution is a limitation of the Omnia display.

I tried to change resolution got a flickering screen - fortunately Plasma reset after 15s of non-application.

You should be able to apply scaling though - again - I am at loss since your system is a dual-gpu and mine is Iris only.

In my mkinitcpio.conf I have added

MODULES=(i915 nvidia nvidia_modeset nvidia_uvm nvidia_drm)

you can try that

Unfortunately, it didn’t work.

This might seem to indicate that Manjaro cannot currently handle this type of system well. In fact, I found that I could not change the screen resolution when I booted Manjaro from the live USB stick before installing. At that point I was hoping to find out after the installation.
I’m afraid I’m going to have to go back to TUXEDO OS, at least for a while, until a solution to this problem is found.

Not the best solution in my case because I use an external monitor and things get huge there.

Just for information: I tried two other Arch-based distributions using their live USB keys - EndeavourOS and CauchyOS. Both had the same symptoms I reported here, i.e., I could not change the screen resolution. Also, neither was able to start X using the default drivers/configuration. To get to the Plasma desktop, I had to select the option corresponding to the Nvidia drivers, just like I did when I installed Manjaro.

So, it seems that Arch-based distributions are currently unable to handle hybrid Intel Iris Xe + Nvidia RTX 3500 systems out of the box. That’s a shame because, on the one hand, it is perfectly possible (as TUXEDO OS proves) and, on the other hand, although I’m not an Nvidia fan for the same reasons as most of Linux users, these cards have become important in the field of machine learning in recent years. Therefore, it would be nice to at least be able to use the Intel video card as the default, while switching on and using the Nvidia GPU only for specific tasks, such as training ML models. Hopefully this will soon be possible in the Arch world out of the box, or at least without too much fuss.

It is a mistake to buy a laptop with switchable GPU then use it for machine learning.

I don’t know how it will work but you could remove the switchable GPU drivers. Then install video-linux and after you get that working install video-nvidia.

This is likely to make your system use the iGPU and you can use the dGPU for the task you created it for.

But if I recall correct Nvidia has some built-in limitations when it comes to run software on the GPU because so many used the cards for crypto-mining instead of gaming.

Can you elaborate a bit on this, please? I’ve seen a lot of people do this, mostly Windows users. It is very common to use the GPU for prototyping models, before full training on clusters.