Timeshift not creating automatic backups

I am having a problem with the automatic backups on timeshift, they are not been created automaticly, even tough i have set up for it to backup every day. I’m using the Gnome version, and the backups are stored on a secondary drive.
Thanks :slight_smile:


maybe check the logs here:

ls /var/log/timeshift/

It appears to be a issue with crontab

[16:20:47] crontab -l
[16:20:47] Failed to read cron tab
[16:20:47] crontab -l
[16:20:47] Failed to read cron tab
[16:20:47] Cron task exists: /etc/cron.d/timeshift-hourly
[16:20:47] Main: save_app_config()
[16:20:47] SnapshotRepo: available()
[16:20:47] is_available: ok
[16:20:47] App config saved: /etc/timeshift.json
[16:20:47] SnapshotRepo: load_snapshots()
[16:20:47] SnapshotRepo: available()
[16:20:47] is_available: ok
[16:20:47] SnapshotRepo: load_snapshots()
[16:20:47] SnapshotRepo: check_status()
[16:20:47] SnapshotRepo: available()
[16:20:47] is_available: ok
[16:20:47] SnapshotRepo: has_snapshots()
[16:20:47] SnapshotRepo: has_space()
[16:20:47] Device: get_disk_space_using_df(): 1
[16:20:47] no snapshots
[16:20:47] Snapshot device: '/dev/sda1'
[16:20:47] Snapshot location: /run/timeshift/backup
[16:20:47] No snapshots on this device
[16:20:47] First snapshot requires: 40,6 GB
[16:20:47] Status: NO_SNAPSHOTS_HAS_SPACE

crontab -l states that there is no crontab for my user

Timeshift don’t find any snapshots. What did you change since last snapshot?

Nothing, i never created a manual snapshot, and the system never did it automatically. I just followed the wizard and left it alone, thinking it had set up properly (it’s a fresh install, 3 weeks old)

And i guess that is the problem :slight_smile: I made a manual snapshot and then it works flawless.

Maybe not enough space available?

df -h

I have 111Gb of space on the drive. I’m gonna create a manual snapshot and see if it works after that :slight_smile:

Since there wasn’t clear answer, I want to put my solution in here (also this topic is the first link when searching “timeshift do not create backup manjaro” so I think there must be some answer.)
Issue really was with this error:

[16:20:47] crontab -l
[16:20:47] Failed to read cron tab

By some reason my system (that I installed yesterday) didn’t start cronie service, so I enabled it via systemctl:

systemctl start cronie.service

And that worked for me!

Since I enabled boot snapshot, I rebooted PC, waited 10 minutes and snapshot was successfully created. Hope it will be helpful for someone.

1 Like

Good morning,
On a fresh install, I had the same problem. I have activate the cronie service. You can chck it with
systemctl list-unit-files --type=service
and activate it with
sudo systemctl enable cronie.service
And I have generated the crontab for root user with
crontab -e

Best Manjaro regards

I was just wondering how timeshift could possibly be working on a systemd system that no longer uses cron, when it’s not creating or enabling timer files. looks like snapper is the better option all around at least if you’re using btrfs. I wonder if any of the rsync options have systemd timer’s.