Timeshift not scheduling

I have created a schedule for Timeshift & run the first backup, but snapshots are not being created automatically.
I checked another topic & followed the advice, but still snapshops do not auto-run.

I am using Manjaro 21.1. & Gnome 40.3, Timeshift 21.06

cronie.service is running, I started it following the advice in the other topic, but the timeshift logs say

[08:18:10] crontab -l
[08:18:10] Failed to read cron tab
[08:18:10] Cron task exists: /etc/cron.d/timeshift-hourly
[08:18:10] Main: save_app_config()
[08:18:10] SnapshotRepo: available()
[08:18:10] is_available: ok
[08:18:10] App config saved: /etc/timeshift/timeshift.json
[08:18:10] SnapshotRepo: load_snapshots()
[08:18:10] loading snapshots from ‘/run/timeshift/backup/timeshift/snapshots’: 2 found

cron seems to be running:

systemctl status cronie.service :heavy_check_mark:
● cronie.service - Periodic Command Scheduler
Loaded: loaded (/usr/lib/systemd/system/cronie.service; enabled; vendor pr>
Active: active (running) since Wed 2021-08-25 08:02:55 JST; 12min ago
Main PID: 384 (crond)
Tasks: 1 (limit: 23837)
Memory: 548.0K
CPU: 2ms
CGroup: /system.slice/cronie.service
└─384 /usr/bin/crond -n

8月 25 08:02:55 Sulaco crond[384]: (CRON) STARTUP (1.5.7)
8月 25 08:02:55 Sulaco crond[384]: (CRON) INFO (Syslog will be used instead of>
8月 25 08:02:55 Sulaco crond[384]: (CRON) INFO (RANDOM_DELAY will be scaled wi>
8月 25 08:02:55 Sulaco systemd[1]: Started Periodic Command Scheduler.
8月 25 08:02:55 Sulaco crond[384]: (CRON) INFO (running with inotify support)

ls /etc/cron.d
0hourly timeshift-hourly

if i run timeshift --check then it creates a snapshot & tags it as DW, but it wont do it without my input.

The DW shapshop was created when I ran timeshift --check otherwise nothing is created the past 10 days.

crontab -l
no crontab for rico
sudo crontab -l
[sudo] password for rico:
no crontab for root

So for some reason Timeshift is not putting the schedule into cron? What to do?

I made a new file using sudo crontab -e and it seems this solved the problem.
(To save the new empty file when nano opened I just pressed spacebar and backspace so the file would be ‘‘modidied’’ and I could save it.)
I’m not sure if this is the ‘‘right’’ way to do it as I’m pretty new here but I guess it works for now.

1 Like

I noticed that sudo crontab -e was mentioned in the other topic, but after doing that I saw a tmp file would be created with a random name. I didn’t know what content, filename or location to save it, so I simply exited without saving. Did you just leave it as default name & location in /tmp?

Yeap. I didn’t change any defaults.

Well, its ‘magically’ begun working correctly now. :grin:
It seems to have started making snapshots automatically some point after I ran timeshift --check in the terminal. or, simply by typing sudo crontab -e & exiting (I haven’t done anything else since that, perhaps it was just a wake up call - ha ha)

The crontab -l Failed to read crontab error still shows up in the log & I still have no user or root crontab.

1 Like

Thanks. I had the same problem and the solution helped.

Sure, that works :sweat_smile:

Sure enough, sudo timeshift --check worked for me.

1 Like