Timeshift: Why is Cronie not enabled given bundled software requires it?

Hey all, newish Manjaro user here, and consider myself between a beginner and Intermediate Linux user. But this particular issue is mind-boggling: I spent a decent chunk of yesterday–having quickly set up Timeshift schedule–trying to get it to make a snapshot. I managed to stumble upon a forum comment or two which stated that the cronie service/daemon wasn’t enabled and hence snapshots would not happen.

Wouldn’t it be easier enough to enable it out of the box, given that Timeshift is a bundled Manjaro s/w package?

Or if you really don’t want to enable cronie why not modify the Timeshift package to add a check to see if it’s enabled and something like a tick-box to then enable it?

I know Linux ain’t Windows, but why make it harder than it needs to be?

EDIT: just to confirm–once I enabled cronie it worked.


  • K.I.S.S.
  • Enabling scheduled backups is a user preference
  • “Why is Cronie enabled? I don’t use it!”

TeejeeTech is the author of Timeshift, not Manjaro. Open an issue (if there isn’t already one) and ask.


I figured that would be the response given. But also I can understand it. Scheduled backups might be a user preference but backups in general are simply standard best practice. The scheduling of them is the way to make sure you don’t forget to do them. So to me, it’s something any serious user would do.

OK. I thought that it could be added upstream (if that’s the correct term) but having said that I imagine the Manjaro team have a lot of work to do and you’re right, it’s better if the developer does it. I will follow that line of inquiry, thanks. :slight_smile: It just seems unfortunate to ship something that doesn’t work out of the box.

I don’t know if you can say that.

Some devs has a preference for btrfs others do not.

Some has extensive knowledge of btrfs but the installer defaults to ext4 - as this is the most widely used filesystem on Linux workstations and most servers probably with the exception of very large SANs.

Sorry if I am mistaken (now removed from original so others don’t think that’s the case). I was recently trying also Fedora and it may have been that it was that distro I’m thinking of.

Id like to notify you that the No-Backup-Crew formally disagrees. :smiling_imp:

I consider myself a serious-enough user … and I have never used backup software on my personal machines.

In any case though… its about choice. If you want backups… set them up. If you dont… dont.
Either choice should result in its desired outcome.

While backup is recommended - even by hardcore no-backup-users like myself - a least if you are low on space and want to rearrange your storage - there will always be choices.

And because a Timeshift backup needs a profile of what to backup and especially where to backup to - it makes little to no sense enabling a cron daemon when there is no jobs to run.

By default, our timeshift configuration takes snapshots whenever package is installed, updated or removed. I don’t use the scheduled backup functionality myself, so I assumed timeshift used systemd timers and not crony. Given the circumstances, I think enabling crony by default might make sense.

I’ve updated the post install / upgrade script to notify if the cronie service is not running.

TimeShift scheduled backups require the cronie.service to be running.
systemctl enable --now cronie.service


This seems like a good compromise for the moments. Ideally crony should be enabled by timeshift, but teejeetech is really busy, so it might take a while. Unless we submit a patch… Does anyone in the team know vala? I suspect @guinux might, but he is usually busy too.

I get what you’re saying. But basically a systemd based schedule would be the preferred/smoother option for better marrying Timeshift with Manjaro?

That would definitely make using the software a lot more straight-forward and accessible.

So the system does snapshot whenever a package is installed? Where are they kept? Because for me I couldn’t get TimeShift to create a snapshot, manually or automatically until I enabled the service and rebooted.

That should be really helpful I believe. Thanks!