Thinkpad T14 Gen 1 - TLP battery thresholds

Hi everyone!

I just got a new Thinkpad T14 Gen1 (AMD) and am trying to set the battery start/stop thresholds. I’ve installed the latest TLP and acpi_call packages. I’m running kernel 5.10. For some reason the battery thresholds are not working. I’ve defined 40% low and 50% high but the battery is always at max charge.

Any ideas on this? Thanks!

<-- TLP 1.3.1 --------------------------------------------

+++ System Info
System = LENOVO ThinkPad T14 Gen 1 20UES1D600
BIOS = R1BET36W(1.05 )
Release = “Manjaro Linux”
Kernel = 5.10.0-1-MANJARO #1 SMP PREEMPT Mon Nov 2 01:03:22 UTC 2020 x86_64
/proc/cmdline = BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=707241bb-b4f6-4215-936e-786a721b8b1f rw quiet apparmor=1 security=apparmor udev.log_priority=3 ipv6.disable=1
Init system = systemd
Boot mode = UEFI

+++ TLP Status
State = enabled
RDW state = not installed
Last run = 10:20:46 PM, 309 sec(s) ago
Mode = AC
Power source = AC

+++ Battery Features: Charge Thresholds and Recalibrate
natacpi = active (data, thresholds)
tpacpi-bat = active (recalibrate)
tp-smapi = inactive (ThinkPad not supported)

+++ ThinkPad Battery Status: BAT0 (Main / Internal)
/sys/class/power_supply/BAT0/manufacturer = LGC
/sys/class/power_supply/BAT0/model_name = 5B10W139
/sys/class/power_supply/BAT0/cycle_count = 1
/sys/class/power_supply/BAT0/energy_full_design = 50500 [mWh]
/sys/class/power_supply/BAT0/energy_full = 50500 [mWh]
/sys/class/power_supply/BAT0/energy_now = 48290 [mWh]
/sys/class/power_supply/BAT0/power_now = 0 [mW]
/sys/class/power_supply/BAT0/status = Unknown

/sys/class/power_supply/BAT0/charge_start_threshold = 40 [%]
/sys/class/power_supply/BAT0/charge_stop_threshold = 50 [%]
tpacpi-bat.BAT0.forceDischarge = 0

Charge = 95.6 [%]
Capacity = 100.0 [%]

Hello,

Is a RC kernel. Please use a different one, see some suggestions here:


Not quite sure what is the difference between T14 and T14s, but here are some hints to increase battery life

Hi! yes I know that it’s an RC kernel, but I decided to try it because was having the same issue under 5.8. Additionally this newer kernel should included some specific optimizations for this laptop as I understand. Thanks for the link! I’m reading it right now.

Just for the record: there was no issue here. You just need to discharge the battery to a lower value than the defined start threshold, then plug in. That will bring your battery to the defined thresholds. Everything is working as expected now:

+++ ThinkPad Battery Status: BAT0 (Main / Internal)
/sys/class/power_supply/BAT0/manufacturer                   = LGC
/sys/class/power_supply/BAT0/model_name                     = 5B10W139
/sys/class/power_supply/BAT0/cycle_count                    =      1
/sys/class/power_supply/BAT0/energy_full_design             =  50500 [mWh]
/sys/class/power_supply/BAT0/energy_full                    =  50500 [mWh]
/sys/class/power_supply/BAT0/energy_now                     =  27510 [mWh]
/sys/class/power_supply/BAT0/power_now                      =      0 [mW]
/sys/class/power_supply/BAT0/status                         = Unknown

/sys/class/power_supply/BAT0/charge_start_threshold         =     50 [%]
/sys/class/power_supply/BAT0/charge_stop_threshold          =     55 [%]
tpacpi-bat.BAT0.forceDischarge                              =      0

Charge                                                      =   54.5 [%]
Capacity                                                    =  100.0 [%]