Theme issue with manjaro-kde-settings

Same issue here, grey (almost white) toolbars in Dolphin, Libre Office, and other apps when using dark theme right after upgrading manjaro-kde-settings.

Have you tried @LordTermor suggestion to remove /etc/xdg/kdeglobals and reboot?
That worked for me.

The active window titlebar color issues seems to have been resolved, however it seems that I still have some custom color settings that are not being used. The main one that I notice is when I select an icon on the desktop. I set it to display a red color behind the selection but it instead is using a black color which appears invisible against my wallpaper. I confirmed that it was, in fact, using black when I set the wallpaper to a single color which was light. Similarly, the color being used when I hover over a button on the taskbar or an item in the Application Launcher and when I select a button on the taskbar is greenish when I believe that same red setting was applying before.

This worked for me:

this didn’t solve the problem in my case

i renamed ~/.config/kdeglobals, ~/.kde4 and /etc/xdg/kdeglobals and rebooted to what is apparently the default theme, breeze, and was not able to change titlebar color in a copy of the theme from the settings UI

related issue: Active window title bar color not changing - #12 by jeramboquai

another possible issue with the last manjaro-kde-settings update:

  1. open settings
  2. click ‘appearance’ menu item
  3. click ‘application style’ menu item

a dialog appears: “the settings of the current module have changed. do you want to …”

this is without having made any changes - the dialog appears most of the time, but not necessarily every time

1 Like

and another possible issue with the last manjaro-kde-settings update:

settings > appearance > splash screen: i can set it to ‘none’, but the change isn’t saved (click on another menu item, then back, and change is lost)

1 Like

I’ve got it: KDE global settings work really strange. Will try fix it a bit later as well.

After updating now, everything is fixed for me. :white_check_mark:

not here - i updated and the behavior is same as before - shall i try renaming ~/.config/kdeglobals, ~/.kde4 and /etc/xdg/kdeglobals again?

I just noticed this thread but I had an issue with my colors of windows (on KDE Testing branch), I just reapplied my color scheme and it fixed it, but I updated the system too today so I’m not sure what did what.

@majik, have you rebooted? If yes, I would try to rename ~/.config/kdeglobals, ~/.kde4 and /etc/xdg/kdeglobals for the moment.

yes sir i did reboot before - and i just now dumped those 2 files and 1 folder and rebooted again and the behavior is the same

running manjaro-kde-settings v20210813-1

Sounds weird, please post you .config/kdeglobals and screenshot with Breath2 (without light or dark) colorscheme applied.

@LordTermor - each time i deleted the files and rebooted, when i opened settings no global theme is selected by default, but i always selected ‘dark theme’ and that seems to default to breeze, not breath2, however the problem of not being able to change titlebar color is present in 2 or 3 of the dark themes i tried

please advise on how you want me to proceed

Try to create a new user and check if problem persists.

same thing

created a fresh acct and went to straight to settings > appearance > colors and couldn’t change titlebar color

Uhm, I’m out of ideas. Post /etc/xdg/kdeglobals here (although you said you’ve tried removing it…)

that’s odd - there is none

last time i renamed it and rebooted a new one was created i thought - not this time

nope, it’s a part of manjaro-kde-settings package