Text not visible in qt applications

I can barely see text in certain areas of qt based applications (see screenshots). I think I’ve first started facing this issue after Qt got upgraded to 5.15.1. I thought it would go away, so I didn’t bother much.

But today I installed virtual box and I can’t ignore this issue any longer, I can barely see the menus and the main text on the UI. I’ve tried fiddling with Kvantum manager but to no avail, infact I can barely see text on Kvantum manager itself! Any help is appreciated. Thank you.


>>> inxi -Fazy                                                               
  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=56d77d09-dec0-4408-b59c-9e65207adba1 rw "acpi_osi=Windows 2020" 
  quiet apparmor=1 security=apparmor 
  resume=UUID=8a55e655-a595-4619-847e-091f12bb98da udev.log_priority=3 
  Desktop: GNOME 3.38.1 tk: GTK 3.24.23 wm: gnome-shell dm: GDM 3.38.2 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Notebook v: N/A 
  serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 84F8 v: 08.11 serial: <filter> UEFI: AMI v: F.29 
  date: 07/17/2020 
  ID-1: BAT0 charge: 42.3 Wh condition: 52.7/52.7 Wh (100%) volts: 12.0/11.6 
  model: HP Primary type: Li-ion serial: N/A status: Discharging 
  Device-1: hidpp_battery_0 model: Logitech Wireless Keyboard serial: <filter> 
  charge: 55% (should be ignored) rechargeable: yes status: Discharging 
  Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: DE 
  L2 cache: 9216 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 52815 
  Speed: 900 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 
  4: 900 5: 900 6: 900 7: 900 8: 901 9: 900 10: 900 11: 900 12: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
  driver: N/A alternate: nouveau, nvidia_drm, nvidia bus ID: 01:00.0 
  chip ID: 10de:1c8d 
  Device-3: Chicony HP Wide Vision HD type: USB driver: uvcvideo bus ID: 1-6:4 
  chip ID: 04f2:b56d 
  Display: x11 server: X.org 1.20.10 compositor: gnome-shell 
  driver: modesetting resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.2.3 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 3000 bus ID: 03:00.0 chip ID: 10ec:b822 
  IF: wlo1 state: up mac: <filter> 
  Local Storage: total: 585.00 GiB used: 126.25 GiB (21.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Samsung model: MZNLN128HAHQ-000H1 size: 119.24 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 3H3Q scheme: GPT 
  ID-2: /dev/sdb vendor: Crucial model: CT500MX500SSD1 size: 465.76 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 023 scheme: GPT 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 6060 bus ID: 00:17.0 chip ID: 8086.282a rev: 10 
  ID-1: / raw size: 145.27 GiB size: 142.49 GiB (98.09%) 
  used: 56.56 GiB (39.7%) fs: ext4 dev: /dev/sdb4 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb3 
  System Temperatures: cpu: 50.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 336 Uptime: 20m Memory: 7.58 GiB used: 2.04 GiB (27.0%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 11.0.0 Packages: 1558 
  pacman: 1555 lib: 337 flatpak: 0 snap: 3 Shell: Zsh v: 5.8 
  running in: gnome-terminal inxi: 3.1.08 
1 Like

same issue here.
I resolved it this way:

Open Kvantum
Select “Change/Delete Theme”
In the “Select a theme” box type KvGnomeDark
…Select a theme: KvGnomeDark
and press: “Use this theme”

Kvantum changed, you can read everything.
Start VirtualBox…should’ve been changed, too.

If you can’t see the “Use this theme” button,
Minimize Kvantum window…minimized you can see a bit more.


Sorry, I mean Press and Hold the Windows Key…you can see a bit more before you release the key switching to minimized view…

I encountered the same and managed to change the theme using qt5ct. You can have look at the link below for more detail.

weird background color

1 Like

Thanks, this worked! The press hold thingy helped me see a little, yes.

Thanks! Will try this out and reply if it works, I think this makes more sense because all the apps affected are qt based.

I stay with Kvantum…seems more powerful.
Be aware that you run into trouble when installing qt5ct.
Do not use the menu entry but start qt5ct in a shell:

$ qt5ct

After tried it out I removed it from my system
because of conflicting environment variables.
As a GNOME user I try to avoid QT Apps as much as possible anyway

I see. Cool, kvantum seems to work flawlessly, I’ll stick with it then. Thanks :slight_smile:

I installed, tried and removed qt5ct.
Removing qt5ct left behind things in the HOME directory.
$ rm -rf $HOME/.config/qt5ct
$ cat .profile | grep QT

Because I found qgnomeplatform 0.6.90 installed,
I changed the value.
$ vi .profile

see github QGnomePlatform

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.